Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

PYM Player 4: biblioteka i eksport do iPhone'a


  • Zaloguj się, aby dodać odpowiedź
130 odpowiedzi w tym temacie

#26 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 19 kwietnia 2010 - 23:16

Debug, panie, debug ;-) Dobra, znalazłem źródło problemu. Po włączeniu PYM Playera w preferencjach przy ścieżce do katalogu dla pobierania napisach jest '(wybrany wcześniej katalog z napisami jest niedostępny)'. Ustawienie go tam (zarówno przyciskiem 'Wyzeruj', który ustawia na '~/Documents/PYM Player - napisy' jak i przyciskiem 'Zmień', któremu podaję dowolnie wybrany katalog) sprawia, że funkcja pobierania napisów DZIAŁA, zarówno z menu Narzędzia, jak i z Findera. Po wyłączeniu PYM Playera i ponownej próbie się wywala - i przy szukaniu z Findera i z menu. Tak jakby nie zapisywał tego ustawienia poprawnie. Przy okazji: napisałeś, że ściąganie z Findera olewa ten ustawiany katalog, czyli powinno działać. Nie olewa - kiedy już ściąga, wrzuca je _zarówno_ w ten katalog, co film jak i do tego katalogo ustawialnego, czyli crashe tak naprawdę w obu przypadkach są identyczne i spowodowane imho brakiem tej ścieżki zapamiętanej. Opcja 'wyzeruj ustawienia', ta globalna, nie pomaga. Następnym krokiem było usunięcie PYM Playera i zainstalowanie go na czysto: - usunąłem AppCleanerem aplikację i dwa pliki .plist w ~/Library/Preferences/ - usunąłem z palca ~/Library/Application Support/Biblioteka\ PYM\ Playera.pymlib - usunąłem z palca ~/Library/Caches/com.pym.PYM\ Player - pobrałem .dmg - zainstalowałem 'standardowo' Po uruchomieniu ścieżka do katalogu z napisami jest ustawiona na tę '~/Documents/PYM Player - napisy' i działa ściąganie i z 'Narzędzia' i z Findera. Po zamknięciu programu i odpaleniu go na nowo ścieżka się znowu gubi i problem wraca. Następny krok: test na innym użytkowniku. Nie pomaga. Następny krok: test na innym użytkowniku z systemem po polsku ;-) Nie pomaga. Myślę, że nie jest to problem lokalny ze złym plikiem preferencji albo uprawnieniami, bo: a) inne aplikacje poprawnie zapisują swoje ustawienia, co wyklucza problem globalny; B) jeśli plik byłby uszkodzony, pomogłoby jego 'na chama' usunięcie, które wykonałem; c) nie działa na innym, świeżo założonym, userze. Logi podczas crasha: 1) kiedy odpalam z Findera przy _wyłączonym_ playerze: 4/20/10 12:41:55 AM [0x0-0x2233231].com.pym.PYM Player[58690] /Users/ftpd/Movies/flashforward.s01e15.720p.hdtv.x264\-immerse.mkv 4/20/10 12:41:55 AM [0x0-0x2233231].com.pym.PYM Player[58690] ???? 4/20/10 12:41:55 AM [0x0-0x2233231].com.pym.PYM Player[58690] ???? 4/20/10 12:41:55 AM [0x0-0x2233231].com.pym.PYM Player[58690] 0 4/20/10 12:41:55 AM [0x0-0x2233231].com.pym.PYM Player[58690] PYM_PLAYER_FORCE_QUIT:0 4/20/10 12:42:10 AM [0x0-0x2233231].com.pym.PYM Player[58690] PYM_PLAYER_FORCE_QUIT:0 (Spostrzeżenie: między jednym Force Quit a drugim mija kilkanaście sekund.) 2) kiedy odpalam z Findera przy _włączonym_ playerze: 4/20/10 12:43:25 AM [0x0-0x2235233].com.pym.PYM Player[58712] PYM_PLAYER_FORCE_QUIT:0 (Bez żadnych innych komunikatów, linia pokazuje się od razu.) 3) kiedy odpalam z menu Narzędzia: 4/20/10 12:44:55 AM [0x0-0x2236234].com.pym.PYM Player[58737] PYM_PLAYER_FORCE_QUIT:0 (Też beż żadnych innych komunikatów, ale ta linia pokazuje się z opóźnieniem.) 4) kiedy poprawiam ścieżkę z palca i ściągam napisy, w logach totalna cisza. ---- Mam nadzieję, że nie namieszałem za bardzo - podczas pisania tego postu kilka razy wpadały mi do głowy nowe pomysły, przez co edytowałem go naście razy, ale chyba nie jest źle i da się zrozumieć? ;-)

#27 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 20 kwietnia 2010 - 10:13

Mam nadzieję, że nie namieszałem za bardzo - podczas pisania tego postu kilka razy wpadały mi do głowy nowe pomysły, przez co edytowałem go naście razy, ale chyba nie jest źle i da się zrozumieć? ;-)


Da się, dzięki, to mi pomogło, chociaż nie włączyłeś dokładnego logowania, wtedy w tych logach
byłoby dużo więcej informacji.

Kolejny build: Download pymplayer401b81.zip from Sendspace.com - send big files the easy way — tym razem powinno być dobrze.

#28 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 20 kwietnia 2010 - 14:14

Włączyłem wchodząc w preferencje tak jak prosiłeś, z altem. Wtedy w ogóle pojawiała się opcja włączenia logowania, bez alta jej nie było. Mam _tylko_ te komunikaty. Zaraz zassam nową wersję i przeedytuję posta, czy pomogło. --- edit --- Pomogło. Wprawdzie po nadpisaniu wersji w /Applications nie było wpisu z katalogiem nadal (pewnie przez popsuty stary plik preferencji) po ustawieniu go ręcznie i ponownym włączeniu programu został zapisany i ściąganie działa. Uwagi, już kosmetyczne: 1) kiedy ściągam z Findera (z menu albo skrótem) w katalogu z filmem pojawiają się napisy .srt i .txt, natomiast dodatkowo kopia napisów .txt (podejrzewam, że tych 'wzorcowych', które przyszły z napiprojektu) zostaje w katalogu ustawionym w preferencjach jako ten do zapisywania napisów; 2) przy ściąganiu z menu Narzędzia w samym programie napisy są ściągane do tego ustawialnego katalogu i pojawia się pytanie, czy je 'skopiować' do katalogu z filmem. Nie lepsza byłaby opcja 'przenieść'?

#29 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 20 kwietnia 2010 - 16:16

Uwagi, już kosmetyczne:
1) kiedy ściągam z Findera (z menu albo skrótem) w katalogu z filmem pojawiają się napisy .srt i .txt, natomiast dodatkowo kopia napisów .txt (podejrzewam, że tych 'wzorcowych', które przyszły z napiprojektu) zostaje w katalogu ustawionym w preferencjach jako ten do zapisywania napisów;
2) przy ściąganiu z menu Narzędzia w samym programie napisy są ściągane do tego ustawialnego katalogu i pojawia się pytanie, czy je 'skopiować' do katalogu z filmem. Nie lepsza byłaby opcja 'przenieść'?


OK. Nowa kompilacja jest już na PYM i na Sendspace.

#30 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 20 kwietnia 2010 - 17:06

Super, dzięki. Poużywam z tydzień, może się całkiem przerzucę ;-)

#31 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 23 kwietnia 2010 - 00:52

Problemik: podczas oglądania filmu odpalany jest sub-proces mplayera (jeśli dobrze widzę) i w tym czasie nie ma możliwości wejścia w preferencje. Trzeba wyłączyć odtwarzanie i dopiero wtedy się da. To bug, czy feature? Jeszcze drobnostka: do przekodowania wymagany jest mencoder, który się ssie z pym.uce.pl 5 kB/s ;-) Przydałoby się go też na sendspace albo coś.

#32 macieks72

macieks72

  • 9 873 postów

Napisano 23 kwietnia 2010 - 01:01

Proszę bardzo, ode mnie.

Download mencoder.tar.gz from Sendspace.com - send big files the easy way

Taka kompilacja jeśli to ważne:
MEncoder dev-CVS-060307-04:23-4.0.1 (C) 2000-2006 MPlayer Team
Mac OSX static build for ffmpegX
CPU: Intel Pentium III Katmai/Pentium III Xeon Tanner (Family: 6, Stepping: 10)
FIXME:Hardenabling SSE and SSE2 without detection
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2


#33 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 28 kwietnia 2010 - 00:24

Nie no, ja sobie mogłem mencodera wziąć z dowolnego miejsca. Tak bardziej pod kątem przyszłych użytkowników, tych mniej doświadczonych, pisałem.

Btw. @Gregory, co sądzisz o możliwości usuwania filmu z biblioteki _razem_ z wywalaniem go fizycznie z dysku? Nie wiem, może jakiś skrót klawiszowy z altem/cmd? Robi mi się powoli burd^H^H^H^Hbałagan w ~/Movies, bo usuwam obejrzane odcinki z bilbioteki, a z dysku zapominam ;-)

---------- Wpis dodano o 01:24 ---------- Poprzedni wpis dodano o 00:10 ----------

Uuu, znalazłem buga! ;-)

@Gregory: z okazji faktu, że defaultowa czcionka nie podoba mi się wybitnie, zmieniłem sobie na inną (Verdanę, konkretnie, ale testowałem z innymi i też jest źle) i działało... do wyłączenia programu. Po ponownym włączeniu napisów (w dowolnym filmie) nie widać, trzeba znów w opcjach ustawić czcionkę (jakąkolwiek) i działa aż do wyłączenia ;-)

#34 yamcia

yamcia
  • 1 postów

Napisano 07 maja 2010 - 14:16

A ja z zapytaniem czy jest w planach obsluga AC-3 tak jak to robi movietime (czy tez quicktime oc zywiscie po odpowiednich modyfikacjach wlasciwosci audio systemu) ze na wyjsciu cyfrowym (w moim przypadku minimac) pojawia sie sygnal dolby digital.

#35 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 07 maja 2010 - 15:26

@Gregory, feature request ;-) Dałoby radę, żeby kategoria w bilbiotece pokazywała gdzieś ilość elementów? Trzymam sobie w 'Seriale' kilka kategorii z poszczególnymi tytułami, w których kilka jest pustych, bo jestem na bieżąco, kilka ma w środku filmy, bo mam zaległe. Takie pokazanie cyferki oszczędziłoby pamiętania, co wisi w kolejce, a co gotowe.

#36 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 07 maja 2010 - 23:54

Uuu, znalazłem buga! ;-)

@Gregory: z okazji faktu, że defaultowa czcionka nie podoba mi się wybitnie, zmieniłem sobie na inną (Verdanę, konkretnie, ale testowałem z innymi i też jest źle) i działało... do wyłączenia programu. Po ponownym włączeniu napisów (w dowolnym filmie) nie widać, trzeba znów w opcjach ustawić czcionkę (jakąkolwiek) i działa aż do wyłączenia ;-)


Mam też przyczynę ;-)
Otóż: po ustawieniu wybranego fonta w ~/Library/Preferences/pym.pymplayer4.preferences zapisuje się ścieżka, w moim przypadku /Library/Fonts/Verdana.ttf, po wyłączeniu Pym Playera jest ona tam sobie nadal. Jednak po ponownym uruchomieniu automagicznie zmienia się na /library/fonts/verdana.ttf, co w przypadku systemu na partycji case sensitive nie działa, no bo jak ;-)

Da radę poprawić, czy do następnej ewentualnej reinstalki i przejścia na nie- case sensitive muszę z palca za każdym odpaleniem przestawiać? ;-)

#37 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 10 maja 2010 - 06:57

@Gregory, feature request ;-)
Dałoby radę, żeby kategoria w bilbiotece pokazywała gdzieś ilość elementów? Trzymam sobie w 'Seriale' kilka kategorii z poszczególnymi tytułami, w których kilka jest pustych, bo jestem na bieżąco, kilka ma w środku filmy, bo mam zaległe. Takie pokazanie cyferki oszczędziłoby pamiętania, co wisi w kolejce, a co gotowe.


Mam to w planie, podobnie jak zapamiętywanie ostatnio odtwarzanego odcinka serialu, tak aby można było wygodnie kontynuować od kolejnego.

Mam też przyczynę ;-)
Otóż: po ustawieniu wybranego fonta w ~/Library/Preferences/pym.pymplayer4.preferences zapisuje się ścieżka, w moim przypadku /Library/Fonts/Verdana.ttf, po wyłączeniu Pym Playera jest ona tam sobie nadal. Jednak po ponownym uruchomieniu automagicznie zmienia się na /library/fonts/verdana.ttf, co w przypadku systemu na partycji case sensitive nie działa


Raport o błędzie, dokładna przyczyna plus sposób rozwiązania. Cudownie, lepiej być nie może ;)
Jasne, poprawię to.

A ja z zapytaniem czy jest w planach obsluga AC-3 tak jak to robi movietime (czy tez quicktime oc zywiscie po odpowiednich modyfikacjach wlasciwosci audio systemu) ze na wyjsciu cyfrowym (w moim przypadku minimac) pojawia sie sygnal dolby digital.


Mplayer teoretycznie ma taką możliwość, ja nie mam jak tego sprawdzić, ale czy zaznaczenie „Przekazuj dźwięk do wyjścia cyfrowego” w preferencjach dźwięku nie daje takiego właśnie efektu? Teoretycznie powinno.

Btw. @Gregory, co sądzisz o możliwości usuwania filmu z biblioteki _razem_ z wywalaniem go fizycznie z dysku? Nie wiem, może jakiś skrót klawiszowy z altem/cmd? Robi mi się powoli burd^H^H^H^Hbałagan w ~/Movies, bo usuwam obejrzane odcinki z bilbioteki, a z dysku zapominam ;-)


Też mi zaczyna tego brakować. Dodam.

Ostatnio nie miałem czasu się tym zająć, a teraz wyjeżdżam (chyba, że znowu wybuchnie jakiś wulkan na Islandii), więc do tych wszystkich poprawek wrócę dopiero pod koniec maja.

#38 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 10 maja 2010 - 10:03

Super, dzięki za feedback, czekam zatem ;-)

#39 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 29 maja 2010 - 00:14

Hop hop? ;-)

#40 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 30 maja 2010 - 14:24

Z okazji Międzynarodowego Dnia Bez Stanika — PYM Player 4.0.2 (kompilacja 83), a w niej:

- poprawka dotycząca obsługi systemów plików z rozróżnianiem wielkości liter,
- poprawki w obsłudze eksportu, m.in. dotyczące synchronizacji dźwięku z obrazem,
- poprawiony błąd, który uniemożliwiał wklejenie zaawansowanych parametrów eksportu za pomocą klawiszy Command-V,
- możliwość usuwania plików z filmami wraz z usuwaniem ich miniaturek z biblioteki (trzeba przytrzymać klawisz Opcja/Alt),
- plus drobne zmiany wewnętrzne, niewidoczne dla użytkownika.

Program do pobrania na PYM, adres w sygnaturce. Jest także kopia na SendSpace.

#41 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 30 maja 2010 - 21:24

Bosko, dziękuję ;-) Jeszcze tylko to wyświetlanie ilości elementów w grupie i wszystko, czego potrzebuję do szczęścia.

#42 Konrado

Konrado

  • 1 844 postów
  • SkądŚwidnica

Napisano 31 maja 2010 - 00:02

Wróciłem do poprzedniej wersji, gdyż nawet po odznaczeniu opcji pokazywania biblioteki, nadal się uruchamiała.

#43 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 02 czerwca 2010 - 09:30

Wróciłem do poprzedniej wersji, gdyż nawet po odznaczeniu opcji pokazywania biblioteki, nadal się uruchamiała.


OK, już poprawiam. Pewnie jeszcze dziś wieczorem będzie dostępna nowa kompilacja z poprawionym tym i kilkoma innymi błędami.

#44 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 04 czerwca 2010 - 14:57

Z okazji 35 urodzin Angeliny Jolie — PYM Player 4.0.2 (kompilacja 84), poprawiłem następujące irytujące błędy:

— uporczywe otwieranie okna biblioteki pomimo zaznaczenia w preferencjach, żeby się nie otwierała,
— problemy z eksportowaniem plików mkv,
— zamykanie programu podczas otwierania okna preferencji na PowerPC z systemem 10.4.

#45 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 21 czerwca 2010 - 10:44

Kolejny mały bug: czasami podczas oglądania filmu przełączam się japko+tab do innych aplikacji. Potem, kiedy film się skończy/nacisnę Esc, nie mogę tą kombinacją klawiszy przenieść w pełni focusa do PYM Playera - niby zmienia się aktywna aplikacja, ale okno jest nadal zasłonięte, odsłania go dopiero kliknięcie w ikonkę w docku. Przepraszam za mało dokładną analizę, póki co daję tylko znać, wieczorem się pobawię i spróbuję znaleźć sposób na 100% powtarzalność problemu ;-)

#46 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 27 czerwca 2010 - 02:49

Kolejny bug: kiedy próbuję usunąć z biblioteki film, którego nie ma już fizycznie na dysku, PYM Player się wywala. W logach: 6/27/10 3:48:13 AM SIMBL Agent[209] warning: failed to get scripting definition from /Applications/PYM Player.app; it may not be scriptable. 6/27/10 3:48:19 AM [0x0-0x4e54e5].com.pym.PYM Player[9731] checkFileName:FAIL:1 6/27/10 3:48:19 AM [0x0-0x4e54e5].com.pym.PYM Player[9731] PYM_PLAYER_FORCE_QUIT:0

#47 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 27 czerwca 2010 - 11:33

Kolejny bug: kiedy próbuję usunąć z biblioteki film, którego nie ma już fizycznie na dysku


Poprawione. :)

#48 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 27 czerwca 2010 - 19:36

Super. A jak badge z ilością elementów przy kategorii w bibliotece? To jedyna funkcjonalność, na którą mocno czekam ;-)

#49 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 28 czerwca 2010 - 10:46

Super. A jak badge z ilością elementów przy kategorii w bibliotece? To jedyna funkcjonalność, na którą mocno czekam ;-)


Ostatnio mam dość dużo innej roboty, więc większe zmiany w PYM Playerze dopiero za jakiś czas. Ale pamiętam o tym. Będzie w wersji 4.1 :)

#50 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 29 lipca 2010 - 08:58

Uwaga: jeżeli ktoś używa trybu pełnoekranowego do wybierania filmów pilotem poprzez przeglądanie ich „okładek” — funkcja ta przestaje działać po uaktualnieniu Safari do wersji 5.0.1.




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych