Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Serwer FTP na macOS High Sierra i hipokryzja Apple


Najlepsza odpowiedź tomasz , 19 stycznia 2018 - 13:48

W sumie o tym nie pomyślałem... a więc po kolei:

 

1. Instalujesz Homebrew

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

2. Instalujesz serwer ftp

brew install pure-ftpd

i tyle :)

Przejdź do postu


  • Zaloguj się, aby dodać odpowiedź
7 odpowiedzi w tym temacie

#1 Marek Popo

Marek Popo
  • 23 postów

Napisano 19 stycznia 2018 - 11:28

Do tej pory korzystałem z odpalonego w tle serwera FTP na moim Macu.

Opcja nie była zbyt łatwo dostępna ale były sposoby na odpalenie takiego serwera i korzystanie z niego.

Po aktualizacji do High Sierra taka możliwość zniknęła.

Apple po prostu usunęło demona ftpd (bez urazy dla moderatora ftpd) i tyle.

Problem w tym, że wiele osób korzystało do tej pory z możliwości odpalenia serwera FTP na swoich Macach np. do obsługi skanerów sieciowych (te starsze nie potrafią korzystać z nowszych protokołów takich jak sftp).

 

Żeby było zabawniej Apple pozwala na istnienie w Mac App Store takich aplikacji jak FTP Server - https://apple.co/2Dk2mCk

Zabrali coś co mieliśmy wbudowane w system od wielu lat ale pozwolili innym na wrzucenie tego do sklepu.



#2 tomasz

tomasz

  • 10 968 postów
  • Płeć:
  • SkądBełchatów, PL

Napisano 19 stycznia 2018 - 11:38

Skopiuj te pliki z komputera na którym jest starszy system:

• /usr/bin/ftp
• /usr/bin/telnet
• /usr/libexec/ftpd
• /System/Library/LaunchDaemons/ftp.plist
 
Na komputerze z High Sierra wyłącz SIP poprzez Recovery Mode
1. Zrestartuj komputer.  Kiedy pojawi się logo Apple wciśnij i przytrzymaj Command+R.
2. Otwórz Terminal (z menu Utilities).
3. Wpisz
 
csrutil disable
i wciśnij Enter.
 
4. Zrestartuj komputer.
 
Przenieś wcześniej skopiowane pliki do odpowiednich lokalizacji na komputerze z High Sierra.
• /usr/bin/ftp
• /usr/bin/telnet
• /usr/libexec/ftpd
• /System/Library/LaunchDaemons/ftp.plist
 
Nadaj odpowiednie uprawnienia plikowi ftp.plist
1. Otwórz Terminal.
2. Wpisz
 
chmod 677 /System/Library/LaunchDaemons/ftp.plist
 
i wciśnij Enter
 
Odpal serwer FTP.
1. Włącz Terminal
2. Wpisz
 
sudo -s launchctl load -w /System/Library/LaunchDaemons/ftp.plist
 
i wciśnij Enter.
 
Sprawdź czy działa.
1. Włącz Terminal
2. Wpisz
 
ftp localhost
 
i wciśnij Enter.
 
Włącz spowrotem SIP
1. Zrestartuj komputer.  Kiedy pojawi się logo Apple wciśnij i przytrzymaj Command+R.
2. Otwórz Terminal (z menu Utilities).
3. Wpisz
 
csrutil enable
 
i wciśnij Enter.
 
4. Zrestartuj komputer.

  • Marek Popo lubi to

#3 ftpd

ftpd

    Nie.


  • 21 768 postów
  • Płeć:
  • SkądPoznań

Napisano 19 stycznia 2018 - 13:29

W Homebrew jest pure-ftpd, vsftpd i proftpd, czego chcieć więcej?


  • tomasz i Marek Popo lubią to

Używaj przycisku 'Zgłoś', zamiast edytować post i pisać w nim, na przykład, "do usunięcia".
Pisanie prywatnej wiadomości do moderatora powinno być ostatecznością. Do tego też służy przycisk 'Zgłoś'.
Do płaczu na pracę Moderacji służy ten wątek. Inne formy będą bezwzględnie kasowane.


#4 tomasz

tomasz

  • 10 968 postów
  • Płeć:
  • SkądBełchatów, PL

Napisano 19 stycznia 2018 - 13:48   Najlepsza odpowiedź

W sumie o tym nie pomyślałem... a więc po kolei:

 

1. Instalujesz Homebrew

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

2. Instalujesz serwer ftp

brew install pure-ftpd

i tyle :)


  • Marek Popo lubi to

#5 Marek Popo

Marek Popo
  • 23 postów

Napisano 22 stycznia 2018 - 10:22

OK serwer proftpd zainstalowany.

Niestety przy próbie zalogowania się mam connection refused.

MacMini:~ marek$ ftp localhost
Trying ::1...
ftp: Can't connect to `::1': Connection refused
Trying 127.0.0.1...
ftp: Can't connect to `127.0.0.1': Connection refused
ftp: Can't connect to `localhost'
ftp> exit
MacMini:~ marek$ 

Serwer po instalacji oczywiście uruchomiłem poleceniem

brew services start proftpd

Niestety sprawdzając uruchomione procesy komendą ps aux próżno szukać procesu proftpd



#6 ftpd

ftpd

    Nie.


  • 21 768 postów
  • Płeć:
  • SkądPoznań

Napisano 22 stycznia 2018 - 16:21

Defaultowy config jest raczej do niczego, patrz:

 

 

 ~ $ /usr/local/sbin/proftpd
2018-01-22 16:21:00,661 ftpd_s_MacBook_Pro proftpd[23952]: warning: unable to determine IP address of 'ftpd_s_MacBook_Pro'
2018-01-22 16:21:00,661 ftpd_s_MacBook_Pro proftpd[23952]: error: no valid servers configured
2018-01-22 16:21:00,661 ftpd_s_MacBook_Pro proftpd[23952]: fatal: error processing configuration file '/usr/local/etc/proftpd.conf'

  • Marek Popo lubi to

Używaj przycisku 'Zgłoś', zamiast edytować post i pisać w nim, na przykład, "do usunięcia".
Pisanie prywatnej wiadomości do moderatora powinno być ostatecznością. Do tego też służy przycisk 'Zgłoś'.
Do płaczu na pracę Moderacji służy ten wątek. Inne formy będą bezwzględnie kasowane.


#7 Marek Popo

Marek Popo
  • 23 postów

Napisano 23 stycznia 2018 - 11:11

Czyli mam powalczyć z plikiem /usr/local/etc/proftpd.conf ?



#8 ftpd

ftpd

    Nie.


  • 21 768 postów
  • Płeć:
  • SkądPoznań

Napisano 23 stycznia 2018 - 13:22

No, na to by wychodziło.


Używaj przycisku 'Zgłoś', zamiast edytować post i pisać w nim, na przykład, "do usunięcia".
Pisanie prywatnej wiadomości do moderatora powinno być ostatecznością. Do tego też służy przycisk 'Zgłoś'.
Do płaczu na pracę Moderacji służy ten wątek. Inne formy będą bezwzględnie kasowane.





Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych