Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Polska czcionka w VLC


  • Zaloguj się, aby dodać odpowiedź
37 odpowiedzi w tym temacie

#1 seroMack

seroMack
  • 628 postów
  • SkądPoznań

Napisano 10 marca 2008 - 16:32

Co zrobić aby program VLC odczytywał polskie znaki diaktryczne? Czy trzeba ściągnąć jakąś bibliotekę/słownik czy może ustawić coś w SETUP? Sprawdzałem w wielu miejsach i niestety nie mogę znaleźć... :/

#2 Falcon

Falcon
  • 639 postów
  • SkądKraków

Napisano 10 marca 2008 - 16:39

File->Open File->Load Subtitles->Settings->Encoding-> CP1250 Pozdrawiam

#3 seroMack

seroMack
  • 628 postów
  • SkądPoznań

Napisano 10 marca 2008 - 17:59

Działa, dziękuję serdecznie :)

#4 vinci

vinci
  • 2 693 postów
  • SkądPoznań

Napisano 10 marca 2008 - 20:57

Mi kiedyś też Falcon z tym pomógł :) Niby takie proste a skomplikowane ;) Męczyłem się z tym chwilę.... :)

#5 ErGo

ErGo
  • 119 postów
  • SkądWrocław

Napisano 10 marca 2008 - 21:44

Ja byłem lepszy - uparłem się, że polskie znaki są w kodowaniu CP1251. Ustawiłem właśnie takie i psioczyłem że nie działają! 8-] Po kilkunastu nerwowych chwilach zorientowałem się gdzie tkwi błąd (miedzy monitorem a oparciem krzesła). Niestety - od tamtego momentu zdążyłem zapomnieć jak to „się stało” że w VLC wyświetlił napisy z polskimi znakami. Dlatego zajrzałem - przypomnieć sobie ;-) W ogóle VLC, z dotąd poznanych aplikacji dla Mac OS X, jawi mi się jako najmniej „macowy”. Przeraża mnie ilość paneli w Preferencjach, ich zawiłość i niezrozumiałość dla początkującego. Przeczuwam że przy pomocy VLC można zarejestrować odsłuchiwaną nim audycję radiową (via internet) ale nie wiem jak się zabrać do użycia takiej opcji.

#6 seroMack

seroMack
  • 628 postów
  • SkądPoznań

Napisano 10 marca 2008 - 22:43

:) A więc jaki macowy program byś polecił (w kórym będą polskie znaki?)

#7 migrena

migrena
  • 6 337 postów
  • SkądŁódź

Napisano 11 marca 2008 - 17:48

mplayer, a wlasciwie pymplayer. do transkodowania w vlc sluza opcje wyjscie strumieniowe > strumien sout > transkoduj. ale nie ma tam rozwijanych list i trzeba znac parametry uzywane w vlc z linii komend. czy sie da bez transkodowania nie mam pojecia.

#8 Harry Brown

Harry Brown
  • 373 postów
  • SkądKrakau

Napisano 11 marca 2008 - 19:14

Mi kiedyś też Falcon z tym pomógł :) Niby takie proste a skomplikowane ;) Męczyłem się z tym chwilę.... :)


Więc mu kliknij w autor.

#9 pretorians

pretorians
  • 235 postów

Napisano 13 marca 2008 - 22:49

Ostatnia najnowsza wersja VLC Media Player 0.8.6e sama potrafi odtwarzać z polskimi czcionkami. Nie trzeba niczego instalować.

#10 seroMack

seroMack
  • 628 postów
  • SkądPoznań

Napisano 14 marca 2008 - 08:07

No tak, jednak trzeba przeprowadzić "operację", o której pisał powyżej Falcon :)

#11 pretorians

pretorians
  • 235 postów

Napisano 14 marca 2008 - 21:44

Zgadza się,

#12 selekta

selekta
  • 166 postów

Napisano 03 maja 2008 - 15:37

Holy cow! Ja do tej pory otwierałem tekst w Firefoksie, zmieniałem ustawienia kodowania, zaznaczałem tekst, wklejałem do tekstedita i zapisywałem w unicode! :) Nigdy nie otwierałem plików przez file -> open file, więc nie znałem tego okna dialogowego. W preferences zaś nie ma kodowania.. VLC jest najlepszym odtwarzaczem, a tak niedorobionym. Ten program mógłby wziąć w ręce ktoś, kto ma pojęcie o filozofii interfejsu użytkownika w OSX.

#13 Evocati

Evocati
  • 2 postów

Napisano 24 sierpnia 2008 - 11:28

Sciagnalem najnowsza wersje VLC i zeby byly polskie znaki nadal trzeba samemu wybierac encoding przy ladowaniu napisow. Ktos ma jakis pomysl jak to obejsc ? zawsze film otwieram dwuklikiem na plik a nie przez wybor pliku w odtwarzaczu.

#14 huski

huski
  • 1 063 postów
  • SkądEU

Napisano 24 sierpnia 2008 - 12:38

File->Open File->Load Subtitles->Settings->Encoding-> CP1250

Też mi się przydało, dzięki

#15 Evocati

Evocati
  • 2 postów

Napisano 24 sierpnia 2008 - 12:42

Ehh dlaczego u mnie to nie dziala ? Nadal sa krzeki w miejscu polskich znakow

#16 Gość_owca666_*

Gość_owca666_*

Napisano 24 sierpnia 2008 - 13:51

Sciagnalem najnowsza wersje VLC i zeby byly polskie znaki nadal trzeba samemu wybierac encoding przy ladowaniu napisow.

Ktos ma jakis pomysl jak to obejsc ? zawsze film otwieram dwuklikiem na plik a nie przez wybor pliku w odtwarzaczu.


Mam wersję 0.8.6c, podejrzewam u Ciebie jest podobnie:
Preferences\Input / Codecs\Other codecs\Subtitles\Subtitles text encoding

Tam ustawisz kodowanie na stałe.

#17 pawello

pawello
  • 150 postów
  • SkądTarnów

Napisano 10 września 2008 - 21:52

a jak ustawic czas wyswietlania napisow w vlc? u mnie jest tak ze nachodza na siebie przy szybkich zmianach... poza tym czy jest zoom na fullscreenie?

#18 George Stark

George Stark
  • 242 postów

Napisano 10 września 2008 - 23:36

Trzeba również pamiętać aby nazwa pliku wideo była taka sama jak nazwa pliku z napisami. Wtedy VLC nie ma problemu z wyświetlaniem napisów w momencie, kiedy wrzucamy do niego jakiś film. Odtwarza od razu wszystko, tak jak PC-towy AllPlayer.

#19 tight-sweater

tight-sweater
  • 1 postów

Napisano 09 października 2008 - 20:29

czesc, jestem tu nowa wiec sie przywitam;) sluchajcie, ok mam nowego VLC i wyswietla mi polskie czcionki, ale polskie znaki roznia sie od pozostalych liter. np. litery ktore nie posiadaja polskich znakow sa pisane boldem, a te ktore maja sa bardzo cienkie i odrozniaja sie od pozostalych. czy to kwestia ustawienia czcionki w VLC? btw. ja mam ustawiona Arial

#20 NiePyta

NiePyta
  • 551 postów
  • Skąd

Napisano 23 stycznia 2009 - 23:57

a ja mam najnowszego (chyba) 0.9.8 i zmieniam na codowanie CP1250 i nadal mam krzaki. napisy sa w foramcie TXTi film i napisy maja taka sama nazwe. probowalem zmienic trzcionke ale i tak to nic nie daje, nadal krzaki. jakies inne pomysly ?

#21 seroMack

seroMack
  • 628 postów
  • SkądPoznań

Napisano 24 stycznia 2009 - 20:23

A możesz przesłać mi ten plik na maila? Sprawdzę jak u mnie będzie chodził. Podać e-mail na prv?

#22 seroMack

seroMack
  • 628 postów
  • SkądPoznań

Napisano 25 stycznia 2009 - 23:09

Tak jak przypuszczałem, u mnie widać polskie znaki, bez problemu. A czy w innych programach widać czcionkę polską? Być może trzeba zmienić ustawienia międzynarodowe systemu lub ustawienia odczytu czcionki w ogóle w systemie?

#23 NiePyta

NiePyta
  • 551 postów
  • Skąd

Napisano 26 stycznia 2009 - 00:52

dzieki za sprawdzienie pliku. dziwne, ze u cibie dziala poprawnie. wszedzi inndziej system pokazuje poprawnie polskie znaki tylko VLC.

#24 hosi

hosi
  • 122 postów
  • SkądDublin, IRL

Napisano 03 maja 2009 - 12:24

Ja mam wersje 0.99a, po ustawieniu na CP1250 wyswietlaja mi sie polskie znaki poza litera "ś" nie wiedziec czemu :/

#25 seroMack

seroMack
  • 628 postów
  • SkądPoznań

Napisano 03 maja 2009 - 22:10

Ja póki co posiadam 0.98b, wszystkie znaki diaktryczne wyświetlają się prawidłowo. Sprawdzę za moment - ściągam najnowszy uptade

---- Dodano 04-05-2009 o godzinie 11:10 ----
Sprawdziłem najnowszą wersję (0.99a), wszystko działa bez zarzutu, łącznie z wyświetlaniem litery 'Ś' :)

Pozdrawiam!




Użytkownicy przeglądający ten temat: 2

0 użytkowników, 2 gości, 0 anonimowych