Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
* * * * * 1 głosy

Upgrade dysku w MacBook Air 13'' Early 2014 na M.2 NVMe 512GB


  • Zaloguj się, aby dodać odpowiedź
21 odpowiedzi w tym temacie

#1 AleksanderGames

AleksanderGames
  • 172 postów
  • SkądWarszawa koło Pćinowa

Napisano 10 kwietnia 2020 - 07:59

Hej,

 

Mam taki problem. Postanowiłem zmienić swoje SSD SATA 128GB na PCI-e 512GB w MacBook Air 13'' Early 2014. W tym celu:

- zakupiłem dysk ADATA SX6000 Pro 512GB

- adapter M.2 NVMe Key M do MacBook AIR (1465, A1466) PRO Retina (A1398, A1502) z roku 2013 2014 2015 i 2017

- zestaw kluczy z T5 (śrubka dysku) i Pentalobe 1.2mm (wszystkie śruby tylnej obudowy)

- zrobiłem dysk startowy z Mojave oraz inny na wszelki wypadek z Catalina

- zrobiłem backup w Time Capsule

 

Po standardowej wymianie (pamiętam o odłączaniu baterii) i zbootowaniu instalatora (wkładamy USB i po włączeniu kompa wciskamy ALT aby wybrać rozruch) pojawia się standardowe okno instalatora w którym mogę mieć terminal, disk utility, odtwarzanie z time capsule lub instalację systemu.

 

Problem w tym, że ani w Disk Utility (nawet po kliknięciu show all), ani w Terminalu (po wpisaniu diskutil list), ani przy próbie świeżego systemu lub odtworzenia, nie widać dysku.

Dysk jest świeży, nieformatowany i niemontowany (nie kupowałem jeszcze kieszeni M.2 NVMe USB 3.1 żeby podłączyć w Windows lub w MacOS).

Próbowałem też Recovery z Internetu (cmd+r), ale tam ładowany jest stary system, który za pewne nie ma obsługi NVMe.

 

Czy macie jakieś sugestie? Obecnie wróciłem do starego dysku i chyba zakupię kieszeń.

 

Wersja Boot ROM to 110.0.0.0.0 i SMC to 2.13f15.

Identyfikator Maca to MacBookAir 6,2, A1466, przedstawiający się jako MacBook Air (13-inch, Early 2014)

 



#2 SERWIS.ME

SERWIS.ME
  • 664 postów
  • Płeć:
  • SkądKraków

Napisano 10 kwietnia 2020 - 08:54

A jaki wcześniej miałeś system na nim? Możliwe, że bootrom jest zbyt stary i dlatego nie widzi tego dysku. Nie mogę znaleźć strony, gdzie są informacje o aktualnych wersjach, ale strzelam, że to tego wina. Możesz wrzucić na chwilę stary oryginalny dysk i na nim zainstalować np. Mojave albo Catalinę i jeśli bootrom jest stary to zostanie zaktualizowany. Potem możesz zamontować nowy dysk i sprawdzić czy już jest widoczny w instalatorze.

 

Znalazłem: https://support.appl.../en-us/HT201518 wyglada na to, że masz stary bootrom.


Użytkownik SERWIS.ME edytował ten post 10 kwietnia 2020 - 08:56

Autoryzowany serwis Apple. 

Naprawy gwarancyjne i pogwarancyjne.
Limanowskiego 4, 30-534 Kraków 
Tel: 12 311 08 11
www.serwis.me

 


#3 AleksanderGames

AleksanderGames
  • 172 postów
  • SkądWarszawa koło Pćinowa

Napisano 10 kwietnia 2020 - 11:31

Dzięki za odpowiedź. System to Mojave 10.14.2 Beta (18C52a). A na penie ostatni oficjalny Mojave.


Ściągnąłem sobie EFI z Twojej stronki, ale pokazuje mi że to nie pod tę wersję systemu. Generalnie wielu ludzi próbowało użyć /usr/libexec/efiupdater, ale po restarcie komputera dochodzili do wniosku, że update nie miał skutku.

 

Czy tu się da zamieszczać zdjęcia? Chciałbym pokazać zrzut ekranu.


A jaki wcześniej miałeś system na nim? Możliwe, że bootrom jest zbyt stary i dlatego nie widzi tego dysku. Nie mogę znaleźć strony, gdzie są informacje o aktualnych wersjach, ale strzelam, że to tego wina. Możesz wrzucić na chwilę stary oryginalny dysk i na nim zainstalować np. Mojave albo Catalinę i jeśli bootrom jest stary to zostanie zaktualizowany. Potem możesz zamontować nowy dysk i sprawdzić czy już jest widoczny w instalatorze.

 

Znalazłem: https://support.appl.../en-us/HT201518 wyglada na to, że masz stary bootrom.

 

 

 

Wpisałem: /usr/libexec/firmwarecheckers/eficheck/eficheck --integrity-check

 

i dostałem:

 

EFI Version: MBA61.88Z.0108.B00.1809171520


Ciekawy artykuł https://eclecticligh...sing-version-2/


Użytkownik AleksanderGames edytował ten post 10 kwietnia 2020 - 11:31


#4 SERWIS.ME

SERWIS.ME
  • 664 postów
  • Płeć:
  • SkądKraków

Napisano 10 kwietnia 2020 - 12:42

Czyli miałeś na tym komputerze zainstalowany wcześniej na starym dysku Mojave?


Autoryzowany serwis Apple. 

Naprawy gwarancyjne i pogwarancyjne.
Limanowskiego 4, 30-534 Kraków 
Tel: 12 311 08 11
www.serwis.me

 


#5 AleksanderGames

AleksanderGames
  • 172 postów
  • SkądWarszawa koło Pćinowa

Napisano 10 kwietnia 2020 - 15:40

Tak. Miałem Mojave. We wtorek odbieram kieszeń, więc wtedy chyba zrobię kopię dysku 1 do 1, tak aby EFI już czekał na tym nowym dysku (czytałem, że ludzie też tak robią, jak mają problemy z widocznością np. dysków Evo od Samsunga). Poza tym przetestuję czy dysk działa (powinien bo nówka z pudełka wyciągnięta). Tym czasem z braku laku updatuje do Cataliny.

 

 

 

 

 

Oooo po aktualizacji do najnowszego Mojave 10.14.6 zmienił się Boot Rom na:

 

EFI Version: MBA61.88Z.F000.B00.2002052050  (Boot ROM Version: 120.0.0.0.0)

 

Sprawdze na tym bez updatu do Cataliny.


Użytkownik AleksanderGames edytował ten post 10 kwietnia 2020 - 15:40


#6 AleksanderGames

AleksanderGames
  • 172 postów
  • SkądWarszawa koło Pćinowa

Napisano 10 kwietnia 2020 - 20:38

No niestety, dla tej wersji boot rom wciąż nie widać dysku.

#7 tumpio

tumpio

    SERWIS


  • 6 226 postów
  • Płeć:
  • SkądWarszawa

Napisano 13 kwietnia 2020 - 12:11

Masz trafioną przejściówkę. W tej wersji EFI ma obowiązek działać. Swoją drogą - dysk 500 OWC to 800 zł, a nawet jak kupisz działającą przejściówkę to często nie działa ona prawidłowo (np. miałem taką co zapis był prawidłowy, ale odczyt spadł do 90MB/s)


  • AleksanderGames lubi to
Specjalistyczny Serwis Komputerów Apple "Serwis Jabłek®"
ul. Stryjeńskich 10 lok usł 2A.
02-791 Warszawa tel: 533-996-563 lub 796-440-048
http://www.macbook-service.com

#8 AleksanderGames

AleksanderGames
  • 172 postów
  • SkądWarszawa koło Pćinowa

Napisano 14 kwietnia 2020 - 17:27

Ok. Dzięki za odpowiedź. Też do tego się przychylam. Wczoraj zamówiłem inną (za 25 zł) na AliExpress co ma 700 pozytywnych komentarzy. A jak to nie pomoże to kupię od Sintecha na Amazon (za 110 zł). Co do dysków dedykowanych. No cóż, nie wiedziałem, że będzie tyle przygód (będzie prosto mówili). Obrałem tę drogę. Sprzętu nie mogę już zwrócić (kosztowo na razie to 350 zł za dysk + 25 zł za adapter + 150 zł za obudowę USB; za chwilę doliczę za inny adapter 25 i 110 zł).

Teraz ciekawostka odnośnie NVMe po USB 3. Dysk jest sprawny. Restore w Disk Utility do sklonowania dysku nie działa (kończy się błędem podczas weryfikacji na koniec). Jak podłączę dysk po USB aby zainstalować MacOS, to go i tak nie widać (inne pendrive USB widać, jak i karty SD).

PS. Ceny dysków skoczyły, jeszcze pół roku temu kupiłem 512GB NVMe po 250 zł, podobnie talerzowe były tańsze (więc to nie jest związane z półprzewodnikami, a parciem na dane lub odświeżaniem kompów).

Użytkownik AleksanderGames edytował ten post 14 kwietnia 2020 - 19:02


#9 AleksanderGames

AleksanderGames
  • 172 postów
  • SkądWarszawa koło Pćinowa

Napisano 15 kwietnia 2020 - 00:15

Obkleiłem jeszcze adapter taśmą izolacyjną, według sugestii w tym komentarzu https://www.ifixit.c...er#answer561534 oraz zrestartowałem PRAM/SMC jak opisał to jeden z użytkowników w komentarzach do adaptera od Sintecha.

 

Też nie pomogło. Tak więc czekam na nowe adaptery, a w zanadrzu mam jeszcze zmianę dysku (z mojego PC).


Użytkownik AleksanderGames edytował ten post 15 kwietnia 2020 - 00:16


#10 dyskietka74

dyskietka74
  • 7 postów
  • SkądSzczerców, Poland

Napisano 22 kwietnia 2020 - 07:25

Mam dokladnie ten sam problem tyle ze w macbook pro 13" 2015r z dyskiem evo 960 2TB i adapterem.

#11 YABBA235

YABBA235
  • 472 postów

Napisano 22 kwietnia 2020 - 10:05

Ja chyba użyłem tego samego adaptera w moim Air-e i dysk był od razu widoczny - najpierw zrobiłem clona starego dysku CCC, podmieniłem je i mac od razu wstanął

Ale ja już wcześniej miałem Catalinę, może to jest przyczyną - niestety, teraz nie mam dostępu do kompa to nie sprawdzę jaką mam wersję bootroma.

Dysk 960 EVO 256GB.

 

Obkleiłem jeszcze adapter taśmą izolacyjną, według sugestii w tym komentarzu https://www.ifixit.c...er#answer561534 oraz zrestartowałem PRAM/SMC jak opisał to jeden z użytkowników w komentarzach do adaptera od Sintecha.

 

Też nie pomogło. Tak więc czekam na nowe adaptery, a w zanadrzu mam jeszcze zmianę dysku (z mojego PC).


Zona na Acera Swift 3, pierwsza córka ma Yogę 520, druga ma Yogę 530, ja mam MacBooka Pro '18 (OC Hackintosh) ,Macbook-a Air 2014 (Real) oraz  iphone XS, backupy i TM QNAP TS-453mini.


#12 AleksanderGames

AleksanderGames
  • 172 postów
  • SkądWarszawa koło Pćinowa

Napisano 22 kwietnia 2020 - 13:41

No już dzisiaj przyszedł adapter od Sintecha (prócz tego idzie od chińczyka, więc i go sprawdzę dla dobra ogółu), ale dopiero w weekend sprawdzę, więc stay tuned. Wydaje mi się, że ten topic będzie wartościowy, bo w sumie poszło ścieżkami negatywnymi, a jak wiadomo, jak trwoga to na forum.

Użytkownik AleksanderGames edytował ten post 22 kwietnia 2020 - 13:43


#13 YABBA235

YABBA235
  • 472 postów

Napisano 22 kwietnia 2020 - 15:01

No to czekamy co z tego wyjdzie :)

Sprawdziłem mój bootrom, mam 120.0.0.0.0, więc w tym na pewno działa dysk nvme :)


Zona na Acera Swift 3, pierwsza córka ma Yogę 520, druga ma Yogę 530, ja mam MacBooka Pro '18 (OC Hackintosh) ,Macbook-a Air 2014 (Real) oraz  iphone XS, backupy i TM QNAP TS-453mini.


#14 AleksanderGames

AleksanderGames
  • 172 postów
  • SkądWarszawa koło Pćinowa

Napisano 25 kwietnia 2020 - 00:26

No Panowie. Dobre wieści. Adapter Sintecha zadziałał. Dysk był widoczny bez przeszkód. Transfery mam przepołowione, 520 MB/s zapis i 1300 MB/s odczyt. Co do adaptera to wygląda jak ten chiński z Allegro, który nabyłem jako pierwszy. Ale różni się kilkoma chyba istotnymi rzeczami.
- cena - 5-krotnie wyższa
- "certyfikat" weryfikacji egzemplarza gwarantujący działanie (to może być sedno tego adaptera)
- podklejenie out-of-box o którym wspomniałem
- standardowe odchylenie dysku bez dokręcenia/docisku (tego nie było w poprzednim, wchodził poziomo i brak docisku mógł powodować, że coś tam "nie stykało", chodzi o takie odchylenie jakie jest przy M.2 w PC)
- śrubka jest mniejsza i nie dotyka żadnych elementów (chociaż i to wyeliminowałem w poprzednim podklejeniem)
- całość jest gruba, musiałem docisnąć klapę (kwestia 1-2 mm), na szczęście MacBook ma tył podklejone termoizolacja na wysokości dysku

Właśnie zainstalowałem nowy Mojave, aby przetestować transfery i chodzenie spać i wybudzanie (działa normalnie, może po dłuższym czasie snu się coś skrzaczy, jak to raportują ludzie).

Teraz przywrócę system z Time Capsule.

Poświęcę się dla dobra nauki i sprawdzę jeszcze adapter zamówiony z AliExpress.

Jakby nie było możecie powtórzyć pattern ;-)

 

EDIT: Właśnie jestem po przywróceniu systemu z time capsule. Wszystko śmiga, a transfery są utrzymane.


Użytkownik AleksanderGames edytował ten post 25 kwietnia 2020 - 00:27


#15 dyskietka74

dyskietka74
  • 7 postów
  • SkądSzczerców, Poland

Napisano 25 kwietnia 2020 - 06:35

AleksanderGames, szkoda że fotki nie zrobiłeś jak podkleić taśmą , gdzie i co. Czekam też na ten "lepszy" adapter.
Podzielę się i ja z operacji na otwartym macu.
Macie jakieś pomysły co z dyskiem wyjętym, tym orginalnym? Ogladalem jakies kieszenie i obudowy ale problem jest tego złącza dysku. Nie widzialem nigdzie w druga strone adaptera.
Pozdrawiam.

#16 AleksanderGames

AleksanderGames
  • 172 postów
  • SkądWarszawa koło Pćinowa

Napisano 25 kwietnia 2020 - 08:27

Dobra, przetestowałem hibernację i niestety nie działa więc ja wyłączyłem.

Testu dokonałem wpisując poniższe komendy; zamykając pokrywę; odczekując 65 sekund; wybudzając komputer otwarciem pokrywy oraz wciśnięciem przycisku power. Efekt był taki, że komputer raz się zrestartował, a następnie zaczął się ładować od zera (w trakcie testów wybudzałem też kompa przed upływem 60 sekund).

Komendy:
sudo pmset -a standbydelay 60
sudo pmset -a hibernatemode 25
pmset sleepnow


Przy czym stadbydelay przywracamy do pierwotnej wartosci. U mnie było 10800 czyli 3 godzin. Dlaczego nie po prostu pmset standby? Bo chciałem przetestować przejście ze sleep do hibernate.

Komenda na wyłączenie hibernacji:

sudo pmset -a hibernatemode 0 standby 0 autopoweroff 0

 

 

 

 

 

 

 

 

 

AleksanderGames, szkoda że fotki nie zrobiłeś jak podkleić taśmą , gdzie i co. Czekam też na ten "lepszy" adapter.
Podzielę się i ja z operacji na otwartym macu.
Macie jakieś pomysły co z dyskiem wyjętym, tym orginalnym? Ogladalem jakies kieszenie i obudowy ale problem jest tego złącza dysku. Nie widzialem nigdzie w druga strone adaptera.
Pozdrawiam.

Fotki porobię przy okazji przesyłki z AliE press. Zestawie też z adapterem od Sintecha. Co do "lepszego" adaptera, to uważam, że Sintech jest najlepszy. Bo tak twierdzą ludzie, którzy widać, że się znają na rzeczy https://forums.macru...2-nvme.2034976/

 

 

EDIT: Komentarz odnośnie transferów. Pamiętajcie, że to są odczyty i zapisy sekwencyjne. Odczyty losowe są znacznie szybsze niż dla SSD, więc to głównie tutaj świeci NVMe. Poza tym to świetne uczucie mieć 400GB wolnego na dysku ;-)


Użytkownik AleksanderGames edytował ten post 25 kwietnia 2020 - 09:12


#17 AleksanderGames

AleksanderGames
  • 172 postów
  • SkądWarszawa koło Pćinowa

Napisano 26 kwietnia 2020 - 08:04

Macie jakieś pomysły co z dyskiem wyjętym, tym orginalnym? Ogladalem jakies kieszenie i obudowy ale problem jest tego złącza dysku. Nie widzialem nigdzie w druga strone adaptera.
 

 

Tutaj masz kieszeń - https://www.aliexpre...0801199696.html są też tańsze dla modeli z 2012 roku



#18 dyskietka74

dyskietka74
  • 7 postów
  • SkądSzczerców, Poland

Napisano 26 kwietnia 2020 - 08:12

AleksanderGames, dziękuję. To naprawdę fajne rozwiązanie, oby tylko zadziałał ten drugi adapter który zamówiłem i czekam na niego. Jak nie to zamówię trzeci, ten co Ty. Zastanawia mnie tylko sposób jak pod kleiłeś taśmą i w którym miejscu na adapterze.

#19 AleksanderGames

AleksanderGames
  • 172 postów
  • SkądWarszawa koło Pćinowa

Napisano 26 kwietnia 2020 - 10:50

Było w linku ifix, który podesłałem wyżej. Ale tutaj masz wsad również ode mnie ;-) + link na którym gościu wymieniał dysk i na nim też widać podklejenia - https://atomstar.twe...ech-m2-adapters

 

Daj znać czy Ci się udało z podklejeniem. Mnie się nie udało, bo nie zrobiłem dystansu (on odpowiada za docisk do pinów), a tylko izolację styku (naprawia zwieranie ze slotem w MacBook).

 

PS. Przepraszam za rozdzielczość, ale to forum pozwala na załączenie maksymalnie 500 KB per post (śmiesznie mało jak na 2020 rok)

Załączone pliki



#20 dyskietka74

dyskietka74
  • 7 postów
  • SkądSzczerców, Poland

Napisano 01 maja 2020 - 15:06

Ok. U mnie również zagościła radość. Drugi adapter okazał się sprawny, lepiej wykonany. System wgrałem z beckupu timemachine, teraz można sie cieszyć 2Tb dyskiem. Nie sprawdziłem jeszcze prędkości i wybudzania, ale widze ze prędkość nie powala.

#21 AleksanderGames

AleksanderGames
  • 172 postów
  • SkądWarszawa koło Pćinowa

Napisano 01 maja 2020 - 17:52

O, a gdzie zakupiłeś adapter? No i nie ma to jak większa pojemność dysku, w sumie po to się zmienia dysk. Prędkość prędkością, szału nie ma, po prostu rzadziej czka, kopiowanie małych i średnich plików śmiga. Są też minusy, troszkę cieplejszy komp, bateria też szybciej schodzi, no i nie ma hibernacji. Natomiast nie zmienia to komfortu użytkowania MacBooka.

#22 dyskietka74

dyskietka74
  • 7 postów
  • SkądSzczerców, Poland

Napisano 01 maja 2020 - 22:03

Adapter kupiłem na allegro, od guffcio_elcomp, 47 pozytywnych ocen produktu, cena 55,58zł i przesyłka. 

Co do prędkości to ok 1200MB/s zapis i ok 1400MB/s odczyt. Z wybudzaniem nie zauważyłem problemu.   


  • AleksanderGames lubi to




Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych