Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Dostęp do plików na NAS


  • Zaloguj się, aby dodać odpowiedź
14 odpowiedzi w tym temacie

#1 hubkubas

hubkubas
  • 57 postów
  • SkądWarschau, Poland

Napisano 08 listopada 2019 - 10:22

Koledzy mam takie 2 problemy, otóż w firmie mam NAS Synology jak dostać się do plików będą wewnątrz sieci tzn w biurze. Ludzie na windowsie mają skrót adresu ip jako właściwość w folderze i zwyczajnie klikaj na folder i mają dostęp do plików, kiedy są na zewnątrz łączą się przez VPN i klikają w ten sam folder i mają dostęp do tych samych plików z zewnątrz. Ja muszę robić jakieś wielkie gimnastyki. Czy jest jakiś sposób, aby mieć tak samo jak w windowsie?

 

Czyli chciałbym tak jak na windows mają czyli robię coś na zasadzie skrótu gdzie wpisuję adres folderu ip nas czyli np \\192.160.0.20 i jeśli jestem w firmie gdzie jest nas to od razu wchodzę w pliki, a jeśli jestem na zewnątrz to łączę się VPN i kiedy jestem połączony to jw. Podpowie ktoś plis.

 

Hubert



#2 ftpd

ftpd

    Nie.


  • 18 797 postów
  • SkądPoznań

Napisano 08 listopada 2019 - 11:33

w Finderze cmd+k (albo z menu Go -> Connect to server) i tam podajesz smb://192.160.0.20 (albo cifs:// albo coś innego - nie wiem, po czym masz to ustawione, ale skoro na Windowsie działa tak, jak opisałeś, to smb/cifs powinny zrobić robotę).
Możesz sobie w tym okienku do łączenia się zapisać adresy do ulubionych. Z tego, co mi wiadomo, nie można tego zautomatyzować, za każdym razem (per sesja, czyli do wylogowania/utraty sieci) musisz się łączyć ręcznie.
---
Jestem Grammar Nazi. Nie znoszę błędów, leni, idiotów i hipsterów.
NIE pomagam przez PW. Mogę co najwyżej pogawędzić.
NIE odpisuję na wiadomości najeżone błędami. Nie chce mi się męczyć oczu.

#3 Shrek

Shrek
  • 1 141 postów
  • Płeć:
  • SkądPoznań

Napisano 04 stycznia 2020 - 22:33

Może tutaj ktoś coś będzie wiedział, od aktualizacji do Cataliny przestał działać NAS w sensie

widac, można się połączyć ale jedynie do odczytu. Wszystkie przywileje włączone, łączy z nas

bez problemu ale nic nie da się zrobić poza odczytem. To samo w dwóch sieciach, na routerach

Fritz, dla testu podstawowej nawet TP-Lonka i to samo, wiec raczej 99% OS nienroutery,


 Only Apple 

#4 ftpd

ftpd

    Nie.


  • 18 797 postów
  • SkądPoznań

Napisano 05 stycznia 2020 - 11:30

Musisz włączyć w NAS obsługę SMBv3. Stary protokół, SMBv1, nie działa w Catalinie.
I zacznij pisać jak człowiek, następne posty pełne bełkotu będę usuwał, a nie na nie odpisywał.


---
Jestem Grammar Nazi. Nie znoszę błędów, leni, idiotów i hipsterów.
NIE pomagam przez PW. Mogę co najwyżej pogawędzić.
NIE odpisuję na wiadomości najeżone błędami. Nie chce mi się męczyć oczu.

#5 Mikołaj Maciejko

Mikołaj Maciejko
  • 2 044 postów

Napisano 07 stycznia 2020 - 19:46

A czy można jakoś sprawdzić, która wersja protokołu SMB została wynegocjowana?

 

Mam taki dziwny przypadek, że Samba postawiona na dość nowym Raspberry Pi jest poprawnie widoczna na wszystkim (Apple TV, Windows, iPhone), a próba podłączenia z Cataliny przez cmd-K do smb://raspberrypi/ (pod tą nazwą jest widoczny w sieci) powoduje wyłącznie wyświetlenie komunikatu "Łączę się z smb://raspberrypi/", który trwa tak długo, aż się go zamknie.

 

Wydaje mi się, że ta wersja Samby obsługuje SMBv3, ale nie wiem, jak to potwierdzić.


Użytkownik Mikołaj Maciejko edytował ten post 07 stycznia 2020 - 19:47


#6 iEjek

iEjek
  • 66 postów

Napisano 07 stycznia 2020 - 22:27

A czy można jakoś sprawdzić, która wersja protokołu SMB została wynegocjowana?

W terminalu, wpisz:

 

smbutil statshares -a



#7 Mikołaj Maciejko

Mikołaj Maciejko
  • 2 044 postów

Napisano 08 stycznia 2020 - 08:38

W terminalu, wpisz:

smbutil statshares -a

Lista jest pusta. Cały czas wyświetla się komunikat, jak powyżej.

#8 pedros

pedros
  • 1 351 postów
  • SkądWAW, PL

Napisano 08 stycznia 2020 - 08:54

Bo to polecenie pokazuje wersję protokołu już zestawionych połączeń…



#9 Mikołaj Maciejko

Mikołaj Maciejko
  • 2 044 postów

Napisano 08 stycznia 2020 - 09:08

No domyślam się. Zastanawiam się, jak to dalej diagnozować.

#10 pedros

pedros
  • 1 351 postów
  • SkądWAW, PL

Napisano 08 stycznia 2020 - 11:41

Spróbuj po IP. Bo niby na różnych forum radzą użyć przedrostka cifs://<sharename or ip>, ale nie każdemu to ponoć działa. Podobnie jak edycja /etc/nsmb.conf Cóż, idzie nowe… ;) A obsługa SMB przez Apple zawsze sprawiała jakieś problemy…


Użytkownik pedros edytował ten post 08 stycznia 2020 - 11:43


#11 Mikołaj Maciejko

Mikołaj Maciejko
  • 2 044 postów

Napisano 08 stycznia 2020 - 11:46

Po IP, jak i cifs zamiast smb jest dokładnie tak samo. /etc/nsmb.conf? Ja mam konfig samby w /etc/samba/smb.conf. Nie wiem, co mógłbym tam edytować, skoro udostępnianie działa poprawnie ze wszystkimi innymi platformami.

#12 ftpd

ftpd

    Nie.


  • 18 797 postów
  • SkądPoznań

Napisano 08 stycznia 2020 - 12:48

O tak sprawdzisz:
 
[~] # smb2status
 
smbd (samba daemon) Version 4.7.12
smbd (samba daemon) is running.
max protocol SMB 2.1 enabled.
Fun fact: mogę się do tego połączyć z Cataliny. To o wymaganym SMBv3 wyczytałem w innym wątku i uwierzyłem - może chodzi bardziej o to, że v1 wyłączyli, a wszystko wyżej działa.
---
Jestem Grammar Nazi. Nie znoszę błędów, leni, idiotów i hipsterów.
NIE pomagam przez PW. Mogę co najwyżej pogawędzić.
NIE odpisuję na wiadomości najeżone błędami. Nie chce mi się męczyć oczu.

#13 Mikołaj Maciejko

Mikołaj Maciejko
  • 2 044 postów

Napisano 08 stycznia 2020 - 13:00

Na czym masz postawioną Sambę? Bo u mnie nie ma smb2status. Mam tylko coś takiego:

$ sudo smbstatus

Samba version 4.5.16-Debian
PID Username Group Machine Protocol Version Encryption Signing
----------------------------------------------------------------------------------------------------------------------------------------

Service pid Machine Connected at Encryption Signing
---------------------------------------------------------------------------------------------

No locked files

#14 ftpd

ftpd

    Nie.


  • 18 797 postów
  • SkądPoznań

Napisano 08 stycznia 2020 - 13:02

Stockową z QNAP.

No ale 4.5.x z pewnością wspiera nowe wersje protokołu.


---
Jestem Grammar Nazi. Nie znoszę błędów, leni, idiotów i hipsterów.
NIE pomagam przez PW. Mogę co najwyżej pogawędzić.
NIE odpisuję na wiadomości najeżone błędami. Nie chce mi się męczyć oczu.

#15 Mikołaj Maciejko

Mikołaj Maciejko
  • 2 044 postów

Napisano 08 stycznia 2020 - 13:25

Ano wspiera. Podłączyłem się Infuse na iPhone i smbstatus pokazuje połączenie protokołem SMB3_02.






Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych