Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

FileVault - komunikat "szyfrowanie wstrzymane"


  • Zaloguj się, aby dodać odpowiedź
32 odpowiedzi w tym temacie

#26 cronopioverde

cronopioverde
  • 3 301 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 04 grudnia 2018 - 01:18

Brak błędu, czyli Twoja nazwa usera i kursor. W przeciwnym razie poinformuje, że "The user name or passphrase you entered is not correct."


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na łamaną polszczyznę to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#27 Sooyca

Sooyca
  • 4 postów

Napisano 14 marca 2020 - 09:55

Witam,

 

mam podobny problem - miałem włączony FileVault, postanowiłem go wyłączyć, w pewnym momencie pasek postępu zmienił się na "odszyfrowywanie wstrzymane" i tak już został.

Nie jest możliwa instalacja aktualizacji. Przy próbie wyświetla się „Trwa konwersja FileVault.”

Na szczęście backup się udał, ale wyświetlił się komunikat „Uwaga! Archiwizowanie dysku zaszyfrowanego na niezaszyfrowanym.”

Dalsze różnice są takie, że po wpisaniu „fdesetup status” wyświetla się „FileVault is Off” (co chyba stoi w sprzeczności z komunikatem o archiwizowaniu dysku zaszyfrowanego na niezaszyfrowanym, ale nie wiem), a po wpisaniu „diskutil apfs list” wyświetla się „No APFS Containers found”.

Po wpisaniu „sudo fdesetup haspersonalrecoverykey” pokazuje się „true”.

Po wpisaniu „sudo fdesetup hasinstitutionalrecoverykey” pokazuje się „false”.

Po uruchomieniu pierwszej pomocy w narzędziu dyskowym pojawia się komunikat:

„Pierwsza pomoc napotkała uszkodzenie, które należy naprawić. Aby naprawić wolumin startowy, uruchom Pierwszą pomoc z partycji Odzyskiwanie. Aby kontynuować naciśnij Gotowe.”

Nie mam jednak partycji Odzyskiwanie.

Zresetowałem pamięć NVRAM i PRAM - nic to nie dało.

Zresetowałem SMC - nic to nie dało.

Mój system operacyjny to Sierra 10.12.6. Co powinienem zrobić, by zdiagnozować problem i doprowadzić komputer do stanu w którym dysk jest odszyfrowany, FileVault jest wyłączony, w preferencjach systemowych pokazuje się adekwatny do tego komunikat, a aktualizacje da się wykonać?

 

Dziękuję za pomoc.



#28 cronopioverde

cronopioverde
  • 3 301 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 14 marca 2020 - 11:45

[…] Nie mam jednak partycji Odzyskiwanie. […]

A dlaczegóż to?


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na łamaną polszczyznę to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#29 Sooyca

Sooyca
  • 4 postów

Napisano 14 marca 2020 - 17:59

Pytanie skłoniło mnie do refleksji, czy aby na pewno jest tak, jak napisałem. Partycja Odzyskiwanie nie wyświetla mi się na mapie partycji narzędzia dyskowego (przez co nabrałem przekonania, że jej nie mam), ale na stronie Apple znalazłem informację jak uruchomić komputer z tejże partycji - trzymając cmd+R. Tak też zrobiłem. Komputer uruchomił się w trybie odzyskiwania, więc, jak się wydaje, partycja Odzyskiwanie jednak jest na moim komputerze i wcześniej napisałem nieprawdę.

Otworzyłem narzędzie dyskowe, następnie pierwszą pomoc na dysku fizycznym - wyskoczył ten sam komunikat co wcześniej „Pierwsza pomoc napotkała uszkodzenie, które należy naprawić. Aby naprawić wolumin startowy, uruchom Pierwszą pomoc z partycji Odzyskiwanie. Aby kontynuować naciśnij Gotowe.”. (Czy to normalne? Przecież komputer był właśnie uruchomiony z partycji Odzyskiwanie.) Próbowałem zamontować wolumin logiczny. Zostałem wtedy poproszony do hasło, jednak ani moje hasło użytkownika (mam uprawnienia administratora), ani klucz szyfrowania do FileVault nie były akceptowane. Przypuszczałem, że może chodzić o uprawnienia użytkowników, więc przyznałem sobie "odczyt i zapis" dla tego woluminu jednak nic to nie dało.

Zatem wydaje się, że jednak mam partycję odzyskiwanie, ale nie wiem jakiego hasła powinienem użyć by móc zamontować wolumin logiczny i uruchomić na nim pierwszą pomoc.


Użytkownik Sooyca edytował ten post 14 marca 2020 - 18:01


#30 cronopioverde

cronopioverde
  • 3 301 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 15 marca 2020 - 13:36

Trochę się pogubiłem w gąszczu nieco chaotycznych informacji, wybacz. Pisałeś już o diskutil apfs, którego to przecież kontenera być na Sierze nie może z oczywistych względów, o montowaniu woluminu logicznego (masz fusion drive czy po prostu nadal FileVault jest włączony mimo wyniku fdesetup status?).

Po pierwsze – możesz się normalnie zalogować na swoje konto i masz dostęp do danych, czy hasło do odszyfrowania Ci nie działa w ogóle?


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na łamaną polszczyznę to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#31 Sooyca

Sooyca
  • 4 postów

Napisano 15 marca 2020 - 18:22

Mogę się normalnie zalogować na swoje konto i mam dostęp do danych.

Nie mam fusion drive. W preferencjach systemowych wyświetla się informacja, że FileVault jest włączony (pomimo, że "fdesetup status" daje "FileVault is Off").



#32 cronopioverde

cronopioverde
  • 3 301 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 23 marca 2020 - 16:41

Skoro możesz, to postaraj się zdiagnozować problem. Wykonaj, proszę EtreCheck oraz puść poniższą serię komend w Terminalu:

{ system_profiler SPHardwareDataType SPDisplaysDataType SPMemoryDataType SPSoftwareDataType SPStartupItemDataType SPStorageDataType -detailLevel mini; spctl --status -v; csrutil status; fdesetup status; ls -l@ /L*/{E*,Int*/*,La*,P*P*,Priv*} /Users/*/L*/{Int*,L*A*,P*P*,S*/Ex*}; osascript -e 'tell application "System Events" to get the name of every login item'; top -stats pid,command,cpu,mem,csw -o mem | head -n 18; grep 'Installed' /private/var/log/install.log | tail -n 10; ls {/L*/L*,~/L*/L*}/D* | grep crash; grep 'crash' /private/var/log/system.log; } 2>/dev/null | pbcopy

i podziel się wynikami.

Disclaimer 1: po poprawnym wykonaniu komend (czyli po ponownym pojawieniu się znaku zachęty) nie zobaczysz wyniku w oknie Terminala, a zamiast tego będzie on skopiowany do schowka. Wklej bezpośrednio do odpowiedzi tutaj albo do jakiegokolwiek notatnika, żeby było na później.

Disclaimer 2: jeżeli tekstu z tych wyników będzie dużo (a pewnie będzie), postaraj się użyć stosownego serwisu, np. pastebin.com, zamiast tworzyć kilometrowe autostrady do scrollowania w wątku. Nie sprzyja to czytelności. Dzięki.

 

Powodzenia.


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na łamaną polszczyznę to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#33 Sooyca

Sooyca
  • 4 postów

Napisano 25 marca 2020 - 21:36

Wydaje się, że udało mi się rozwiązać problem. 

W oczekiwaniu na odpowiedź zacząłem szukać sposobu na uruchomienie pierwszej pomocy na dysku. 

Udało mi się to w końcu zrobić uruchamiając komputer w trybie odzyskiwania, uruchamiając terminal, a następnie komendę

"fsck_cs -y nazwa_woluminu”, tak jak to zasugerowano tutaj: https://apple.stackexchange.com/a/190845

Zapis terminalu z tego procesu jest tutaj:

https://pastebin.com/dzyvpxjA

Po restarcie i normalnym logowaniu pasek zmienił się z "odszyfrowywanie wstrzymane" na "odszyfrowywanie". 

Nie korzystałem wtedy z komputera za wyjątkiem sprawdzania postępu przez około 2 dni. Wczoraj proces zakończył się. Przez pierwsze pół godziny wyświetlał się jednak komunikat, że FileVault jest włączony, co wzbudziło moje zaniepokojenie. Później jednak ten komunikat zmienił się na "FileVault jest wyłączony" i tak jest do tej pory.

 

Wszystko wydawało się być w porządku, ale tak czy siak odpaliłem później EtreCheck (wydaje się to być fajny program, nie znałem go wcześniej, dzięki!) i serię komend którą podałeś. Dały one, odpowiednio, następujące wyniki:

https://pastebin.com/cPBdC07U

https://pastebin.com/wWGWSBnd.

 

 

Dzięki za pomoc!






Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych