Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Zmiana nazwy użytkownika administratora zmieniła jej uprawnienia - brak użytkownika z adminem!


  • Zaloguj się, aby dodać odpowiedź
16 odpowiedzi w tym temacie

#1 arbukiwi

arbukiwi
  • 1 postów

Napisano 18 listopada 2017 - 22:46

Cześć! 

 

Chciałam zmienić nazwę użytkownika. Zmiana się nie wiem czemu nie zapisała, ale użytkownik któremu chciałam zmienić ma teraz uprawnienia standardowe! Nie mogę cofnąć zmian, bo poprzednie dane użytkownika z uprawnieniami administratora już nie działa. 

 

Tylko ten jeden użytkownik miał uprawnienia admina. Więc aktualnie na moim komputerze nie ma żadnego użytkownika z uprawnieniami administratora.

 

Czy ktoś się już z tym spotkał? Czy wiecie jak mi pomóc? ;- ) 



#2 ciotka_paszczaka

ciotka_paszczaka
  • 1 044 postów

Napisano 19 listopada 2017 - 04:42

Możesz stworzyć nowe konto administracyjne poprzez uruchomienie tego standardowego Asystenta ustawień, który pojawia się przy pierwszym uruchamianiu Maka.

1. Uruchom kompa w trypie pojedynczego użytkownika przytrzymując command+s

2. gdy pojawi się czarny ekran konsoli wpisz kolejno: (Przed kropką nie ma spacji)

mount -uw /
rm /var/db/.AppleSetupDone

to usunie plik ustawień i przy ponownym uruchomieniu pojawi się pytanie o stworzenie nowego konta. Konto będzie miało uprawnienie administratora.

3. Wpisz reboot i wciśnij enter

4. Stwórz nowe konto za pomocą asystenta, który się uruchomi. (NIE NADAWAJ MU NAZWY, KTÓRA BYŁA WCZEŚNIEJ UŻYWANA) - pojawią się też pytania o podanie strefy czasowej i tych innych pierdół, nie musisz się nigdzie logować do żadnych Apple ID, konta iCloud itp, klikaj pomiń/nie loguj w tych wypadkach.

 

PS. oczywiście mozna użyć w konsoli komendy dscl i stworzyć grupę i konto administatora ręcznie. Trzeba wpisać więcej komend. Nie ma sensu.


Użytkownik ciotka_paszczaka edytował ten post 19 listopada 2017 - 05:01

Nie czytam prywatnych wiadomości.


#3 cronopioverde

cronopioverde
  • 3 065 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 19 listopada 2017 - 19:35

Poważam Twoje porady zazwyczaj, jednak tym razem ośmielę się nieskromnie nie zgodzić. Zamiast bawić się w Single User Mode i zapamiętywanie komend, ewentualnie przepisywanie, wystarczy szybciutkie:

sudo dscl . append /Groups/admin GroupMembership nazwaużytkownika

„Ślepe” hasło admina wymagane, oczywiście, jak też zastąpienie prawidłową nazwą. I restart.

 

Aaa… co mi tam: mam nawet skrypcik bezbolesny powłoki (chmod a+x mu w mordę, jakby się nie chciał ruszać, oraz wyczyszczenie rozszerzonych atrybutów polecam, gdyby z udostępnianiem przez ichnią chmurę kombinowali), który z standard juzera zrobi szefa:

https://drive.google...iew?usp=sharing


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na tekst bez liter diakrytyzowanych to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#4 Xirr

Xirr
  • 15 postów
  • SkądMX

Napisano 30 maja 2018 - 11:59

Witam serdecznie,

 

niestety wpadłam dziś na ten sam genialny pomysł zmiany nazwy użytkownika na koncie administratora z tego względu, że w sieci mamy dwa komputery o tej samej nazwie.

Wpisałam powyższą komendę, jednak terminal pyta o hasło - poprzednie z wiadomych względów nie działa a jeśli wygenerowało się jakieś randomowe, to nie mam pojęcia gdzie je znaleźć. 

Link już nie działa.

 

Można liczyć na jakąś pomoc?


iMac Pro | iMac | Apple Watch series 3 | iPhone X


#5 ftpd

ftpd

    Nie.


  • 18 386 postów
  • SkądPoznań

Napisano 31 maja 2018 - 09:34

Co to jest 'powyższa komenda'?


---
Jestem Grammar Nazi. Nie znoszę błędów, leni, idiotów i hipsterów.
NIE pomagam przez PW. Mogę co najwyżej pogawędzić.
NIE odpisuję na wiadomości najeżone błędami. Nie chce mi się męczyć oczu.

#6 Xirr

Xirr
  • 15 postów
  • SkądMX

Napisano 01 czerwca 2018 - 07:56

Poważam Twoje porady zazwyczaj, jednak tym razem ośmielę się nieskromnie nie zgodzić. Zamiast bawić się w Single User Mode i zapamiętywanie komend, ewentualnie przepisywanie, wystarczy szybciutkie:

sudo dscl . append /Groups/admin GroupMembership nazwaużytkownika

„Ślepe” hasło admina wymagane, oczywiście, jak też zastąpienie prawidłową nazwą. I restart.

 

Aaa… co mi tam: mam nawet skrypcik bezbolesny powłoki (chmod a+x mu w mordę, jakby się nie chciał ruszać, oraz wyczyszczenie rozszerzonych atrybutów polecam, gdyby z udostępnianiem przez ichnią chmurę kombinowali), który z standard juzera zrobi szefa:

https://drive.google.com/file/d/18lKx6Phe-VVTn3aVYkDYufRgbxmRzZ27/view?usp=sharing

 

 

@ftpd, komenda z cytowanego komentarza powyżej.


iMac Pro | iMac | Apple Watch series 3 | iPhone X


#7 Xirr

Xirr
  • 15 postów
  • SkądMX

Napisano 07 czerwca 2018 - 09:40

Single mode user też nie działa, prawdopodobnie potrzebne hasło roota, bo linijka do wpisywania nie jest aktywna. 

Po wpisaniu komendy nie pokazuje się nic, zero odpowiedzi.

 

Jest na to jakiś inny sposób czy po prostu muszę wszystko cofnąć do stanu przed zmianą nazwy?


iMac Pro | iMac | Apple Watch series 3 | iPhone X


#8 pedros

pedros
  • 1 298 postów
  • SkądWAW, PL

Napisano 07 czerwca 2018 - 12:58

W single user mode masz uprawnienia roota. Kasujesz plik /var/db/.AppleSetupDone i po restarcie zakładasz nowe konto admina.



#9 Xirr

Xirr
  • 15 postów
  • SkądMX

Napisano 07 czerwca 2018 - 13:10

Rozumiem, co mam zrobić, jednak single user mode nie daje mi możliwości wpisania komendy. Widzę jedynie próby pingowania i tyle.


iMac Pro | iMac | Apple Watch series 3 | iPhone X


#10 pedros

pedros
  • 1 298 postów
  • SkądWAW, PL

Napisano 07 czerwca 2018 - 15:01

A napisz co dokładnie robisz, żeby w ten tryb pojedynczego użytkownika wejść? Bo mam wrażenie że o dwóch różnych rzeczach rozmawiamy…



#11 Xirr

Xirr
  • 15 postów
  • SkądMX

Napisano 07 czerwca 2018 - 15:24

Przy uruchamianiu przytrzymuję CMD+C.

Pokazuje się czarny ekran i mnóstwo linijek tekstu/komend/atrybutów, nie mam pojęcia jak to się fachowo nazywa. 


iMac Pro | iMac | Apple Watch series 3 | iPhone X


#12 tomekkos

tomekkos
  • 784 postów
  • SkądWarszawa

Napisano 07 czerwca 2018 - 18:40

chyba miało być cmd+s...


Komputer:  Mac Pro, macOS Mojave, Intel Xeon Quad Core 3,7 GHz, 64 GB DDR 3, Dual AMD Fire Pro D300, 1 TB SSD PCIe, 8 TB LaCie Thunderbolt 2 RAID 0

Telefon:  iPhone SE 32 GB, iOS 12, odtwarzacz: Fiio X5 III + Sennheiser HD 598


#13 Xirr

Xirr
  • 15 postów
  • SkądMX

Napisano 11 czerwca 2018 - 07:35

Oczywiście miałam na myśli CMD+S.

Pracuje jako grafik, więc częściej mam w głowie CMD+C niż CMD+S, stąd pomyłka.  :o


iMac Pro | iMac | Apple Watch series 3 | iPhone X


#14 Xirr

Xirr
  • 15 postów
  • SkądMX

Napisano 19 czerwca 2018 - 10:54

Żeby już nikogo nie męczyć, a żeby pomóc osobom, którym również zachciało się zmieniać nazwy użytkownika na koncie administratora - klawiatura bluetooth nie działa pod trybem Single User Mode.

 

Kolejność wszystkich komend, które należy wpisać próbując założyć nowe konto administratora w trybie SUM:

/sbin/fsck -fy 
/sbin/mount -uw/
rm /var/db/.AppleSetupDone
reboot

Po reboocie pojawia się kreator nowego konta. Ważnym jest by stworzyć NOWE konto a nie backup poprzedniego.

Po zalogowaniu przydzielamy uprawienia administratora i działa.


iMac Pro | iMac | Apple Watch series 3 | iPhone X


#15 Patrycja P

Patrycja P
  • 9 postów

Napisano 14 sierpnia 2018 - 22:26

Witam, 

Odświeżę temat. Zakupiłam komputer i niestety jest na nim administrator ale nie jestem nim ja. Nie pokazuje mi się hasło do logowania, do komputera tylko kiedy cokolwiek chce zmienić na komputerze no i mam problemy z instalacją programów. Niestety nie będę miała kontaktu z firmą do poniedziałku a bardzo mi zależy na uzyskaniu uprawnień. Może ktoś szybciej coś poradzi. Nie chciałam bym robić recovery przez wifi ponieważ miałam z tym problem na tym komputerze a niestety nie posiadam dysku instalacyjnego. No chyba że zrobię pendrive. Ale może udało by się bez.

 

Próbowałam powyższe techniki jednak na nic się to nie zdało. Nie otrzymałam możliwości startowania od początku. Jakie otrzymuje informacje po robieniu powyższych komend dostaje taką komendę:

override-w---r--/root/wheel/var/db/.applesetupdone? wpisuje :yes i dostaje informację taką:Read drive only. 

Koniec działań bo daje "return" i muszę zrestartować kompa. 

 

Czy może jest jakiś inny sposób czy jednak pozostaje mi tylko pendrive lub czekanie do poniedziałku? 

 

Z góry dziękuję za pomoc. 

 

Pozdr. 

Pat


Temat nie aktualny nieaktualny udało się dzięki tej stronie :)

 

https://www.wikigain.com/reset-forgotten-mac-os-x-el-capitan-password/

 

Pozdr

Pat



#16 raingod

raingod
  • 1 postów

Napisano 04 stycznia 2019 - 00:41

Czołem.

mam dokładnie identyczny problem, ale też inny - command+s u mnie nie działa. Siedzę nad komputerem od kilku godzin i nie wiem już co robić :(

 



#17 cronopioverde

cronopioverde
  • 3 065 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 04 stycznia 2019 - 15:51

@up jeśli masz założone firmware password albo Twój komputer jest z tych nowszych, z T2, jak wspomniano w tym artykule, nie będziesz mógł uruchomić urządzenia w trybie Single User. W drugim przypadku postępuj zgodnie z zaleceniami w cytowanym artykule wsparcia co do wpisywania komend unixowych, w pierwszym natomiast – zdejmij uprzednio hasło sprzętowe.


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na tekst bez liter diakrytyzowanych to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych