Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie

MacBook Air 13 Mid 2013 - nie uruchamia się system po wymianie dysku SSD


  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 Geronimmo

Geronimmo
  • 3 postów

Napisano 13 listopada 2018 - 10:51

Witam serdecznie!

Jestem posiadaczem MacBook Air 13" - wersja Mid 2013. Otrzymałem go bez dysku SSD i niestety nie posiadam żadnego fabrycznego dysku dla Apple. Aby wykorzystać dysk M.2 PCIe, który posiadam, zakupiłem adapter do dysku SSD M.2 NVMe.

Po uruchomieniu komputera z opcją CMD+R uruchamia się instalator systemu w wersji 10.8 (Mountain Lion). W tej wersji systemu niestety dysk jest niewidoczny do instalacji. Po przeszukaniu wiedzy w internecie znalazłem informację, że obsługa dysków PCIe możliwa jest w Macbookach od wersji systemu 10.13 (High Sierra). W związku z powyższym przygotowałem sobie bootowalny pendrive z najnowszą wersją 10.14.1. Faktycznie na tej wersji instalatora dysk został wykryty i bez problemów udało mi się dysk sformatować oraz zainstalować MacOS. Jednakże po instalacji i wyciągnięciu pendrive system "nie podnosi się" - po chwili od włączenia wyświetlany jest katalog ze znakiem zapytania. Przy uruchomieniu systemu z opcją ALT nie jest widoczny ten dysk wewnętrzny.

Przystąpiłem zatem do instalacji systemu na zewnętrzny nośnik SSD podłączony do komputera przez port USB - co ciekawe, w tym przypadku nie mam żadnych problemów. Komputer uruchamia się z dysku USB w najnowszej wersji, a co najciekawsze - dysk wewnętrzny jest widoczny i mogę normalnie z nim pracować...

Sprawdziłem również dysk przez program DriveDx - program widzi ten dysk wewnętrzny i wyświetla, że wszystkie parametry są prawidłowe.

 

Próbowałem również przywrócić pracujący i skonfigurowany system przez opcję "odtwarzania" w narzędziach dysku, jak również przez TimeMachine, ale w obu przypadkach jest tak samo - komputer nie bootuje z dysku wewnętrznego.

 

Sprawdziłem również wersje EFI oraz SMC - dostępne aktualizacje na stronie Apple wyświetlają informację, że już posiadam te wersje...

 

Bardzo proszę o pomoc, w świecie MacOS jestem świeży i już nie wiem co więcej mogę zrobić.

 

Trochę informacji, które mogą być przydatne:

Identyfikator modelu: MacBookAir6,2

Wersja Boot ROM: MBA61.0099.B19

Wersja SMC (system): 2.13f15

 

Zamontowany dysk wewnętrzny:

ADATA SX8200NP

Protokół: PCI-Express

Typ mapy partycji: GPT (tablica partycji GUID)

System plików: Kronikowany HFS+



#2 Geronimmo

Geronimmo
  • 3 postów

Napisano 14 listopada 2018 - 14:01

Dodam jeszcze pewne moje działania, które wykonałem w międzyczasie:

1. Po uruchomieniu komputera w trybie bootowania z USB odpaliłem terminal i wykorzystałem polecenie "bless" do ustawienia bootwania dysku twardego

bless --setBoot --device /Volumes/disk0s2

 

To zmieniło parametr "Uruchamialny" w informacjach o dysku na TAK.

 

Wykonałem jeszcze raz format dysku wewnętrznego oraz świeżą instalację, jednakże dalej nie bootuje systemu z tego dysku  :(

 

Wykonując teraz polecenie bless --info otrzymuję komunikat:

 

finderinfo[0]: 146504 => Blessed System Folder is /Volumes/MacOS/System/Library/CoreServices

finderinfo[1]: 457098 => Blessed System File is /Volumes/MacOS/System/Library/CoreServices/boot.efi

finderinfo[2]:      0 => Open-folder linked list empty

finderinfo[3]:      0 => No alternate OS blessed file/folder

finderinfo[4]:      0 => Unused field unset

finderinfo[5]: 146504 => OS X blessed folder is /Volumes/MacOS/System/Library/CoreServices

64-bit VSDB volume id:  0x0A51BFC7321D5010



#3 D4n2

D4n2
  • 59 postów

Napisano 15 listopada 2018 - 10:50

Cześć,

 

Jak przy starcie przytrzymujesz klawisz Option to nie uruchamia się menadżer uruchamiania, gdzie możesz wybrać z którego dysku ma startować ? Jak się uruchomi system to wchodzisz w preferencje -> dysk startowy i ustaw już na stałe...

 

bless --setBoot --device /Volumes/disk0s2

 

dobrze już nie pamiętam ale nie powinno być:

 

bless --mount "/Volumes/disk0s2" -- setBoot

 

?


Użytkownik D4n2 edytował ten post 15 listopada 2018 - 11:10


#4 Geronimmo

Geronimmo
  • 3 postów

Napisano 16 listopada 2018 - 09:39

Cześć - dzięki za odpowiedź.

Jak uruchamiam komputer z klawiszem Option bez podłączonych urządzeń przez USB nie wyświetla mi się żaden dysk. Jak podłącze dysk SSD przez USB to pokazują się dwie opcje - partycja z systemem (w moim przypadku Mac2) oraz partycja z odzyskiwaniem 10.14.1.

Jak uruchomię komputer z podłączonym moim drugim dyskiem gdzie mam system MacOS i wchodzę w Preferencje systemowe -> Dysk startowy to mam możliwe dwie opcje: Mac2 (zewnętrzny dysk) i MacOS (wewnętrzny dysk) - odblokowuję zmianę, zaznaczam ten wewnętrzny a następnie "Uruchom ponownie". Komputer się uruchamia ponownie i niestety nie może odpalić dysku po chwili wyświetlając katalog ze znakiem zapytania  <_<


Wpisałem wskazane przez Ciebie polecenie z lekką modyfikacją, a mianowicie:

bless --mount "/Volumes/MacOS" --setBoot

i dostałem taką informację zwrotną:

Could not set boot device property: 0xe00002bc


Zresetowałem jeszcze komputer i wykonałem te polecenie na terminalu w trybie odzyskiwania - tutaj błąd mi się nie wyświetlił. Dodatkowo zgodnie ze znalezioną poradą w necie wyłączyłem integrację poleceniem csrutil disable - jednakże dalej nic - MacOS nie startuje mi z dysku wewnętrznego...  :unsure:



#5 iDoit Serwis Apple

iDoit Serwis Apple
  • 450 postów
  • Płeć:
  • Skądwarszawa

Napisano 19 listopada 2018 - 11:33

Możliwości może być dużo, bez dokładniejszej diagnozy może być ciężko od razu trafić w źródło problemu. Najlepiej przynieść sprzęt na darmową diagnoze, nic Cie to nie kosztuje a coś już będziesz wiedział więcej. Może dysk uszkodzony, może coś z systemem, może slot jest uszkodzony.


Pogwarancyjny Serwis Apple Warszawa
Warszawa, ul. Gagarina 31

 

Pogwarancyjny Serwis iPhone Wrocław

Wrocław, Kościuszki 65





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych