Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Bootcamp nie uruchamia instalatora


  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 myfakinapple

myfakinapple
  • 2 postów

Napisano 18 kwietnia 2017 - 21:25

Korzystam z MBA late 2015, OS Yosemite. Próbuje wgrać windows 10 przez bootcamp'a. Program normalnie formatuje USB, pobiera i zgrywa na niego oprogramowanie windowsa, jednak po dzieleniu dysku na partycje, komputer uruchamia się ponownie z OSX, nie z partycji BOOTCAMP. W dysku startowym widzę tylko partycje OSX. Partycja BOOTCAMP  jest widoczna w finderze, ale nie potrafię jej uruchomić.

 

Wobec czego mam partycję BOOTCAMP (2mb zajęte z 60GB) i mam USB z nagranym instalatorem Win 10 ( waży nieco ponad 8gb z 16gb) - wszystko zrobione przez program bootcamp. W jaki sposób mogę teraz zainstalować system na wolnej partycji i uruchomić ją?

 

PS Proces przywracania dysku do jednej partycji i odpalania bootcamp'a od nowa (z i bez pobierania oprogramowania) powtarzałem kilkukrotnie - efekt zawsze ten sam - pusta partycja + USB z nagranym instalatorem.



#2 imrik

imrik
  • 3 450 postów
  • SkądWrocław, Poland

Napisano 19 kwietnia 2017 - 09:41

To co napiszę poniżej to tylko jeden z możliwych wariantów. Możliwe że w twoim przypadku przyczyna jest inna.

 

Miałem coś podobnego i powodem był fakt, że komputer posiadał porty USB 3.0 a pendrive miałem USB 2.0 i z jakiegoś powodu instalator windows nie zgłaszał się po restarcie komputera na koniec procedury asystenta Bootcamp.

 

Poradziłem w taki sposób, że wykorzystałem komendę bless aby wymusić restart komputera z obsługą USB 2.0

sudo bless -mount "/Volumes/PENDRIVE_INSTALACYJNY_WINDOWS/" -legacy -setBoot -nextonly

Sprowadziło się to do uruchomienia asystenta Bootcamp, przejścia przez niego do ostatniego etapu, wprowadzenie komendy w terminal i dokończenie procedury Bootcamp (która kończy się restartem maszyny).

 

Pamiętaj, że podczas instalacji windows komputer uruchomi się ponownie raz lub dwa razy - możliwe że w połowie instalacji windows (po zrzuceniu plików instalacyjnych z pendrive na partycję Bootcamp) wrócisz do MacOS. Powinno wystarczyć ponowne uruchomienie komputera z partycji Bootcamp wtedy (wciśnięty klawisz alt na klawiaturze).



#3 myfakinapple

myfakinapple
  • 2 postów

Napisano 19 kwietnia 2017 - 12:41

To co napiszę poniżej to tylko jeden z możliwych wariantów. Możliwe że w twoim przypadku przyczyna jest inna.

 

Miałem coś podobnego i powodem był fakt, że komputer posiadał porty USB 3.0 a pendrive miałem USB 2.0 i z jakiegoś powodu instalator windows nie zgłaszał się po restarcie komputera na koniec procedury asystenta Bootcamp.

 

Poradziłem w taki sposób, że wykorzystałem komendę bless aby wymusić restart komputera z obsługą USB 2.0

sudo bless -mount "/Volumes/PENDRIVE_INSTALACYJNY_WINDOWS/" -legacy -setBoot -nextonly

Sprowadziło się to do uruchomienia asystenta Bootcamp, przejścia przez niego do ostatniego etapu, wprowadzenie komendy w terminal i dokończenie procedury Bootcamp (która kończy się restartem maszyny).

 

Pamiętaj, że podczas instalacji windows komputer uruchomi się ponownie raz lub dwa razy - możliwe że w połowie instalacji windows (po zrzuceniu plików instalacyjnych z pendrive na partycję Bootcamp) wrócisz do MacOS. Powinno wystarczyć ponowne uruchomienie komputera z partycji Bootcamp wtedy (wciśnięty klawisz alt na klawiaturze).

Niestety, terminal wyświetla "Legacy mode not supported on this system". Korzystanie z pendrive'a 3.0 Może mieć na to wpływ?



#4 DanielF

DanielF
  • 4 993 postów
  • SkądSiedlce

Napisano 19 kwietnia 2017 - 12:49

Nie każdy pendrive współpracuje dobrze z makiem, sprawdź jakiś inny


Fallout ...war, war never changes...

#5 imrik

imrik
  • 3 450 postów
  • SkądWrocław, Poland

Napisano 19 kwietnia 2017 - 14:29

Generalnie właściwym rozwiązaniem jest po pierwsze korzystanie z odpowiedniego pendrive (pasującego pod porty komputera i włożonego w prawidłowy port USB) i prawidłowego instalatora Windows (czyli standardowego ze strony MS, te z płyt czy z innych źródeł nie zawsze pykną). Wymagania Apple ma na swojej stronie, lecz generalnie na nowszym sprzęcie pod kontrolą El Capitan czy Sierra pójdzie minimum Windows 8.1 albo Windows 8. Jest to związane z tym, że Bootcamp od jakiegoś czasu ładuje instalator windows jedynie w pełnym trybie EFI, a na to wsparcie MS dał dopiero w Windows 8 albo 8.1.

 

Możesz próbować to obejść korzystając właśnie z bless (umożliwiającą firmware udawanie BIOS, a interfejsy udają USB 2.0) ale z tego co czytam dokumentację SIP blokuje tą komendę nawet dla roota. Rozwiązania są dwa:

- zdjąć SIP (niezalecane)

- W teorii wybranie pendrive jako dysku startowego z preferencji systemowych -> Dysk Startowy powinno zadziałać. Nie jestem pewien czy ten pendrive będzie tam po prostu dostępny jako opcja.

 

Swoją drogą jeśli po włożeniu przygotowanego pendrive przez asystenta bootcamp i uruchomieniu komputera z wciśniętym klawiszem alt nie widzisz tego pendrive ani jako EFI ani normalnie to na 99% oznacza, że powinieneś użyć innego obrazu ISO Windowsa - zgodnego z wymaganiami Apple.

https://support.appl.../en-us/HT204048


Użytkownik imrik edytował ten post 19 kwietnia 2017 - 14:32





Użytkownicy przeglądający ten temat: 2

0 użytkowników, 2 gości, 0 anonimowych