Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Nie mogę zainstalować Windowsa na MacBooku - nie takie partycje


  • Zaloguj się, aby dodać odpowiedź
9 odpowiedzi w tym temacie

#1 suchypop

suchypop
  • 14 postów

Napisano 05 marca 2014 - 11:45

Witam jestem tu nowy. Od razu mówię, że przewertowałem chyba wszystkie tematy na forum ale nie bardzo to pomogło. Mój problem polega na tym, że podczas próby instalacji systemu Windows 8 z Boot Camp jest problem z partycjami. Partycje wydzielam automatycznie za pomocą asystenta boot camp. W trakcie instalacji podczas wyboru partycji do zainstalowania systemu otrzymuję komunikat: "Nie można zainstalować systemu Windows na tym dysku. Wybrany dysk zawiera tabelę partycji MBR. W systemach z interfejsem EFI, system Windows można instalować tylko na dyskach GPT." Zastosowałem wszystkie opcje jakie znalazłem na forum, łącznie z wyczyszczeniem dysku do zera, jednak nic to nie dało i cały czas występuje ten sam problem. W macu mam 2 dyski SSD (z systemem) i HDD (na dane i tutaj chciałem zamontować windowsa). Wndows jest mi potrzebny do kilku programów, których nie ma w wersji na OS X, a maszyna wirtualna nie bardzo sobie z nimi radzi. Nie mam już pomysłu co zrobić aby problem zniknął. Jeśli ktoś miał podobny problem i go rozwiązał prosiłbym o pomoc. Mam Macbooka Pro i system próbuję zamontować za pomocą zewnętrznego napędu.

#2 JerryEvo

JerryEvo
  • 3 921 postów
  • Płeć:

Napisano 05 marca 2014 - 16:04

Czyli czyszcząc dysk w Narzędziu Dyskowym wybrałeś "Partycje", w "Układ partycji:" wybrałeś "Schemat 1 partycji", kliknąłeś przycisk "Opcje" i tam wybrałeś "Tablica partycji GUID", a następnie zatwierdziłeś przyciskiem "OK". Następnie w Format wybrałeś "Mac OS Extended (kronikowany)" i nacisnąłeś "Zastosuj". Tak przygotowany dysk potraktowałeś Asystentem Boot Camp?

#3 suchypop

suchypop
  • 14 postów

Napisano 05 marca 2014 - 16:27

Na początku zrobiłem w ten sposób, że mając jedną partycje (były tam jakieś pliki z danym, których nie usuwałem) z "Tablica partycji GUID" użyłem asystenta boot camp do wydzielenia partycji na windows. Nic to jednak nie dało. Później zrobiłem tak jak napisał JerryEvo. Ten sam problem. Próbowałem nawet sformatować partycję na NTFS pod OS X i też to nie przeszło.

#4 JerryEvo

JerryEvo
  • 3 921 postów
  • Płeć:

Napisano 05 marca 2014 - 16:31

Przepraszam, wcześniej nie zwróciłem na to uwagi. BootCamp nie umożliwia instalowania Windows na innym dysku niż podstawowy. Musiałbyś wrzucić ten dysk jako główny (i jedyny), zainstalować Windows, a następnie wrócić do aktualnej konfiguracji dysków.

#5 suchypop

suchypop
  • 14 postów

Napisano 05 marca 2014 - 16:43

Dobra, a jak zostawie tylko HDD podłączony, przygotowany pod instalację windowsa to czy ona ruszy? Czy muszę postawić na tym dysku OS X i wtedy dopiero instalować windowsa?

#6 JerryEvo

JerryEvo
  • 3 921 postów
  • Płeć:

Napisano 05 marca 2014 - 17:30

Teoretycznie można zainstalować tylko system Windows jednak lepiej byłoby zainstalować Mac, a następnie użyć Asystenta Boot Camp i zostawić na Mac OS choćby 10GB. Przy okazji jak coś Ci się stanie z systemem na dysku podstawowym to będziesz miał jak łatwo to diagnozować.

#7 suchypop

suchypop
  • 14 postów

Napisano 05 marca 2014 - 17:40

Dzięki za pomoc.

#8 suchypop

suchypop
  • 14 postów

Napisano 06 marca 2014 - 23:27

Widnows został zainstalowany. Musiałem postawić na HDD od nowa OS X z niego uruchomić bootcamp. Następnie w momencie wyboru partycji wystąpił ten sam błąd i w tym momencie sformatowałem cały dysk i wydzieliłem od nowa partycje i ruszyła instalacja. Wszystko się zamontowało i działa. Teraz jest tylko problem ze sformatowaniem pozostałej przestrzeni dyskowej pod OS X, ale to już inna bajka ;)

#9 towal

towal
  • 821 postów
  • SkądRacibórz

Napisano 28 marca 2014 - 15:52

Witam. Trochę późno ale może się przyda. Jak stawiasz system od nowa na to Mavericks w terminalu wpisz (jak będziesz świeżo po dzieleniu dysku) sudo gdisk /dev/disk0 (prawdopodobnie disk0 co sprawdzisz wpisując po tym p, jeżeli nie to disk1) następnie 1)x 2)n 3)w 4)y W tym momencie masz hybrydową. Po restarcie najlepiej zrestartuj jeszcze pamięć PRAM poprzez cmd+alt+p+r podczas uruchamiania systemu jak dojdzie do jabłka to powinien się zrestartować i wtedy instalujesz spokojnie Win. Pozdro

#10 suchypop

suchypop
  • 14 postów

Napisano 15 kwietnia 2014 - 17:05

Mam w końcu jeden dysk ssd na którym mogę postawić osx i winde. Problem z instalacją występuje nadal. Podpowiedź użytkownika towal nie pomogła w rozwiązaniu problemu. Partycje wyglądają tak: disc0 - 200mb disc0 - 60 GB na osx Tutaj zadziałał asystent bootcamp: disc0 - 128 mb disc0 - 60 GB partycja bootcamp Czyli mam 4 partycje. Przy wyborze i sformatowaniu partycji bootcamp według instrukcji za każdym razem jest komunikat ze zdjęcia, nie ważne która partycja została wybrana. [ATTACH=CONFIG]21142[/ATTACH] Instalacja windowsa ruszy pod warunkiem że wszystkie partycje zostaną usunięte i stworzone od nowa. Ale tedy leci OSX. Może ma ktoś jeszcze jakieś pomysły to proszę o pomoc.




Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych