Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Polska czcionka w ściąganych napisach do filmów


  • Zaloguj się, aby dodać odpowiedź
16 odpowiedzi w tym temacie

#1 all999

all999
  • 446 postów
  • SkądWarszawa

Napisano 18 stycznia 2012 - 15:47

Od jakiegoś czasu (chyba od upgrade'u do Liona) mam problem z polską czcionką w napisach do filmów. Nie tyle w samym odtwarzaczu a po prostu w pliku z napisami. Pliki te ściągają się z krzaczkami zamiast polskich znaków. Zwykle ściągam przez QNapi ale próby pobrania napisów bezpośrednio ze strony kończą się podobnie. Te same napisy pobrane pod windowsem (VirtualBox) posiadają normalnie polską czcionkę. Mój odtwarzacz to Movist. Macie jakieś pomysły?

#2 k344

k344
  • 61 postów
  • SkądWarszawa, PL

Napisano 18 stycznia 2012 - 20:19

po ściągnięciu napisów nie otwieraj ich w edytorze tekstu w celu sprawdzenia, tylko wrzucaj od razu do odtwarzacza. Otwieranie w edytorze może zmieniać kodowanie tekstu i jak nie rozpozna polskich znaków zamienia je na "krzaczki" i tak już zostają. Tak zauważyłem z własnych doświadczeń.

#3 highbrass

highbrass
  • 78 postów

Napisano 18 stycznia 2012 - 21:16

Mam podobny problem z QNapi, krzaczki występują nawet bez otwierania , pojawiają się nawet na DVD, czy BL Z napisami z Napiprocekt pobranymi pod Win nie ma tego problemu.

#4 all999

all999
  • 446 postów
  • SkądWarszawa

Napisano 18 stycznia 2012 - 23:49

po ściągnięciu napisów nie otwieraj ich w edytorze tekstu w celu sprawdzenia, tylko wrzucaj od razu do odtwarzacza. Otwieranie w edytorze może zmieniać kodowanie tekstu i jak nie rozpozna polskich znaków zamienia je na "krzaczki" i tak już zostają. Tak zauważyłem z własnych doświadczeń.


Ta sama sytuacja występuje bez otwierania napisów. Zacząłem je otwierać dopiero kiedy zauważyłem problem.

#5 krakers

krakers
  • 8 135 postów
  • SkądNibylandia

Napisano 19 stycznia 2012 - 00:08

Jeżeli otwierasz plik z napisami w TextEdicie to krzakami się nie sugeruj. U mnie też są krzaki w nim a w filmie polskie znaki wyświetlają się poprawnie.

#6 all999

all999
  • 446 postów
  • SkądWarszawa

Napisano 19 stycznia 2012 - 13:38

Jeżeli otwierasz plik z napisami w TextEdicie to krzakami się nie sugeruj. U mnie też są krzaki w nim a w filmie polskie znaki wyświetlają się poprawnie.


Krzaki są i w odtwarzaczu i w pliku.

#7 krakers

krakers
  • 8 135 postów
  • SkądNibylandia

Napisano 19 stycznia 2012 - 13:45

Nie używałem Movista nigdy, ale nie trzeba tam kodowania przypadkiem przestawić jak w VLC żeby były polskie znaki?

#8 all999

all999
  • 446 postów
  • SkądWarszawa

Napisano 19 stycznia 2012 - 22:52

Nie używałem Movista nigdy, ale nie trzeba tam kodowania przypadkiem przestawić jak w VLC żeby były polskie znaki?


Mam ustawiony fabrycznie taki oto zestaw kodowania:
Unicode (UTF-8)
Unicode (UTF-16)
Ucicode (UTF-16BE)
Ucicode (UTF-16LE)
Ucicode (UTF-32)
Ucicode (UTF-16BE)
Ucicode (UTF-16LE)
Central European (Mac OS)

#9 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 20 stycznia 2012 - 08:19

Napisy pobierane z NapiProjektu mają polskie znaki w CP-1250.

#10 all999

all999
  • 446 postów
  • SkądWarszawa

Napisano 22 stycznia 2012 - 19:27

Napisy pobierane z NapiProjektu mają polskie znaki w CP-1250.


Nie mam możliwości wyboru takiego kodowania w programie, którego używam.

#11 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 22 stycznia 2012 - 20:29

Nie mam możliwości wyboru takiego kodowania w programie, którego używam.


Może występuje pod inną nazwą, np. Windows 1250? Windows Latin-2? Code Page 1250? Windows Central European?

#12 all999

all999
  • 446 postów
  • SkądWarszawa

Napisano 24 stycznia 2012 - 01:17

Może występuje pod inną nazwą, np. Windows 1250? Windows Latin-2? Code Page 1250? Windows Central European?


Dodanie kodowania nic nie zmienia. Ściągnięte pliki .srt również w innych odtwarzaczach wyświetlają krzaki zamiast polskich znaków. Nawet na Apple TV z aTV Flash jest to samo. Wygląda więc na to że pliki są "psute" podczas zapisu na dysk.

#13 biosorcerer

biosorcerer
  • 13 postów

Napisano 25 stycznia 2012 - 10:18

Konwertuj pliki z napisami do UTF-8 - polecam TextWrangler - świetny edytor - do ściągnięcia w AppStore...

#14 eviltomek

eviltomek
  • 780 postów
  • SkądDębica

Napisano 04 maja 2013 - 16:58

rozwiazal ktos ten problem?

#15 Śfieży

Śfieży
  • 909 postów

Napisano 04 maja 2013 - 21:42

W Movist ustawia się język napisów na "Środkowo europejski (Windows Latin 2)". Ustaw to w programie bez otwartego żadnego filmu i zamknij Movist. Od następnego uruchomienie będzie to traktował jak ustawienie domyślne. Przynajmniej tak jest w starej darmowej wersji 0.6.8.

#16 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 07 maja 2013 - 16:57

Konwerter do napisów: http://myapple.pl/pr...tml#post1520251

Bierzemy napisy txt z NapiProjektu, przeciągamy do ikonki konwertera, plum — i kodowanie zostało zmienione na UTF-8.

#17 Jurenio

Jurenio
  • 1 postów

Napisano 15 października 2013 - 09:50

Witam. Wyznaję proste rozwiązania i odkryłem takie wczoraj. Nie wymaga ściągania żadnego softu:
1. Otwieram napisy w systemowym Text Edicie, ale nie przez kliknięcie, tylko przez menu Open. Z listy kodowań wybieram ostatnie, czyli latin-2.
To JEDYNE, w którym plik otwiera się z poprawnymi znakami.
2. Zapisuję plik z kodowaniem UTF-8.
Koniec, gotowe. 1 minuta roboty.

- - - Połączono posty - - -

Zapomniałem dodać słowo wyjaśnienia. Kiedy się klika w plik lub go przeciąga na program, Text Edit otwiera napisy w trybie automatycznej detekcji kodowania. I głupek wybiera latin-1, który pokazuje krzaki. Dlatego trzeba otwierać przez Open, wtedy można ręcznie wybrać kodownie latin-2.

Druga ważna rzecz - zapiasanie napisów w formacie UTF-8 spowoduje, że każdy komp, każdy telewizor i każdy odtwarzać będą to poprawnie czytać.




Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych