Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Pomocy: bad sektory?


  • Zaloguj się, aby dodać odpowiedź
11 odpowiedzi w tym temacie

#1 iMuck

iMuck
  • 510 postów
  • Skądstolyca

Napisano 20 lipca 2005 - 18:40

Niewątpliwą przyjemność używania nowonabytego iBooka popsuło mi podejrzenie, że jego dysk twardy jest uszkodzony. System zachowywał się dość dziwnie. Choć nie zwalniał ( a dysk wciąż pracuje cicho), to jednak nie zapamiętywał ustawień, wywalał regularnie iScrolla etc. Parę godzi temu włączyłem mojego małego, białego przyjaciela i ... okazało się, że folder w którym trzymałem całkiem sporo całkiem wartościowych danych zniknął bez śladu, natomiast system wyświetlił informacje, że alias nie może zostać otwarty (zrobiłem alias w kolumnie aplikacje, dokumenty etc. do tego folderu), ponieważ folder do którego się donosi jest niedostępny. Po otwarciu folderu z poziomu dysku, okazało się ze jest w im tylko jeden plik z kilkudziesięciu, które się tam znajdowały poprzednio. Chyba nie ma wątpliwości, ze zeżarł je dysk. Moje pytanie brzmi: jakie narzędzia do diagnozowania dysku, odzyskiwania danych etc. polecacie? Na piecyku miałem BadCopyPro, które raz pomogło mi odzyskać troche danych z klastra dotniętego uszkodzeniem. Czy jest coś podobnego na maki?

#2 MacDada

MacDada

    MyApple Team

  • 7 237 postów
  • Skąd3city

Napisano 20 lipca 2005 - 19:09

Może jednak lepiej jak skontaktujesz się z SADem??

#3 janek

janek
  • 236 postów
  • SkądŁódź

Napisano 20 lipca 2005 - 19:17

Z Twoich ostatnich postów wynikało, że rzeczywiście coś jest nie tak z jakimś elementem hardwearu i właściwie SAD powinien zająć się Twoimi kłopotami (jak to wyjdzie w praktyce to się okaże) i na dobrą sprawę powini też odzyskać dane. Jak teraz coś zrobisz na własną rękę to mogą nie uznać. Chyba, że Ci się śpieszy. Ja tylko raz miałem problem z dyskiem w laptopie (travelstar - okropne cholerstwo, a apple montował to seryjnie). Wyjęłem dysk, wsadziłem do zewnętrznej kieszeni FiWi i po prostu przetestowałem zwykłym Nortonem i zadziałało. Ale w Twoim wypadku to oczywiście narusza zasady gwarancji. Swoją drogą szkoda, pierwszy kontakt z makiem i takie okropne problemy. Mam nadzieję, że wszystko będzie ok.

#4 agrzesko

agrzesko
  • 381 postów
  • SkądZielona Góra

Napisano 20 lipca 2005 - 20:20

Nie przejmuj sie! tez mialem to w nowym iBooku G4... tzn nie wiem dokladnie czy "to". Ale musialem wymienic dysk. tzn SAD wymienil. Ja sprawdzalem plytka Hardware Test.Powinienes dostac ja razem z systemem i komputerem. Ustawic tam dokladne sprawdzanie i powinien wykryc blad. Jest tez opcja naprawiania i/lub weryfikacji bledow na dysku czy cos takiego bodajrze w Disc Utility z plytki intsalacyjnej, albo z tej plytki Apple Hardware Test. U mnie ta plytka wykryla blad jak juz calkowicie dysk padl i MAc OS X sie nie uruchomil :o ... Napisalem wszystko do Cortlandu (tam kupowalem) dokladnie co sie dzialo jakie komunikaty co napisala mi plytka Hardware TEst itp... i serwisant odrazu powiedzial "aha... ok wysylamy do SADu" ... spisal cos tam zabrali kompa i musialem czekac. Ale teraz juz jest wszystko wporzadku. Tylko Ku*** nie wiem czemu. Mialem dysk innej firmy na poczatku..(MATSHITA) chyba cyz cos takiego. A teraz mi dali: SAMSUNG MP0402H :/ no ale juz nie marudze i uzywam sobie tego sprzeciku.

#5 janek

janek
  • 236 postów
  • SkądŁódź

Napisano 20 lipca 2005 - 20:38

wiesz, odkąd padł mi ten travelstar (seryjny), też mam samsunga (był tani - to fakt), zajrzę pod klawirę... dokładnie tego samego co Ty. Już 3-mce i nie mam problemów. Więc mam nadzieję, że wszystko będzie ok. Sory za mały off iMuck, co do hardware test to rzeczywiście agrześko ma rację!!! wypróbuj koniecznie.

#6 iMuck

iMuck
  • 510 postów
  • Skądstolyca

Napisano 20 lipca 2005 - 20:46

Sęk w tym, że moj iBook nie jest nowy. Jest używany. Nie mam na niego gwarancji. Napisałem tylko, że go niedawno kupiłem. Jest prawie pół roku po gwarancji, także żaden SAD nie wyświadczy mi żadnej przysługi. Gdybym miał gwarancje nawet bym nie pytał, tylko od razu oddał go do naprawy. Na szczęscie kupiłem go z kompletnym pakietem oprogramowania, także mam Apple Hardware Test. Zaraz go nim przelecę :wink:. Interesuje mnie jednak również kwestia narzędzi do odzyskiwania danych. Jesli coś przyjdzie Wam do głowy, to będę wdzieczny. Z ostatniej chwili: zarówno quick jak i extended hardware test przeszedł pomyślnie, ale przyznam, że dysk (mass storage) był testowny chyba najkrócej ze wszystkich komponentów (!). Nie wiem czy się cieszyć z wyniku, bo ciągle mam pewne obawy. W koncu rzeczy nie znikają z dysku ot tak sobie! Aha, zainstalowałem tez mały rogamik SMART Reporter, który ma przekazywać komunikaty o sprawności dysków wyposazonych w S.M.A.R.T i też wszystko wydaje się OK. Sądzę, że przeinstaluję mojemu iBookowi system zanim wyciągnę z niego dysk w celu dokładniejszych badań (mam przejściówkę, dzięki której mogę podłaczyć ten dysk do wnętrzności mojego ręcznie składanego pieca i przesłuchac go przy pomocy pecetowskich toolsów). Jednak gdyby przyszedł wam jakiś program diagnostyczny dla maków do głowy, to może zaoszczędzilibyście mi rozbierania mojego laptopa na czynniki pierwsze :wink: PS: Disk Utility to pierwsze narzędzie, które mi przyszło do głowy, ale z poziomu systemu nie ma w nim niczego do tego typu testu,a lbo poprostu takiej opcji nie widzę :cry:

#7 Mac_Abra

Mac_Abra
  • 674 postów
  • Skądsskątowni

Napisano 20 lipca 2005 - 23:26

Odpowiedź brzmi:

NORTON (i jeszcze raz Norton... Ok, wiem, że to drogo, ale może na potrzebę jednego testu uda się program tylko "wypożyczyć"? ;) )

Jak Ci będzie mało to przeszukaj VersionTracker (i tak uważam, że najlepsze narzędzia diagnostyczne miała dziewiątka :D )

(już późno i ciężkawo mi się myśli, więc o odzyskiwaniu może jutro...)

#8 janek

janek
  • 236 postów
  • SkądŁódź

Napisano 21 lipca 2005 - 06:23

iMuck skąd jesteś? Co do nortona to mam takiego, który chodzi na 9tce i OSX public beta, to właśnie on odzyskał mi dane z tego travelstara. Jakbyś był przypadkiem z Łodzi, lub okolic to z wypożyczeniem nie byłoby problemu.

[ Dodano: 2005-07-21, 07:25 ]
na versiontracker można też znaleźć taki program coctail, ale nie wiem czy to zadziała w Twoim wypadku. Ale może poprawić błędy z tym schrollem.

#9 iMuck

iMuck
  • 510 postów
  • Skądstolyca

Napisano 23 lipca 2005 - 18:30

Wielkie dzięki, Janek, jestem ujęty twoją propozycją i chęcią pomocy. Niestety trochę mi nie po drodze, bo mieszkam w Krakowie. W najgorszym razie podepnę go pod moj piecyk i przetestuję pecetowskimi programami. Jesli chodzi o Cockatail, to nie pomaga na iScrolla, ale wiem juz chyba o co z nim chodzi. Przy któryms starcie zauważyłem, że system przestaje inicjowac programy (na screenie startowym z przesuwającym się niebieskim suwakiem)po zainicjowaniu ustawien sieci! Raz uruchamia wszystkie (az do konca "skali") a czasem po prostu przerywa po ustawieniu sieci. Pomyslalem sobie, ze musze pogrzebac przy opcjach startu i ustawilem logowanie usera i... pomoglo! Teraz niezaleznie od tego, czy suwak dojdzie do konca czy nie - iScroll i tak dziala, bo w "get Info" ustawiłem jego działanie na usera (czyli mnie) a nie na system, takze z tym mam spokoj. Jednak doszlo mi dodatkowe zmartwienie: podejrzewam, ze w moim niespełna 1,5rocznym ibooku wyczerpała sie już bateryjka PRAMowska (mam nadzieje, ze nie kontaminuje terminów: chodzi mi o tę, która utrzymuje własciwą godzinę etc.). Nie wiem jak się do niej dostac w celu wymiany. Ktos z was wymienial? Bo mnie od czasu do czasu po starcie pokazuje sie data 1stycznia 1970, a to dobrych pare lat przed moim urodzeniem :lol: Sądzę, że wymiana tej baterii pozbawi mnie kilku kłopotów z jakimi się borykam. Jednak dysk twardy tak czy owak bede musial przetestowac, bo robi jakies numery (Secure Erase Trash potrafi trwać wieki, a nawet nie dojsc do skutku, także mam prawie pewnosc, ze zamieszkały na nim bady). Swoją drogą to nie Travelstar, tlko jakaś Toshiba. Nie mam pewności, ze jest to oryginalny dysk od Appla, jak się do niego dokopie, to sie dowiem (powinien miec jabłko na naklejce, prawda?). Moje jabluszko wydaje się byc troche robaczywe, alei tak jestem w nim zakochany. Dokupie mu niedługo RAMu, żeby się bidulek nie pocił tak strasznie przy większych appsach. Mam tez prośbę do admina/moderatora, żeby nie usuwał moich postów, tak jak to niedawno zrobił, tylko dlatego, że nie wznoszę czołobitnych pochwał pod adresem systemu operacyjnego marki Apple Inc., a zamist tego zdarza mi się miec z nim problemy. W koncu to chyba niezależne forum, a Apple czy SAD nie sponsorują tej strony? A może o czymś nie wiem? Czasem po prostu musze określic problemy na jakie napotykam, bo inaczej nie uzyskam odpowiedzi jak je przezwycięzyć. Dziekuje wszystkim makjuzerom za pomoc

#10 MacDada

MacDada

    MyApple Team

  • 7 237 postów
  • Skąd3city

Napisano 23 lipca 2005 - 18:36

@iMuck: wydaje mi się, że to usunięcie posta to było niechcący... wtedy akurat była zmiana serwera, więc wiele postów "zaginęło w akcji"...

#11 janek

janek
  • 236 postów
  • SkądŁódź

Napisano 23 lipca 2005 - 21:05

Jednak doszlo mi dodatkowe zmartwienie: podejrzewam, ze w moim niespełna 1,5rocznym ibooku wyczerpała sie już bateryjka PRAMowska (mam nadzieje, ze nie kontaminuje terminów: chodzi mi o tę, która utrzymuje własciwą godzinę etc.). Nie wiem jak się do niej dostac w celu wymiany.


Nie wymienialem, ale tez mi sie wyczerpala (kupilem uzywanego kompa, ktory dlugo stal bez baterii). W support na stronie apple'a albo w listach dyskusyjnych na applu powinienes znalezc rozwiazanie, ktore mogloby pomoc. U mnie wygladalo to nastepujaco (nam PB Pismo) - po wylaczeniu komputera (podlaczonego do zasilania) trzymalem wcisniety przez ok 10 sek przycisk restart, nastepnie wlaczylem kompa. Ladowalem go przez cala noc, nastepnego dnia zrobilem to samo (reset) i bateria pram sama odzyla. Zapewne dla iBooka G4 tez jest jakis sposob. Moze ktos pomoze, ja bym w kazdym razie akurat z tym nie panikowal. A tak swoja droga, to probowales moze zrobic czysta instalacje? moze ten schrool czy co innego niezle narozrabial?

#12 iMuck

iMuck
  • 510 postów
  • Skądstolyca

Napisano 27 lipca 2005 - 07:46

Jeśli chodzi o dysk, to mam już pewność, że jest w porządku. Przetestowałem go skrupulatnie programem Drive Genius, który można pobrać na przykład stąd:

http://www.prosoften...7f0d191aa4233e9

gdyby ktoś miał taką potrzebę :D Oczywiście jest to wersja trial, która po wpisaniu serialu otrzymanego po zakupie :lol: staje się w pełni funkcjonalna :mrgreen:
Program jest narzędziem wielofunkcyjnym - o wszystkich jego funkcjach przekonacie się najlepiej sami go testując. Oprócz skanowania na okoliczność badbloków ma też opcje sprawdzania integralnośći, defragmentacji (moim zdaniem bardzo przydatna), duplikacji (kopiowania zasobow z dysku na inny) oraz kilka opcji napraw (między innymi uźyteczna opcja odtwarzania "b-tree"). Plik pobrany ze strony producenta waży 128mb i jest spakowanym obrazem bootowalnej płyty ważącej koło 450mb, z ktorej możemy odpalić program przed startem systemu, tak żeby mieć możliwość skorzystania z wszystkich funkcji programu (z poziomu systemu dostępne są tylko niektóre, a to z racji niemożliwośći "odmontowania" dysku systemowego. Oczywiście jesli testujemy dyski zewnętrzne ta zasada nie obowiązuje). Radzę najpierw zainstalować program w systemie, a dopiero po tym odpalić go z bootowalnej płytki - nie musimy wówczas wpisywać serialu przy każdym starcie programu z płyty, co oszczędza nam sporo czasu i wysiłku (trzeba wówczas wpisywać dość długi serial ręcznie)

Piszę o tym wszystkim w celu udzielenia informacji osobom, które na tym forum będą szukały informacji na podobny co ja temat. BTW: na zagranicznych forach przeczytałem, że produkt symanteca tzn. pakiet Norton Utilities nie działa najlepiej pod OS Xem (a przynajmniej dużo gorzej niż pod mac os classic), dlatego polecane są programy takie jak Drive Genius (ma tę przewagę nad innymi programami o podobnej funkcjonalności, że można go pobrać ze strony producenta), a także DiskWarrior, Disk 10 i kilka innych.

[ Dodano: 2005-07-27, 09:18 ]

@iMuck: wydaje mi się, że to usunięcie posta to było niechcący... wtedy akurat była zmiana serwera, więc wiele postów "zaginęło w akcji"...


Jeśli tak, to najmocniej przepraszam za bezpodstawny zarzut :oops: . Nie przyszło mi do głowy, że mogły zadecydować kwestie techniczne




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych