Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

PYM Dictionary 0.9.5 (i słownik systemowy)


  • Zaloguj się, aby dodać odpowiedź
47 odpowiedzi w tym temacie

#26 nevoX

nevoX
  • 855 postów
  • SkądTorun, Poland

Napisano 15 grudnia 2010 - 21:28

Ten sam problem, jakieś pomysły?

#27 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 15 grudnia 2010 - 23:25

Do instalacji słownika systemowego niezbędne jest połączenie z Internetem. Usuń katalog /Użytkownicy/TWOJE_KONTO/Biblioteki/Caches/pymhelper wraz z zawartością, po czym opróżnij kosz. Następnie spróbuj jeszcze raz zainstalować słownik systemowy. Jeżeli to nie pomoże i znów pojawi się ten komunikat, otwórz Terminal i wpisz w nim: cd ~/Library/Caches/pymhelper ; make Daj znać, co pojawiło się w odpowiedzi.

#28 nevoX

nevoX
  • 855 postów
  • SkądTorun, Poland

Napisano 17 grudnia 2010 - 15:14

Pierwsze nie pomogło.

W odpowiedzi na zapytanie do Terminala otrzymuję:

-bash: make: command not found



#29 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 17 grudnia 2010 - 16:13

Zainstaluj XCode.

#30 nevoX

nevoX
  • 855 postów
  • SkądTorun, Poland

Napisano 18 grudnia 2010 - 11:37

Zainstalowane od początku. Fakt, że przy instalacji było trochę opcji do wyboru. Ja wybrałem tylko te podstawowe. Trzeba coś innego?

screen-capture.png

#31 macieks72

macieks72

  • 9 873 postów

Napisano 18 grudnia 2010 - 12:24

Przy instalacji widocznie nie wybrałeś Unix dev tools czy coś podobnego, albo masz coś kompletnie zrąbane. Chodzi o to ze nie masz 'make' w systemie jak wyraźnie mówi komunikat, a to się instaluje właśnie z Xcode. Zainstaluj jeszcze raz całe Xcode i patrz co instalujesz, zaznacz odpowiednie opcje jeśli są odznaczone. I nie chodzi tutaj o sam program Xcode także screenshot który dałeś jest nie potrzebny, a o całe środowisko, kompilator etc.

#32 nevoX

nevoX
  • 855 postów
  • SkądTorun, Poland

Napisano 18 grudnia 2010 - 20:14

Prawda, trzeba było doinstalować ten dodatkowy pakiet. Teraz wszystko śmiga! Dzięki wszystkim :)

#33 blezz

blezz
  • 2 postów

Napisano 12 czerwca 2011 - 13:28

Witam. Odświeżam temat, bo chciałbym się dowiedzieć, czy są jakieś szanse na zintegrowanie słownika polsko-angielskiego z systemowym. Używam go na co dzień (a pewnie nie tylko ja) i bardzo by mi to ułatwiło życie, gdybym miał wszystko w słowniku systemowym :)

#34 Konrad1982

Konrad1982
  • 3 postów

Napisano 19 grudnia 2011 - 01:03

Witam. Ja rowniez mam maly problem. Chce zainstalowac PYM na Lion 10.7 ale w Xcode nie widze zadnej opcji - zainstaluj jako slownik systemowy. Jak wiec moge to zrobic? Z gory dziekuje.

#35 Harry Brown

Harry Brown
  • 373 postów
  • SkądKrakau

Napisano 19 grudnia 2011 - 14:57

Konrad, jako słownik systemowy instalujesz go z poziomu PYM Dictionary, a XCode musi być wcześniej zainstalowane.

#36 Konrad1982

Konrad1982
  • 3 postów

Napisano 19 grudnia 2011 - 21:29

Dzieki Harry. Po kilku godzinnej walce z problemem ewentualnie dobrnalem do celu i wszystko dziala jak nalezy.

#37 fischu

fischu
  • 152 postów
  • SkądDąbrowa Górnicza

Napisano 20 września 2012 - 19:33

Odgrzewam temat, gdyż nigdzie nie mogę znaleźć odpowiedzi na mój problem, a widzę, że tutaj już była o nim mowa. Chodzi o błąd ""Kompilacja słownika nie powiodła się. Słownik nie zostanie zainstalowany"." Mam system Mountain Lion 10.8.2 oraz świeżo zainstalowany Xcode. Próbowałem usunąć z cache podane pliki, niestety nic nie pomaga. Xcode instaluje się bezpośrednio z AppStore, więc nie mam zbytnio wpływu na dodatki, które są z nim instalowane. Proszę o pomoc.

#38 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 20 września 2012 - 19:38

Masz wpływ. W którymśtam menu xcode jest opcja istalacji console tools. Albo możesz je sobie same zassać (bez reszty xcode) z developer.apple.com.

#39 fischu

fischu
  • 152 postów
  • SkądDąbrowa Górnicza

Napisano 20 września 2012 - 19:43

A orientujesz się może jak to się dokładnie zwie? Jestem właśnie na developer.apple.com, ale nigdzie nie widzę nic co nazywałoby się 'console tools'... EDIT: Podejrzewam, że chodzi o 'Command Line Tools for Xcode'. No nic zobaczymy, dzięki za pomoc.

#40 ftpd

ftpd

    Nie.


  • 19 910 postów
  • Płeć:
  • SkądPoznań

Napisano 20 września 2012 - 19:49

Tak, to to.

#41 fischu

fischu
  • 152 postów
  • SkądDąbrowa Górnicza

Napisano 20 września 2012 - 20:10

Dla potomnych: Wszystko działa jak powinno, jeśli tylko nie pominiecie żadnego kroku. Dzięki wielkie raz jeszcze ;)

#42 eragooo

eragooo
  • 120 postów

Napisano 15 października 2012 - 23:18

fischu, możesz powiedzieć jak dokładnie zainstalowałeś to na Mountain Lionie?
Mi wyskakuje taki błąd:
Dołączona grafika
Xcode plus Command Line Tools zainstalowane...

#43 Gregory

Gregory


  • 2 714 postów
  • Skądᴧ̊

Napisano 16 października 2012 - 16:47

Niestety, Apple zmieniło katalog, w którym instalowane są narzędzia Xcode, przez co program nie może ich znaleźć. Poza tym najnowsza wersja Xcode nie zawiera dołączonych narzędzi wymaganych do kompilacji słownika, trzeba je pobrać ręcznie. Otwórz Xcode i wybierz polecenie menu Xcode > Open Developer Tool > More Developer Tools. Pobierz obraz dysku Auxiliary Tools for Xcode, otwórz go, znajdź tam katalog Dictionary Development Kit, po czym wrzuć go do /Developer/Extras na dysku startowym. Jeśli na dysku startowym nie ma katalogu Developer, to go utwórz, podobnie jak katalog Extras wewnątrz niego. Wtedy PYM Dictionary powinien rozpoznać narzędzia do generowania słownika — muszą one znajdować się w /Developer/Extras/Dictionary Development Kit/. Postaram się uaktualnić program oraz opis na stronie. Niestety, innej możliwości nie ma — to są narzędzia, przy użyciu których autorzy słownika PWN powinni stworzyć wersję dla Maca. Jako że tego nie zrobili, to całą czarną robotę musi wykonać za nich użytkownik, w czym (jak może…) pomaga mu PYM Dictionary.

#44 eragooo

eragooo
  • 120 postów

Napisano 16 października 2012 - 19:01

Gregory, wielkie dzięki! Świetną robotę wykonujesz!

#45 wjw44

wjw44
  • 38 postów

Napisano 12 lutego 2013 - 23:12

nowa instalacja Instalowałem PYM Dictionary pod Snow Leopardem, potem zmieniałem na kolejne wersje systemu. Teraz kupiłem Maca Mini, ale z wiadomych względów postanowiłem zainstalować wszystko od nowa. PYM Dictionary zainstalował się bez problemu, a jeśli chodzi o słownik systemowy, po prostu przeniosłem plik ze starego kompa i już! Bez problemu z Xcode'em itp. Pozdrawiam! Władek

#46 michy

michy
  • 16 postów

Napisano 16 czerwca 2013 - 13:08

Używam PYM Dictionary od bardzo dawna i uważam go za świetny program. Do tej pory korzystałem tylko z aplikacji PYM Dictionary, aby uzyskać dostęp do słowników, i nie dokonywałem żadnej kompilacji na słownik systemowy. Dzisiaj zainstalowałem PYM Dictionary na nowym komputerze, MBP retina, i nie wygląda on za dobrze (chociaż oczywiście działa), dlatego chciałem skorzystać z opcji przeniesienia słownika ang-pol do słowników systemowych. Zrobiłem wszystko według wskazówek autora, na jego stronie, i myślę, że ściągnąłem odpowiednie narzędzia i umieściłem je we właściwych folderach, bo kompilacja słownika rozpoczyna się normalnie ... jednak gdy pasek postępu dochodzi do końca (po koło 1-2 min), pojawia się komunikat, że kompilacja się nie powiodła i słownik nie został zainstalowany. Oczywiście w takiej sytuacji nie ma go też w preferencjach systemowego słownika. Michał. PS Problem rozwiązany... parę postów wyżej była informacja, że pomogło doinstalowanie jakiegoś pakietu... zabrakło dla mnie informacji jaki pakiet dokładnie trzeba było doinstalować - w moim przypadku pomogło doinstalowanie "Command Line Tools (OS X Mountain Lion) for Xcode - April 2013"

#47 mrggpl

mrggpl
  • 6 postów

Napisano 04 września 2013 - 08:12

a gdzieś kopiujesz jakieś pliki? Bo też mam najnowszego MBP z retiną i nie chce mi działać ten słownik. Tzn. działa przez PYM Dictionary ale nie dodaje się jako systemowy. - zainstalowałem Command Line Tools do xcode, z menu PYM Dictionary wybieram zainstaluj jako słownik systemowy i wywala mi, że nie mam xcode... - próbowałem przez Dictionary Developer Kit ale to zwykły pakiet który wrzuciłem do katalogu z xcodem (/Developer/Extras) nadal to samo, nawet nie mam pewności, że to działa Mógłby ktoś napisać jak przebiega proces instalacji słownika w paru punktach na najnowszym OS X oraz najnowszym xcode?

#48 kefas198

kefas198
  • 72 postów
  • SkądKraków, PL

Napisano 10 października 2013 - 10:01

Czy ktoś wie, gdzie można jeszcze kupić wersję 2.0? Widzę wszędzie tylko 3.0 i 4.0... - a sam posiadam oryginalną wersję 3.0 z czasów Windowsa Czy ewentualnie jest możliwość legalnego korzystania z wersji 2.0 jeśli posiada się wersję 3.0? (Jeśli tak, to gdzie wtedy ewentualnie mógłbym znaleźć wersję 2.0)?




Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych