Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
* * * * * 1 głosy

MacBook Air z M1 - Magistrala USB 4 czy 3.1?


  • Zaloguj się, aby dodać odpowiedź
11 odpowiedzi w tym temacie

#1 DamianeqPL

DamianeqPL
  • 20 postów

Napisano 10 stycznia 2021 - 20:10

Hej,

 

Mam pewny konflikt informacyjny, na stronach Apple w informacjach o nowym MacBook'u Air z M1 znajduje się informacja, że posiada złącza USB 4, natomiast jak wchodzę w zakładkę "Raport systemowy" to widzę "Magistrala USB 3.1: Sterownik kontrolera hosta: AppleT8103USBXHCI" to w końcu jest to USB w wersji 4-tej czy nie?

 

Wrzucam screen.

Załączone pliki



#2 maxwawa

maxwawa
  • 134 postów

Napisano 10 stycznia 2021 - 20:49

Słuszna uwaga.

W Macbooku Pro z M1 też jest  USB 3.1 a powinno być USB 4 tak jak na stronie Apple

Czyli mamy niezgodność towaru z podaną specyfikacją ?



#3 Blue

Blue
  • 238 postów
  • SkądPoznań, Warszawa

Napisano 10 stycznia 2021 - 21:27

Nie wiem gdzie problem widzicie, wyraźnie pisało i pisze, że usb w tym porcie obsługuje standard 3.1. Chyba nie rozumiecie czym jest USB4. Bo wszystko się dokładnie zgadza i jest zgodne ze specyfikacją USB4. Zapoznajcie się najpierw, a potem piszcie, bo szkoda czasu na takie wątki.

 

https://support.appl...25?locale=pl_PL

 

Dopiszę aby było jasne.

USB 4 musi spełniać następujące warunki:

- Ładowanie - wspiera

- Minimum USB 3.1 gen 1 - Apple dało nam 3.1 gen 2

- Może wspierać Thunderbolt 3 - wspiera

- Minimalny transfer 20 Gbit/s - Apple dało nam 40 Gbit/s w TB3.


Użytkownik Blue edytował ten post 10 stycznia 2021 - 21:37


#4 maxwawa

maxwawa
  • 134 postów

Napisano 10 stycznia 2021 - 21:58

Na tej stronie https://www.apple.co...macbook-pro-13/

Thunderbolt / USB 4

 

jest informacja wprowadzającą potencjalnego kupującego w błąd.

ale na tej co podałeś  to faktycznie jest tylko 3.1

W takim razie Apple powinno zmienić te opisy 

bo specyfikacja USB 4  znacząco różni  sie  od 3.1 t

Powinno być w specyfikacji:  Dwa porty Thunderbolt / USB 3.1 i wtedy byłoby w porządku,  po co mydlić oczy czymś czego  ... nie ma.


Użytkownik maxwawa edytował ten post 10 stycznia 2021 - 21:58


#5 Blue

Blue
  • 238 postów
  • SkądPoznań, Warszawa

Napisano 11 stycznia 2021 - 09:44

Tylko taki problem, że Apple jednak korzysta ze standardu USB4 i w nim transferuje USB 3.1 gen 2 plus TB3. W poprzednich makach nie było USB tylko był TB3, który to mógł obsłużyć protokół USB. Ze strony usera na jedno wychodzi. I tak i tak dostajemy prawie to samo. Ale standard się zgadza i Apple może pisać, że ma USB4. Bo ma. Więc nikt nie wprowadza nikogo w błąd. Po prostu USB4 to teraz standard oparty na TB3 i obsługuje szereg różnych protokołów. W krótkim materiale promo Apple nie wymieniło szczegółów implementacji, wymieniło je w danych technicznych dopiero.

#6 DamianeqPL

DamianeqPL
  • 20 postów

Napisano 11 stycznia 2021 - 10:54

Panowie,

 

To podam inne źródło (strona Apple) https://support.appl.../pl-pl/HT201163 - napisane jest ze (specyfikacja wg. tabeli) USB 4 Do 10 Gb/s Do 15 W przy 5 V moje USB obsługuje z tego co widzę po podłączeniu urządzeń Do 900 mA przez co nie działa poprawnie dysk zewnętrzny. (za niskie zasilanie)



#7 Blue

Blue
  • 238 postów
  • SkądPoznań, Warszawa

Napisano 11 stycznia 2021 - 12:12

15W i 5V to jest 3A, więc zdecydowanie więcej niż 0.9A. Nie bardzo rozumiem. Masz dysk, który wymaga 0.9A zasialania? To powinien tyle spokojnie dostać, chyba że masz jakąś przejściówkę co podaje 0.5A tylko.



#8 DamianeqPL

DamianeqPL
  • 20 postów

Napisano 11 stycznia 2021 - 13:03



15W i 5V to jest 3A, więc zdecydowanie więcej niż 0.9A. Nie bardzo rozumiem. Masz dysk, który wymaga 0.9A zasialania? To powinien tyle spokojnie dostać, chyba że masz jakąś przejściówkę co podaje 0.5A tylko.

 

 

Problem w tym, że komputer daje zasilanie 0,9A zamiast 3A jak powinno być w USB 4

 

 

Mam kieszeń USB, na dysk M.2 NVMe i po podłączeniu do Laptopa HP Omen z Thunderbolt dysk śmiga bez problemu, po podłączeniu do Apple MacBook Air z M1 po kilku minutach kopiowania na dysk, system krzyczy o niepoprawnym odłączeniu dysków, dysk znika z systemu i ponowne podłączenie i odłączenie nie daje efektu, muszę wszystko zresetować i dopiero jest widoczny ponownie.

 

Dlatego zainteresowałem się tematyką złączy w tym MacBooku i nie wiem co mam zrobić.

 

 

Screen

screen-usb.png


Użytkownik DamianeqPL edytował ten post 11 stycznia 2021 - 13:11

  • BlueBook lubi to

#9 Blue

Blue
  • 238 postów
  • SkądPoznań, Warszawa

Napisano 11 stycznia 2021 - 13:36

Jak sam widzisz, wynegocjowane natężenie odpowiada podawanemu, przyczyna musi leżeć w innym miejscu (albo błędne informacje są podawane tutaj). To, że jest coś nie tak ze sterownikiem usb to wiadomo, bo różne problemy ludzie zgłaszają, mi np. negocjuje tylko 5Gbit zamiast 10 przez co mam obniżoną prędkość. U Ciebie pięknie wynegocjował 10 ale coś innego jest nie tak. Problem może być jeszcze inny. Bo albo Apple sterownik ma bugi albo też to usb 3.1 opakowane w standard usb4 nie jest poprawnie rozpoznawane przez kontrolery. Więc tu może być bug w standardzie usb4 bo standard definiuje wsteczną kompatybilność, mimo to starsze urządzenia, które nie słyszały o usb4 się nie dogadują. Oby to była tylko kwestia sterownika, wtedy update powinien rozwiązać problemy.


  • DamianeqPL lubi to

#10 DamianeqPL

DamianeqPL
  • 20 postów

Napisano 11 stycznia 2021 - 13:46

Jak sam widzisz, wynegocjowane natężenie odpowiada podawanemu, przyczyna musi leżeć w innym miejscu (albo błędne informacje są podawane tutaj). To, że jest coś nie tak ze sterownikiem usb to wiadomo, bo różne problemy ludzie zgłaszają, mi np. negocjuje tylko 5Gbit zamiast 10 przez co mam obniżoną prędkość. U Ciebie pięknie wynegocjował 10 ale coś innego jest nie tak. Problem może być jeszcze inny. Bo albo Apple sterownik ma bugi albo też to usb 3.1 opakowane w standard usb4 nie jest poprawnie rozpoznawane przez kontrolery. Więc tu może być bug w standardzie usb4 bo standard definiuje wsteczną kompatybilność, mimo to starsze urządzenia, które nie słyszały o usb4 się nie dogadują. Oby to była tylko kwestia sterownika, wtedy update powinien rozwiązać problemy.

 

To co teraz zrobić? Czy są jakieś HUBy zasilane z zewnątrz? które usuną problem z zasilaniem?



#11 Blue

Blue
  • 238 postów
  • SkądPoznań, Warszawa

Napisano 11 stycznia 2021 - 15:18

Można zadzwonić do wsparcia Apple, wsparcia producenta kieszeni (może ma jakiś update firmware). A jak nie to zaczekać jeszcze na kolejną wersję Big Sur i zobaczyć czy coś to zmienia. Potem można się zastanawiać co dalej, bo nie ma gwarancji, że dany hub będzie działać z Twoją kieszenią. I nie wiadomo czy jest to akurat kwestia zasilania.

 

To co teraz zrobić? Czy są jakieś HUBy zasilane z zewnątrz? które usuną problem z zasilaniem?



#12 DamianeqPL

DamianeqPL
  • 20 postów

Napisano 11 stycznia 2021 - 16:01

ok, tylko czy Wy też macie tak, że niezależnie (poza sprzętem Apple typu iPhone) podłączycie do USB to w Informacje o Systemie pojawia się info:   Natężenie dostępne dodatkowo (mA): 0 ?

 

 

edit: Spędziłem ponad godzinę na rozmowę z Apple, na chwile obecną nie ma rozwiązania na mój problem, być może zostanie to naprawione z aktualizacją dot. wsparcia monitorów - podobno do MacBooków można obecnie tylko podłączyć monitor po HDMI, inne rozwiązania mają problem i podobno to może być również kwestia zasilania.

 

 

edit2: Przetestowałem 3 dyski zewnętrzne, niezależnie czy miały swoje zasilanie czy czerpały z USB MacBook stosował Natężenie Dostępne (mA) 900,

Do czasu naprawy (mam nadzieję że aktualizacja pomoże) może być problem z zewnętrznymi dyskami.


Użytkownik DamianeqPL edytował ten post 11 stycznia 2021 - 17:59





Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych