Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Stara klawiatura + nowa mysz/trackpad - interferencje


  • Zaloguj się, aby dodać odpowiedź
3 odpowiedzi w tym temacie

#1 sk4

sk4
  • 232 postów

Napisano 21 lipca 2019 - 18:03

Witam,

Do posiadanej bezprzewodowej klawiatury A1314 dokupiłem nową mysz A1667 i trackpad A1535 (który raczej jednak mało się przydaje ku mojemu zaskoczeniu). Czasami zdarzają się problemy jakby zakłóceniem połączeń BT. Klawiatura (i w zasadzie tylko ona) potrafi zgłupieć. Zalagować się, powtarzać jeden klawisz itd. Całość działa pod systemem macOS 10.13.6 na MBP 13" Late 2013.
Czy coś wiadomo o jakiś niekompatybilnościach pomiędzy starą klawiaturą, a nową generacją, albo wersją laptopa?
Miałem kiedyś Magic Mouse i wraz z tą samą klawiaturą działały bez problemu.
Nie ma też innych urządzeń BT poza laptopem, klawiaturą, myszą i trackpadem.

Pozdrawiam

EDIT: Aby klawiatura wróciła do normalności wystarczy wyłączyć jedno z urządzeń Magic Trackpad 2 lub Magic Mouse 2. Obojętnie które. Oczywiście problemem jest BT, ale fakt, że nie ma bezpośredniej interferencji (nie ma znaczenia, które urządzenie wyłączę) i konflikt jest pomiędzy "starą" klawiaturą, a 2 generacją urządzeń, podejrzewam że problem leży w komunikacji lub coś. Czy zatem jedynym rozwiązaniem byłaby wymiana klawiatury na wersję 2?

Użytkownik sk4 edytował ten post 21 lipca 2019 - 19:33


#2 tomtom_su

tomtom_su
  • 308 postów
  • SkądWroclaw

Napisano 22 lipca 2019 - 08:25

Może problemem jest właśnie używanie dwóch urządzeń wskazujących równocześnie.



#3 sk4

sk4
  • 232 postów

Napisano 25 lipca 2019 - 15:08

Oj to raczej na 100% nie, bez problemu obsługuje równoległe wszystkie 3.

Co ciekawe, nie dzieje się tak zawsze i chyba powoli zauważam pewną tendencję. Mam przepuszczenia, że problemem jest uśpienie laptopa i kolejne wybudzenie. Coś się jakby źle uruchamiało po wybudzeniu czasami. Może kolejność aktywowania urządzeń albo coś. Nie wiem, ale badam sprawę :-)

#4 sk4

sk4
  • 232 postów

Napisano 02 sierpnia 2019 - 15:10

Update do sprawy. Udało mi się znaleźć błąd, a właściwie dwa. Duża prośba czy ktoś mógłby to przetestować u siebie?

Dla ułatwienia skróty:

  • K - Apple Wireless Keyboard
  • M - Magic Mouse 2
  • T - Magic Trackpad 2
     
  1. T i M - tryb ON (fizycznie włączone)
  2. Uruchamiamy komputer
  3. Po zalogowaniu przechodzimy w tryb uśpienia
  4. Odczekujemy minimum 60 sekund, aby urządzenia zewnętrzne przeszły w tryb uśpienia
  5. Wybudzamy komputer naciskając dowolne klawisze K
  6. Po kilku sekundach (z aktywnymi T i M), K zaczyna powtarzać literki i się zaplętać
  7. Przełączamy w tryb OFF T lub M co "naprawia" K.
  8. Restartujemy komputer

Najważniejszy jest tutaj punkt 5. Jeżeli wybudzimy komputer używając T lub M to nie ma problemu. Wszystko działa.

Nie wiem od czego zależy te "kilka sekund" w punkcie 6. Przez chwilę K działa poprawnie, tak samo M i T. I nagle przestaje. Co ciekawe. Jeżeli odblokowujemy komputer hasłem, to jak nie wpiszemy szybko hasła, to K zawiesi się już na oknie logowania i wpisanie hasła będzie niemożliwe bez wykonania kroku 7.

 

 

Znalazłem przy okazji też drugi błąd, który (bez podstaw do takiego wniosku) może też sugerować, że M jest u mnie w jakiś sposób uszkodzone i stąd problem powyżej.

  1. T - ON, M - OFF
  2. Uruchamiamy komputer
  3. M - ON i aktywujemy M kliknięciem/ruchem
  4. Po kilku sekundach (z aktywnymi T i M) - K zaczyna powtarzać literki i się zaplętać
  5. Przełączamy w tryb OFF T lub M co "naprawia" K
  6. Restartujemy komputer

Co ciekawe, odwrotna kombinacja przełączników na T i M nie powoduje takiego problemu.

 

Prośba o potwierdzenie dla tych urządzeń. Oraz zaznaczenie wersji OS i laptopa.






Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych