Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Błąd com.apple.osinstall -3


  • Zaloguj się, aby dodać odpowiedź
3 odpowiedzi w tym temacie

#1 defthings

defthings
  • 18 postów

Napisano 18 października 2018 - 08:00

Witam, po aktualizacji imaca do high sierra wysypał się system, postanowiłem przeinstalować system bez formatowania dysku i otrzymałem powyższy błąd. Ktoś wie gdzie jest problem? Mam trochę danych na tym dysku i wolałbym nie instalować od zera. 



#2 cronopioverde

cronopioverde
  • 3 549 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 18 października 2018 - 23:47

Jesteś w stanie ruszyć w tym momencie Terminal? To poproszę wkleić tam:
 

{ system_profiler SPHardwareDataType SPDisplaysDataType SPMemoryDataType SPSoftwareDataType SPStartupItemDataType SPStorageDataType -detailLevel mini; fdesetup status; spctl --status; } 2>/dev/null | pbcopy

 
zatwierdzić enterem/returnem i od razu w odpowiedzi tutaj dać tylko „wklej”/cmd+V.
 
Nie będzie widać żadnych wrażliwych danych, uprzedzę od razu.

I też uprzedzę, że to nie rozwiązanie. To prośba o jakieś informacje, bo w poście #1 nie ma w zasadzie prawie nic.


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na łamaną polszczyznę to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#3 defthings

defthings
  • 18 postów

Napisano 19 października 2018 - 18:13

Jesteś w stanie ruszyć w tym momencie Terminal? To poproszę wkleić tam:
 

{ system_profiler SPHardwareDataType SPDisplaysDataType SPMemoryDataType SPSoftwareDataType SPStartupItemDataType SPStorageDataType -detailLevel mini; fdesetup status; spctl --status; } 2>/dev/null | pbcopy

 
zatwierdzić enterem/returnem i od razu w odpowiedzi tutaj dać tylko „wklej”/cmd+V.
 
Nie będzie widać żadnych wrażliwych danych, uprzedzę od razu.

I też uprzedzę, że to nie rozwiązanie. To prośba o jakieś informacje, bo w poście #1 nie ma w zasadzie prawie nic.

 

Dzięki za odpowiedz, dostęp do terminala mam z poziomu instalatora więc nie mam jak zapisać danych wyjściowych z tej komendy :/ Próbowałem uruchomić pierwszą pomoc na tym dysku ale też zgłasza błąd.. załączam zdjęcie -> https://we.tl/t-aFjuCSkXsE



#4 cronopioverde

cronopioverde
  • 3 549 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 24 października 2018 - 00:45

Ach te APFS-y! ;)

 

Jeszcze dużo ludzi na nie narzeka. Z czasem na pewno wygładzą i dopieszczą, a póki co, to wczesne stadium…

Ad rem: jeżeli miałeś na tym dysku ważne rzeczy, to mam nadzieję, a Ty pewnie jeszcze większą, że jednak backup już istnieje. Reszta to standardowa procedura: clear install, o ile dysk nie padł (bo to też możliwość), i przywrócenie danych; osobiście zostałbym jeszcze przy HFS+ (instrukcje do znalezienia w sieci, jak wymusić pozostanie/zablokować konwersję w czasie instalacji High Sierry, nawet jeżeli ma się SSD), ale jeżeli chcesz dać drugą szansę APFS, to go ahead – skarżą się jedni, a inni nie.

 

Ewentualnie spróbuj jeszcze naprawy w single user mode (przeczytawszy najpierw man fsck i man fsck_apfs) – zaszkodzić nie zaszkodzisz. 
 


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na łamaną polszczyznę to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych