Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Terminal - brak Telnet


  • Zaloguj się, aby dodać odpowiedź
9 odpowiedzi w tym temacie

#1 elprezesso

elprezesso
  • 439 postów
  • SkądŁódź

Napisano 10 października 2017 - 17:16

W Mac OS 10.13 w aplikacji terminal, zniknęła komenda TELNET. Poczytałem trochę na innych stronach, jak przywrócić telnet, niestety nie bardzo mi się widzi inastalacja HomeBrew. Może ktoś z Forumowiczów, zna inne rozwiązanie na przywrócenie TELNETU. 

 



#2 pedros

pedros
  • 1 392 postów
  • SkądWAW, PL

Napisano 10 października 2017 - 17:20

nc

https://forums.devel...om/thread/79056


Użytkownik pedros edytował ten post 10 października 2017 - 17:21


#3 ftpd

ftpd

    Nie.


  • 20 873 postów
  • Płeć:
  • SkądPoznań

Napisano 11 października 2017 - 10:43

Co Cię boli w Homebrew?
Możesz spróbować binarki z 10.12, powinna działać.



#4 elprezesso

elprezesso
  • 439 postów
  • SkądŁódź

Napisano 11 października 2017 - 13:13

Co Cię boli w Homebrew?
Możesz spróbować binarki z 10.12, powinna działać.

 

Potrzebuje tylko telent, a nie chcę "zaśmiecać systemu" niepotrzebnym mi softem. Zobacze binarki z 10.12. Napiszę jak tylko znajdę chwilkę by przy tym posiedzieć, jaki rezultat.


Co Cię boli w Homebrew?
Możesz spróbować binarki z 10.12, powinna działać.

z Netcat jest problem, przynajmniej dla mnie. Dość często łącze się do sesji AS/400, telnet działa super, natomiast nc nie jestem w stanie zestawić połączenia, z AS/400 (TN5250)


Użytkownik elprezesso edytował ten post 11 października 2017 - 13:14


#5 ftpd

ftpd

    Nie.


  • 20 873 postów
  • Płeć:
  • SkądPoznań

Napisano 11 października 2017 - 13:21

Sprawdziłem za Ciebie. Binarka z 10.12 działa. https://insomniac.pl/f/telnet, łap.



#6 elprezesso

elprezesso
  • 439 postów
  • SkądŁódź

Napisano 17 października 2017 - 08:35

Dzięki bardzo za pomoc, po paru dniach intensywnej pracy znalazłem chwilę by usiąść i wykonać niezbędną pracę.

 

Działa super, jeszcze raz dzięki.

 

Dodatkowo dla zainteresowanych tematem napiszę mały poradnik krok po kroku jak przywrócić telnet

 

1. wyłączamy System Integrity Protection (rootless) [temat opisywany na forum]

2. pobieramy plik wskazany przez kolegę FTPD i kasujemy rozszerzenie

3. odpalamy terminal 

4. przechodzimy do katalogu z plikiem telnet

5. kopiujemy plik wskazany przez FTPD do katalogu /usr/bin/ (komenda sudo cp telnet /usr/bin/)

6. po skopiowaniu wpisujemy w terminalu komendę (sudo chmod +xr telnet)

7. gotowe



#7 ftpd

ftpd

    Nie.


  • 20 873 postów
  • Płeć:
  • SkądPoznań

Napisano 17 października 2017 - 10:21

Ad1: to konieczne? Bo ja testowałem lokalnie, z ~/Downloads.

Ad2: śmiesznie z tymi rozszerzeniami, to chyba feature Safari 11, że dodaje. Po stronie serwera plik nie ma żadnego rozszerzenia.

Ad6: "sudo chmod +xr /usr/bin/telnet", żeby być konkretnym (nie zmieniłeś katalogu, będą płakać, że file not found :P).

 

Ewentualnie można do /usr/local/bin, tam chyba SIP nie operuje.



#8 elprezesso

elprezesso
  • 439 postów
  • SkądŁódź

Napisano 17 października 2017 - 13:14

 

Ad6: "sudo chmod +xr /usr/bin/telnet", żeby być konkretnym (nie zmieniłeś katalogu, będą płakać, że file not found :P).

 

Ewentualnie można do /usr/local/bin, tam chyba SIP nie operuje.

Dzięki za poprawnie

 

Sprawdzałem czy można do /usr/local/bin, niestety nie działa poprawnie. Choć może to kwestia uprawnień, czyli można pominąć punkt 1, a punkt 6 na pewno należy powtórzyć komenda (sudo chmod +xr /usr/local/bin/telnet).



#9 ciacho

ciacho
  • 61 postów
  • SkądWarszawa

Napisano 17 października 2017 - 14:20

W /usr/local/bin można zapisywać jako zwykły użytkownik (byle w grupie staff) więc sudo nie będzie potrzebne (przynajmniej u mnie tak jest, a nie pamiętam czy to zmieniałem czy nie).
Użytkownik wielu różnych rzeczy, _nie_ fanboy A/A. Zagorzały przeciwnik świętych wojen systemowo-rozwiązaniowych.

#10 ftpd

ftpd

    Nie.


  • 20 873 postów
  • Płeć:
  • SkądPoznań

Napisano 17 października 2017 - 16:16

Ja nie mówiłem, że można bez chmoda. Sugerowałem tylko, że do /usr/local/bin nie trzeba wyłączać SIP.






Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych