Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Zamknięcie pokrywy komputera i spadek baterii


  • Zaloguj się, aby dodać odpowiedź
15 odpowiedzi w tym temacie

#1 Krzysztof09

Krzysztof09
  • 95 postów

Napisano 02 października 2017 - 21:39

Witam, 

posiadam Macbooka Pro 2015. Po zaktualizowaniu do 10.13 zauważyłem, że jak mam zamkniętą pokrywę komputera to w ciągu 3 godzin spadło mi aż 5% baterii. Funkcja Power Nap wyłączona. Bluetooth wyłączony, ale wifi włączone. Przed aktualizacją komputer mógł tak leżeć przez 10 godzin i schodził max 1% baterii. Liczba cykli baterii to 102, natomiast stan- Normalny. Ktoś z Was spotkał się z takim problemem?



#2 wankus

wankus
  • 35 postów

Napisano 13 grudnia 2017 - 11:27

zauwazylem to samo, macbook air, wczesnie na el capitan mogl lezec dlugo z zamknieta klapa i schodzilo minimalnie baterii, teraz po aktualzacji do high sierra jest kiepsciutko z bateria, po nocy z zamknieta klapa bateria potrafi spasc o 15-20%.

 

aktualizacja robiona "na brudno", czy czysta instalacja + przywrocenie backupu z timemachine pomoze?


MBP 13 early 2015, 16GB RAM, 128GB SSD, 10.11.6 | MBA 13, early 2015, 8GB RAM, 128GB SSD, 10.13.1

iMac 27, 32GB RAM, 1TB fusiondrive, 10.13.1


#3 MiL

MiL
  • 1 253 postów
  • Płeć:

Napisano 13 grudnia 2017 - 11:44

Ja mam MacBook Pro TB w ciągu doby w uśpieniu bateria spada o 10%. Dodatkowo na dysku zapisywane są gigabajty danych. Sprawdźcie jak to jest u was. Wygląda to tak jakby się sam wybudzał i usypiał.


Znalazłem rozwiązanie. Powodem tego zjawiska jest opcja TCPKeepAlive ustawiona na 1 w ustawieniach zarządzania energią. Można to sprawdzić w terminalu wpisując pmset -g.
Przy włączonej tej fladze komputer budzi się aby pobierać coś z sieci. Po ustawieniu na 0 bateria w uśpieniu nie spada już tak szybko.

#4 raflos

raflos
  • 69 postów

Napisano 29 grudnia 2017 - 10:39

Znalazłem rozwiązanie. Powodem tego zjawiska jest opcja TCPKeepAlive ustawiona na 1 w ustawieniach zarządzania energią. Można to sprawdzić w terminalu wpisując pmset -g.

Przy włączonej tej fladze komputer budzi się aby pobierać coś z sieci. Po ustawieniu na 0 bateria w uśpieniu nie spada już tak szybko.

Czy można prosić o napisanie krok po kroku ( komendy w terminalu) jak zmienić ustawienia tej opcji na 0. Mam nowego MacBooka Air i też zauważyłem, że przy zamkniętej klapie energia ulatuje jak szalona  


  • makemymind lubi to

#5 MiL

MiL
  • 1 253 postów
  • Płeć:

Napisano 29 grudnia 2017 - 15:30

pmset -a TCPKeepAlive 0



#6 zorba

zorba
  • 155 postów

Napisano 07 stycznia 2018 - 13:48

Ja mam MacBook Pro TB w ciągu doby w uśpieniu bateria spada o 10%. Dodatkowo na dysku zapisywane są gigabajty danych. Sprawdźcie jak to jest u was. Wygląda to tak jakby się sam wybudzał i usypiał.


Znalazłem rozwiązanie. Powodem tego zjawiska jest opcja TCPKeepAlive ustawiona na 1 w ustawieniach zarządzania energią. Można to sprawdzić w terminalu wpisując pmset -g.
Przy włączonej tej fladze komputer budzi się aby pobierać coś z sieci. Po ustawieniu na 0 bateria w uśpieniu nie spada już tak szybko.

 

Czy po prawie miesiącu użytkowania z ustawieniem na "0" potwierdzasz spowolnienie spadku % naładowania baterii w uśpieniu ??

 

pmset -a TCPKeepAlive 0

 

U mnie niestety komenda nie zadziałała.


Użytkownik zorba edytował ten post 07 stycznia 2018 - 13:49


#7 MiL

MiL
  • 1 253 postów
  • Płeć:

Napisano 08 stycznia 2018 - 10:00

Tak, teraz w ciągu doby bateria spada o 1-2%, wcześniej było to ponad 10%. W logach też nie ma już wybudzeń.

Czy ta komenda ustawia ci tą flagę na 0? I pomimo tego nadal komputer się wybudza?

Spróbuj przed uśpieniem wyłączyć WIFI i sprawdź czy to pomoże. Czy jesteś w systemie zalogowany do iCloud lub Google? Podejrzewam że to sprawdzanie tych kont wybudza komputer, ale tego nie sprawdzałem.



#8 Mikis314

Mikis314
  • 73 postów

Napisano 08 stycznia 2018 - 11:37

Po wpisaniu w/w komendy ukazuje się taka informacja:

"Warning: This option disables TCP Keep Alive mechanism when sytem is sleeping. This will result in some critical features like 'Find My Mac' not to function properly.

'pmset' must be run as root..."



#9 ftpd

ftpd

    Nie.


  • 20 972 postów
  • Płeć:
  • SkądPoznań

Napisano 08 stycznia 2018 - 12:14

No przecież masz napisane wprost.

Dodaj 'sudo' na początek.


Używaj przycisku 'Zgłoś', zamiast edytować post i pisać w nim, na przykład, "do usunięcia".
Pisanie prywatnej wiadomości do moderatora powinno być ostatecznością. Do tego też służy przycisk 'Zgłoś'.
Do płaczu na pracę Moderacji służy ten wątek. Inne formy będą bezwzględnie kasowane.


#10 Mikis314

Mikis314
  • 73 postów

Napisano 08 stycznia 2018 - 12:20

Teraz po wpisaniu komendy a następnie hasła wyświetla się następująca informacja:

"Warning: This option disables TCP Keep Alive mechanism when sytem is sleeping. This will result in some critical features like 'Find My Mac' not to function properly."

 

To znaczy, że funkcja TCPkeepAlive została wyłączona, tak?



#11 ftpd

ftpd

    Nie.


  • 20 972 postów
  • Płeć:
  • SkądPoznań

Napisano 08 stycznia 2018 - 12:26

Weź może przeczytaj man pmset i zobacz, jak to sprawdzić, a nie przepisujesz komendy z internetu w ciemno.


Używaj przycisku 'Zgłoś', zamiast edytować post i pisać w nim, na przykład, "do usunięcia".
Pisanie prywatnej wiadomości do moderatora powinno być ostatecznością. Do tego też służy przycisk 'Zgłoś'.
Do płaczu na pracę Moderacji służy ten wątek. Inne formy będą bezwzględnie kasowane.


#12 Mikis314

Mikis314
  • 73 postów

Napisano 08 stycznia 2018 - 12:33

Właśnie znalazłem możliwe rozwiązanie problemu, który mnie irytuje. A, że Maca mam dopiero od dwóch miesięcy to uczę się podstaw i liczę na jakieś wsparcie. Myślałem, że to forum od tego jest... Natomiast widzę, że Ty jesteś wybitnie zarozumiały.



#13 cesiu111

cesiu111
  • 636 postów
  • SkądRz

Napisano 08 stycznia 2018 - 12:43

Nie rozumiem twojej irytacji. Kolega podpowiedział sposób, dzięki któremu sprawdzisz, jak czytać komunikaty komendy, której użyłeś.

Jej manual jest bardziej wiarygodny, niż jakiekolwiek wypociny użytkowników na forum.

 

Jeżeli ktoś by ci napisał, że 'rm -rf' w unixie tworzy nowy folder o nazwie 'rf', to byś najpierw o tej komendzie poczytał, czy wpisał w terminal, żeby sprawdzić?


iPhone


#14 zorba

zorba
  • 155 postów

Napisano 08 stycznia 2018 - 16:31

Tak, teraz w ciągu doby bateria spada o 1-2%, wcześniej było to ponad 10%. W logach też nie ma już wybudzeń.

Czy ta komenda ustawia ci tą flagę na 0? I pomimo tego nadal komputer się wybudza?

Spróbuj przed uśpieniem wyłączyć WIFI i sprawdź czy to pomoże. Czy jesteś w systemie zalogowany do iCloud lub Google? Podejrzewam że to sprawdzanie tych kont wybudza komputer, ale tego nie sprawdzałem.

 

Udało mi się wyłączyć TCP KeepAlive. Teraz potestuję.

Najwyżej wrócę do pierwotnych ustawień.

Wcześniej po wyłączeniu Wi-Fi i uśpieniu Maca chyba % wolniej spadały. 



#15 shoier

shoier
  • 2 postów

Napisano 13 września 2018 - 12:20

Witam trochę odgrzebie temat. Miałem podobny problem MBA 2013, Wyłączyłem wybudzanie wifi i zastosowałem komendę z tcpkeepalive, nie mam jednak, pojęcia jak mam to sprawdzić, że została ona wyłączona. Jednak po 10 godzinach nie zszedł mi nawet %. Jak mam sprawdzić co wyłączyłem komendą tcpkeepalive? Chciałbym ja włączyć i porównać zużycie baterii, ponieważ może pomogło samo wyłączanie wybudzania poprzez wifi. Jestem nowym użytkownikiem maca.



#16 makemymind

makemymind
  • 613 postów
  • SkądWrocław

Napisano 13 września 2018 - 13:31

To jest dla mnie odwieczna zagadka bo na El Cap mi spadalo kilka % przez noc a w HS nic nie umyla.. A robilem update, nic na czysto..




Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych