Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Włączony TRIM (Chameleon Optimiser) -> zakaz wjazdu i brak Recovery


  • Zaloguj się, aby dodać odpowiedź
10 odpowiedzi w tym temacie

#1 jacekada

jacekada
  • 32 postów
  • SkądWarszawa

Napisano 19 sierpnia 2016 - 22:54

Dobry wieczór,

 

podkusiło mnie, żebym włączył TRIM na Samsungu EVO 840 po tym jak dosyć szybko spadała żywotność SSD (po ok. roku stracił 7%).

Po restarcie już się nie podnosi, a dokładniej chwilę wczytuje dane i znika jabłko a pojawia się za to zakaz wjazdu. Próby z CMD+R i CMD+OPT+R nie działają. reset PRAM/NVRAM też zrobiłem na wszelki wypadek.

Mam aktualną kopię TM na serwerze NAS, ale nie mam jak się do niej dostać. Siedzę teraz w domu przy PC i zastanawiam się jak zrobić pena z Yosemite. Czy jedyny sposób to nadinstalować system i zrobić restore z backupu?

 

Może ktoś mi podpowie, żebym mógł jutro podjechać do pracy i naprawić Maca? Tam też niestety nie ma więcej nowych Maców - same zabytki.

 

pzdr.



#2 ciotka_paszczaka

ciotka_paszczaka
  • 1 051 postów

Napisano 20 sierpnia 2016 - 00:55

Czyli jak wciskasz alt przy starcie maka to nie ma partycji recovery, czy nie da się z niej wystartować?

 

Można zamontować dysk NAS po sieci bez instalowania systemu, tak aby odzyskać dane z Time Machine, ale musisz mieć albo działającą partycje recovery, albo jakiś dysk instalacyjny z systemem, żeby a niego zbootować maka. Wtedy otwierasz terminal i tu masz dalej... http://www.timbroder...nology-nas.html

 

Skoro nie działa ci również odzyskiwanie przez Internet to innego magicznego sposobu raczej nie ma...

Przydałby się teraz ten pendrive za 15 zł, z nagranym systemem, gdzieś w szufladzie, co go każdy powinien mieć :)

 

BTW:

Pod Yosemite od wersji 10.10.4  i w nowszych systemach nie potrzeba żadnych zewnętrznych narzędzi do włączenia funkcji Trim.

Systemowa funkcja trimforce działa bez problemu na dyskach firm trzecich. http://osxdaily.com/...-ssd-mac-os-x/ 


Użytkownik ciotka_paszczaka edytował ten post 20 sierpnia 2016 - 01:09

Nie czytam prywatnych wiadomości.


#3 jacekada

jacekada
  • 32 postów
  • SkądWarszawa

Napisano 20 sierpnia 2016 - 11:38

Przy alcie mam tylko dysk systemowy. Tego właśnie nie rozumiem, czy nie włączyłem jakiejś opcji tworzenia partycji Recovery przy instalacji Yosemine? Co prawda robiłem upgrade a nie czystą instalację.

Przez noc zrobiłem instalację na pendrivie przy pomocy TransMac. Zobaczę czy da się z niego wystartować, żeby mieć dostęp do NAS.


Użytkownik jacekada edytował ten post 20 sierpnia 2016 - 11:39


#4 NoneZ

NoneZ
  • 237 postów
  • Płeć:

Napisano 20 sierpnia 2016 - 11:38

Wygląda na to, że dotknął Cię znany problem związany z wprowadzeniem przez Apple kontroli kext'ów.

Przeczytaj to: "Recovering from stop sign on boot screen" tu: https://www.cindori....r-and-yosemite/



#5 jacekada

jacekada
  • 32 postów
  • SkądWarszawa

Napisano 20 sierpnia 2016 - 11:43

@ NoneZ

No tak, tyle że cały problem polega na braku Recovery...

 

@ ciotka_paszczaka

Teraz już wiem, że powinienem mieć w szufladzie pendrive z instalacją, ale wcześniej nie byłem tego świadom. "Stary" jestem i nie mam już nawyku do nowego, zawsze były jakieś dyskietki i CD/DVD, i te mam w szufladach. Uważam, że Apple powinno zaraz po instalacji nowego systemu, uruchomić procedurę tworzenia takiego pendrive.


Użytkownik jacekada edytował ten post 20 sierpnia 2016 - 11:52


#6 jacekada

jacekada
  • 32 postów
  • SkądWarszawa

Napisano 20 sierpnia 2016 - 19:04

Nie udało się uruchomić pendrive z instalacją Yosemite zrobioną na PC.

 

Jakimś cudem znalazłem w jakimś pudle stary dysk z partycją instalacyjną (ale nie Recovery).

Niestety nie udało mi się zamontować TM z Synology.

 

Wygląda na to, że dotknął Cię znany problem związany z wprowadzeniem przez Apple kontroli kext'ów.

Przeczytaj to: "Recovering from stop sign on boot screen" tu: https://www.cindori....r-and-yosemite/

Spróbowałem też naprawić kext ale nie udało się. Pokazuje błąd:

IOAHCIBlockStorage.kext has invalid signature; omitting.

 

Póki nie załatwię skądś normalnego pendrive z instalacją, to chyba pozostało spróbować zainstalować system z tej odnalezionej na starym dysku partycji instalacyjnej.



#7 Śfierzyk

Śfierzyk
  • 318 postów

Napisano 21 sierpnia 2016 - 00:38

A czy ten TRIM jest potrzebny wszystkim dyskom SSD niebrandowanym przez Apple?

Mam akurat dysk INTEL w MBP i nie wiem czy powinienem tego użyć?

Znalazłem artykuł na ten temat:

http://www.makoweabc...a-ssd-pod-os-x/

I zaczynam mieć mętlik. :-(


Użytkownik Śfierzyk edytował ten post 21 sierpnia 2016 - 00:52

Błogosławieni, którzy nie mając nic do powiedzenia, nie ubierają tego w słowa.


#8 ciotka_paszczaka

ciotka_paszczaka
  • 1 051 postów

Napisano 21 sierpnia 2016 - 07:51

Generalnie, to, że jakiś pan z Kingstona coś gdzieś tam powiedział, to dotyczy zapewne dysków Kingstona. 

 

Tu przystępnie wyjaśnione z czym ten TRIM się w ogóle je i jaki ma wpływ na to aby szybkość dysku nie spadała z czasem jego użytkowania. Może i faktycznie niektórzy producenci wyposażają swoje dyski w jakieś super-duper systemy Garbage Collection, które są w stanie zastąpić działanie TRIM. No ale to chyba byś musiał poczytać w specyfikacji tego swojego Intela. 

 

Ja mam włączony TRIM na Samsungach 850 EVO. Napisane jak byk mają, że obsługują TRIM (mimo, że niby mają wbudowany też jakiś algorytm automatycznego oczyszczania pamięci). To włączyłem. Jakby miało to zły wpływ na dysk, to by się tym nie chwalili.


Użytkownik ciotka_paszczaka edytował ten post 21 sierpnia 2016 - 07:51

Nie czytam prywatnych wiadomości.


#9 jacekada

jacekada
  • 32 postów
  • SkądWarszawa

Napisano 21 sierpnia 2016 - 16:57

No i skończyło się tym, że mam naprawiony system.

Tak jak pisałem, nie miałem skąd wziąć pendrive instalacyjnego, ale miałem stary dysk z MacOs X 10.7 z partycją instalacyjną. Zrobiłem instalację na innym dysku. Co dziwne nie wiem jak ale zainstalowała się wersja 10.10. Jak już miałem dostęp do dysków, to z instalki Yosemite zrobiłem nadinstalację, potem update do 10.10.5 i nawet szybciej chodzi. Obyło się bez TM.

 

Teraz mam pytanie, czy mam jakimś innym sposobem włączyć trim na EVO 840, czy już to jest za duże ryzyko? Ponoć z Disk Sensei update 1.2 i Trim Enabler 3.1 efekt jest dobry i bez ryzyka.

 

Disabling kext signing is no longer necessary!
The “gray boot screen/stop sign” issue is gone!
Your system is no longer modified in any way!
Trim will no longer reset on updates!

 

Ale wolałbym nie być pierwszy...

Czy ktoś już próbował tymi narzędziami?

 

No i przy okazji mam pytanie jak usunąć system, który tymczasowo zainstalowałem? Niestety zdenerwowany i zmęczony nie pomyślałem o dodaniu partycji. Choć tak po prawdzie to teraz nie przypominam sobie, żeby gdzieś była ku temu okazja. Chodzi mi o sposób bez kasowania całej partycji.



#10 ciotka_paszczaka

ciotka_paszczaka
  • 1 051 postów

Napisano 21 sierpnia 2016 - 20:08

No i skończyło się tym, że mam naprawiony system.

Tak jak pisałem, nie miałem skąd wziąć pendrive instalacyjnego, ale miałem stary dysk z MacOs X 10.7 z partycją instalacyjną. Zrobiłem instalację na innym dysku. Co dziwne nie wiem jak ale zainstalowała się wersja 10.10. Jak już miałem dostęp do dysków, to z instalki Yosemite zrobiłem nadinstalację, potem update do 10.10.5 i nawet szybciej chodzi. Obyło się bez TM.

 

Teraz mam pytanie, czy mam jakimś innym sposobem włączyć trim na EVO 840, czy już to jest za duże ryzyko? Ponoć z Disk Sensei update 1.2 i Trim Enabler 3.1 efekt jest dobry i bez ryzyka.

 

Disabling kext signing is no longer necessary!
The “gray boot screen/stop sign” issue is gone!
Your system is no longer modified in any way!
Trim will no longer reset on updates!

 

Ale wolałbym nie być pierwszy...

Czy ktoś już próbował tymi narzędziami?

 

No i przy okazji mam pytanie jak usunąć system, który tymczasowo zainstalowałem? Niestety zdenerwowany i zmęczony nie pomyślałem o dodaniu partycji. Choć tak po prawdzie to teraz nie przypominam sobie, żeby gdzieś była ku temu okazja. Chodzi mi o sposób bez kasowania całej partycji.

 

Tak jak pisałem w pierwszej odpowiedzi. Od wersji 10.10.4 nie potrzebujesz żadnych osobnych narzędzi  do włączenia TRIM. Appple dodało włączanie TRIM dla dysków firm trzecich. Użyj polecenia w Terminalu:

sudo trimforce enable

dwa razy cię zapyta, potwierdź i komputer zostanie zrestartowany.

wyłączyć TRIM można tak samo:

sudo trimforce disable

System z drugiego dysku usuniesz po prostu kasując wszystkie foldery i pliki poza katalogiem /Users i folderami z czerwonym znaczkiem. Włącz sobie pokazywanie plików ukrytch 

w Terminalu:

defaults write com.apple.finder AppleShowAllFiles YES

potem restrart Findera

killall Finder

wyłączasz tak samo, tylko "NO" na końcu

Będziesz widział całą zawartość drugiego dysku z niepotrzebnym systemem. Zostaw foldery z czeronym znaczkiem i katalog /Users (Użytkownicy)  - tam jest twój katalog domowy zawierający wszystkie ewentualne pliki, biurko, Dokumenty itp.


Użytkownik ciotka_paszczaka edytował ten post 21 sierpnia 2016 - 20:56

Nie czytam prywatnych wiadomości.


#11 angelares

angelares
  • 856 postów
  • Skądona taka blada?

Napisano 23 sierpnia 2016 - 12:11

Tak jak pisałem w pierwszej odpowiedzi. Od wersji 10.10.4 nie potrzebujesz żadnych osobnych narzędzi  do włączenia TRIM. Appple dodało włączanie TRIM dla dysków firm trzecich. Użyj polecenia w Terminalu:

sudo trimforce enable

dwa razy cię zapyta, potwierdź i komputer zostanie zrestartowany.

wyłączyć TRIM można tak samo:

sudo trimforce disable

System z drugiego dysku usuniesz po prostu kasując wszystkie foldery i pliki poza katalogiem /Users i folderami z czerwonym znaczkiem. Włącz sobie pokazywanie plików ukrytch 

w Terminalu:

defaults write com.apple.finder AppleShowAllFiles YES

potem restrart Findera

killall Finder

wyłączasz tak samo, tylko "NO" na końcu

Będziesz widział całą zawartość drugiego dysku z niepotrzebnym systemem. Zostaw foldery z czeronym znaczkiem i katalog /Users (Użytkownicy)  - tam jest twój katalog domowy zawierający wszystkie ewentualne pliki, biurko, Dokumenty itp.

 

 

Potwierdzam. Trimforce wystarczy na 840stce. Mam postawiony fusiondrive i na yosemite mi się posypały uprawnienia. Zainstalowałem el capitan na świeżo i od tego czasu spokój.

 

Pozzdro, aa






Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych