Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Nie mogę otworzyć iPhoto w Finderze


  • Zaloguj się, aby dodać odpowiedź
26 odpowiedzi w tym temacie

#1 ted.one

ted.one
  • 119 postów

Napisano 07 października 2015 - 17:14

Problem chyba bardziej sytemowy niż soft'owy. 

 

1. Na Mavericks wykonałem kopię (cmd+c) biblioteki iTunes na dysk zewnętrzny. 

2. W ustawieniach iPhoto wybrałem aby biblioteka była odczytywana z tego dysku zewnętrznego. 

 

3. Gdy podłączam dysk zewnętrzny z biblioteką iPhoto do mac'a z Yosemite, to mam taki obraz:

 

ff1eb7485a09b68b.png

 

 

Folder iPhoto jest "szary", mogę na niego kliknąć - pokazuje info, ale nie mogę skopiować ani otworzyć.

 

iPhoto na Yosemite go nie widzi. 

 

Próbowałem podłączyć dysk do starego Mac'a, tego z Mavericks. Tam też ten folder jest szary, a iPhoto nie widzi biblioteki.

 

Będę wdzięczny za wszelką pomoc. To zdjęcia z wielu ostatnich lat. 



#2 Śfierzyk

Śfierzyk
  • 318 postów

Napisano 07 października 2015 - 19:12

A w folderze "Obrazki" nie masz przypadkiem kopii fotek z iPhoto?

 

Przy okazji z ciekawości zapytam, co to za rozszerzenia masz w górnym menu pomiędzy Copy a WiFi?


Błogosławieni, którzy nie mając nic do powiedzenia, nie ubierają tego w słowa.


#3 ted.one

ted.one
  • 119 postów

Napisano 07 października 2015 - 19:23

Nie mam. To jest inny komputer, nie ten, na którym pierwotnie znajdowało się iPhoto.

Sprawdziłem jednak jeszcze raz i na pewno nie mam. Jest tylko nowa biblioteka iPhoto (ta którą mam na dysku)

 

Odnośnie rozszerzeń, od lewej:

- Hazel - taki Automator 

- Karabiner - kiedyś miał inną nazwę, już zapomniałem jaką, dzięki niemu mam m.in. prawy alt pod prawym cmd

- Sophos Antivirus.



#4 ftpd

ftpd

    Nie.


  • 18 693 postów
  • SkądPoznań

Napisano 08 października 2015 - 11:56

Daj sobie r+w do tego katalogu, to nie będzie 'szary'.


---
Jestem Grammar Nazi. Nie znoszę błędów, leni, idiotów i hipsterów.
NIE pomagam przez PW. Mogę co najwyżej pogawędzić.
NIE odpisuję na wiadomości najeżone błędami. Nie chce mi się męczyć oczu.

#5 ted.one

ted.one
  • 119 postów

Napisano 08 października 2015 - 12:01

cmd+i - odczyt i zapis ? Jest zrobione - nadal nie działa...



#6 ted.one

ted.one
  • 119 postów

Napisano 08 października 2015 - 15:43

Mam nadzieję, że rozwiązanie z tą szarą biblioteką się znajdzie.

 

Jeżeli jednak nie, oto co właśnie robię:

1. podłączyłem dysk z iPhoto i odpaliłem program do odzyskiwania danych

2. odzyskuję teraz wszystkie zdjęcia i filmy na drugi dysk zewnętrzny.

 

Działa. Są zdjęcia, są filmy....... w gigantycznej strukturze katalogów... Czyli dane uratowane...

... ale jak pomyślę, że mam to teraz na nowo dodać do biblioteki... Nie wiem jak to zostanie pogrupowane, ale znając iPhoto nijak ;) 

 

Stąd pytanie: 

jak dodać kolosalną (!!!!) ilość zdjęć i filmów, rozrzuconych po setkach katalogów, do iPhoto aby nie zwariować ?



#7 cronopioverde

cronopioverde
  • 3 208 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 08 października 2015 - 17:40

Zmieniło Ci bibliotekę iPhoto na katalog (a nie „folder” :) ) jakimś cudem, więc program nie traktuje go jako biblioteki, bo niby dlaczego? Jeśli cała jego zawartość jest w nienaruszonym stanie, zrób następująco:
Zaznacz katalog (ten z Twojego pierwszego postu, nie ten odzyskany później), daj command-I, w „Nazwa i rozszerzenie” dopisz mu rozszerzenie .photolibrary i zatwierdź. Następnie przytrzymaj klawisz option i tak uruchom iPhoto. Poprosi o wskazanie biblioteki. Wybierz tę właśnie. Otwiera?


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na tekst bez liter diakrytyzowanych to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#8 ted.one

ted.one
  • 119 postów

Napisano 08 października 2015 - 19:48

Brzmi mądrze i sensownie ;) Sprawdzę jutro. Dysk zewnętrzny został w biurze. Dzięki. 



#9 ted.one

ted.one
  • 119 postów

Napisano 09 października 2015 - 13:09

Jest tak: faktycznie mogłem zrobić cmd+i, wpisać rozszerzenie ".photolibrary" po nazwie. 

Nic się nie zmieniło, ponad to, że:

- rubryka "nazwa i rozszerzenie" jest szara i nieaktywna,

- w ww. rubryce nadal jest tylko "iPhoto" - za to w zakładce u góry jest iphoto.photolibrary (!)

- pole "ukryj rozszerzenie" było i nadal jest odznaczone (bez ptaszka). 

 

Udostępnienia i uprawnienia: odczyt i zapis dla wszystkich. 

 

5705ee481a35b332.png



#10 cronopioverde

cronopioverde
  • 3 208 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 09 października 2015 - 13:19

Możesz podzielić się wynikiem komendy z Terminala

ls /Volumes

? Bo coś mi się tu widzi, że teraz z zamontowanego woluminu zrobiłeś .iphotolibrary, nie zaś z katalogu, który jest na nim :)


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na tekst bez liter diakrytyzowanych to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#11 ted.one

ted.one
  • 119 postów

Napisano 09 października 2015 - 13:21

To możliwe. 

 

ls /VolumesLast login: Tue Sep 29 12:11:44 on ttys000

MacBook-Marcin:~ Ted$ ls /Volumes

Macintosh HD iPhoto.photolibrary

MacBook-Marcin:~ Ted$ 1s /Volumes

-bash: 1s: command not found

MacBook-Marcin:~ Ted$ ls /Volumes

Macintosh HD iPhoto.photolibrary

MacBook-Marcin:~ Ted$ 

 

 

/edit

Faktycznie tak było. 

 

W takim razie nie mogę nadać rozszerzenia katalogowi "iphoto". Gdy na niego klikam, cmd+i jest szary i nieaktywny. Jak na zrzucie powyżej.


Użytkownik ted.one edytował ten post 09 października 2015 - 13:22


#12 cronopioverde

cronopioverde
  • 3 208 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 09 października 2015 - 13:30

Zmień sobie z powrotem nazwę woluminu na iPhoto (możesz to zrobić najzwyczajniej w świecie klikając na niego prawym przyciskiem myszy w pasku bocznym i wybierając „Zmień nazwę”), żeby nie komplikować dodatkowo. Po tej zmianie podziel się wynikiem komendy:

ls -le /Volumes/iPhoto/

I tym razem skopiuj i wklej stąd, proszę. To pozwoli Ci uniknąć literówki, jak powyżej z tym 1s.


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na tekst bez liter diakrytyzowanych to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#13 ted.one

ted.one
  • 119 postów

Napisano 09 października 2015 - 13:37

Nazwa została zmieniona. 

 

Terminal poniżej:

 

Last login: Fri Oct  9 14:36:25 on ttys000

MacBook-Marcin:~ Ted$ ls -le /Volumes/iPhoto/

total 0

drwxrwxrwx  4 Ted  staff  136 20 wrz 21:41 iPhoto

MacBook-Marcin:~ Ted$ 



#14 cronopioverde

cronopioverde
  • 3 208 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 09 października 2015 - 13:46

To jeszcze pośledźmy i zobaczmy wynik

ls -le /Volumes

Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na tekst bez liter diakrytyzowanych to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#15 ted.one

ted.one
  • 119 postów

Napisano 09 października 2015 - 14:19

Last login: Fri Oct  9 14:36:37 on ttys000

MacBook-Marcin:~ Ted$ ls -le /Volumes

total 8

lrwxr-xr-x  1 root  admin    1 27 wrz 21:22 Macintosh HD -> /

drwxrwxr-x  9 Ted   staff  374 23 maj  2014 iPhoto

MacBook-Marcin:~ Ted$ 



#16 cronopioverde

cronopioverde
  • 3 208 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 09 października 2015 - 14:28

Zatem spróbujmy sobie z tym fantem poradzić. Do poniższych komend będziesz potrzebował hasła administratora. Podczas jego wpisywania nie zobaczysz żadnych znaków, więc wpisuj uważnie, aby uniknąć pomyłki. Wklej po kolei poniższe komendy po jednej na raz, zatwierdzając returnem i hasłem administratora, kiedy Terminal o to poprosi:

sudo chown -R Ted:admin /Volumes/"iPhoto"

potem:

sudo chmod 755 /Volumes/"iPhoto"

Popatrz teraz w okno Informacji katalogu, o którym mowa. Czy nadal rubryka „Nazwa i rozszerzenie” jest nieaktywna?


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na tekst bez liter diakrytyzowanych to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#17 ted.one

ted.one
  • 119 postów

Napisano 09 października 2015 - 14:44

Robiłem powoli, bardzo uważałem. Kopiuj - wklej.

 

Wkleiłem pierwszą, poprosił o hasło, wpisałem hasło, kliknąłem enter. Nic się nie pojawiło. Nic nie zatwierdziło.

Wkleiłem drugą. Nic się nie pojawiło. Nic nie zatwierdziło.

 

Nadal nieaktywne w Finderze.



#18 cronopioverde

cronopioverde
  • 3 208 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 09 października 2015 - 14:48

Nic się nie powinno było pojawiać wizualnie jako efekt. To nie żaden błąd.

A co teraz pokazuje komenda

ls -le /Volumes

Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na tekst bez liter diakrytyzowanych to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#19 ted.one

ted.one
  • 119 postów

Napisano 09 października 2015 - 14:50

Last login: Fri Oct  9 15:42:08 on ttys000

MacBook-Marcin:~ Ted$ ls -le /Volumes

total 8

lrwxr-xr-x  1 root  admin    1 27 wrz 21:22 Macintosh HD -> /

drwxr-xr-x  9 Ted   staff  374 23 maj  2014 iPhoto

MacBook-Marcin:~ Ted$ 



#20 cronopioverde

cronopioverde
  • 3 208 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 09 października 2015 - 15:06

Zechcesz powtórzyć pierwszą z komend?

sudo chown -R Ted:admin /Volumes/"iPhoto"

I poczekaj aż jej działanie się zakończy i zobaczysz ponownie linijkę: MacBook-Marcin:~ Ted$

Wtedy znowu wpisz

ls -le /Volumes

i pokaż wynik, żeby sprawdzić, czy zadziałała.


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na tekst bez liter diakrytyzowanych to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#21 ted.one

ted.one
  • 119 postów

Napisano 09 października 2015 - 15:16

teraz dobrze ?

 

Last login: Fri Oct  9 15:50:09 on ttys000

MacBook-Marcin:~ Ted$ sudo chown -R Ted:admin /Volumes/"iPhoto"

Password:

MacBook-Marcin:~ Ted$ ls -le /Volumes

total 8

lrwxr-xr-x  1 root  admin    1 27 wrz 21:22 Macintosh HD -> /

drwxr-xr-x  9 Ted   staff  374 23 maj  2014 iPhoto

MacBook-Marcin:~ Ted$ 



#22 cronopioverde

cronopioverde
  • 3 208 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 09 października 2015 - 16:57

Dobra, zadziałała już wcześniej. Zaćma chwilowa, przepraszam za roztargnienie podczas próby zrobienia kilku rzeczy naraz :)

Popróbujmy zmienić mu nazwę nie przez Findera, tylko z Terminala:

sudo mv /Volumes/iPhoto/iPhoto /Volumes/iPhoto/Biblioteka\ iPhoto.photolibrary

(Znowu zatwierdzenie hasłem). Puszcza Cię teraz? Czy pokazuje coś w rodzaju "operation not permitted"?


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na tekst bez liter diakrytyzowanych to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#23 ted.one

ted.one
  • 119 postów

Napisano 09 października 2015 - 19:38

Udało się zmienić nazwę na "bibliotekaiphoto.photolibrary" (nadal jest "szare" po kliknięciu cmd+i).

 

Uruchomienie iPhoto z "alt" wskazało możliwą do wyboru bibliotekę iPhoto (tą nad którą pracujemy). Po jej wybraniu pojawił się komunikat: "nie można było otworzyć biblioteki, biblioteka nie została rozpoznana". 



#24 cronopioverde

cronopioverde
  • 3 208 postów
  • Płeć:
  • Skądprzytuptał nocą jeż?

Napisano 09 października 2015 - 20:03

W takim razie istnieje prawdopodobieństwo, że w trakcie tego kopiowania, które przeprowadziłeś z Mavericksa, uszkodziła się baza danych biblioteki. Zważywszy, że prawdopodobnie nie masz kopii zapasowej Time Machine pierwotnej biblioteki, bo w przeciwnym wypadku w ogóle nie podnosiłbyś tematu na forum, sprawa się nieco komplikuje. Możliwe, że zostanie Ci, tak jak wcześniej zauważyłeś, dodawanie ponownie odzyskanych zdjęć do iPhoto (jak to opisałeś w poście #6), ale to żmudna i czasochłonna robota, więc nie zaszkodzi wcześniej spróbować innej „deski ratunku”, którą znam (może inni forumowicze zasugerują jeszcze coś, w końcu to otwarte forum, nie musimy tu gadać tylko we dwóch  :D ):
Pobierz sobie wersję darmową tego programiku. Jeśli nie zobaczysz swojej biblioteki na liście po lewej, dodaj ją ręcznie z menu File > Add Library > Choose manually… (lewy dolny róg). Może być, że program już rozpozna ją i otworzy, może też być, że nie. Tak czy inaczej, żeby odbudować bazę danych, użyj menu Library > Rebuild Library… 

Stworzy to nową kopię istniejącej biblioteki o prawidłowej strukturze rozpoznawalnej przez iPhoto. Nazwij ją jak chcesz lub zostaw nazwę Biblioteka… (rebuilt), wedle uznania. Zachowaj ją gdzieś, gdzie masz wystarczająco dużo miejsca, bo jej rozmiar będzie porównywalny z tą już istniejącą, której nie możesz otworzyć (czyli gdzieś koło 95 GB). Cały proces potrwa nieco, to w końcu sporo danych do zapisania. Po zakończeniu wskaż aplikacji iPhoto tę nową, przebudowaną bibliotekę i… trzymamy kciuki! :)
Jeśli wszystko się powiedzie i zdjęcia będą w komplecie, starą usuń, by niepotrzebnie nie zajmowała miejsca.

Jeśli się nie powiedzie, licz na pomysłowość i wiedzę innych forumowiczów albo w ostateczności dodawaj wszystko z powrotem ręcznie, choć nie życzę.

Powodzenia.


Po pierwsze: na priv mogę zbereźne żarty poopowiadać, pomagam na forum.

Po drugie: brak mojej odpowiedzi na tekst bez liter diakrytyzowanych to wybór purysty. Z tym się nie walczy.
Po trzecie: postawy roszczeniowe zostawiamy dla BOK.
Zmian traffic lights nie przewiduję…


#25 ted.one

ted.one
  • 119 postów

Napisano 13 października 2015 - 14:34

iPhoto Library Manager nie działa. Chyba wiem dlaczego. Od czasu Yosemite nie ma iPhoto - jest Photos :/

 

Apple tutoriale mówią, że migracja winna nastąpić automatycznie - klikając z altem - Photos powinno odczytać moje iPhoto. Sorry, ale nie tym razem, Apple. 

 

Szkoda, niestety czeka mnie żmudne przenoszenie. 

 

Jeszcze większa szkoda, że nie jestem jedynym, którym ciągły aplowski pęd do nowości i apdejtowania niszczy wizerunek solidnej marki.

Za każdym bowiem razem jest "coś". Albo sterowniki, albo bateria, albo gesty, skróty. You name it. 

 

cronopioverde

bardzo dziękuję za pomoc.






Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych