Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Wyłączanie się MacBooka po odłączeniu wtyczki magsafe


Najlepsza odpowiedź tumpio , 03 grudnia 2014 - 20:32

Tajemnicze zachowanie maca zostało wyjaśnione  -  najprostsze rozwiązanie - uszkodzony zasilacz (prawdopodobnie podróbka).

Przejdź do postu


  • Zaloguj się, aby dodać odpowiedź
13 odpowiedzi w tym temacie

#1 Deryk

Deryk
  • 18 postów

Napisano 01 grudnia 2014 - 14:16

Cześć, od niedawna mam problem z moim MBP 13 mid 2009, 4GB RAM, 160 GB HD, OsX 10.10.1. Otóż, komputer wyłącza się gdy odpinam wtyczkę ładowarki w momencie ładowania (dioda swieci na pomarańczowo).
Po takim wyłączeniu sie Maca muszę odczekać chwile nim go mogę znów włączyć. no i problem mam wtedy z zasilaczem, nie ładuje (nie pali się dioda), i dopiero po którymś podłączeniu, i kombinowaniu z kierunkiem podłączenia wtyczki (choć to nie powinno mieć przecież znaczenia) magsafe zaczyna działać.
Jeden jedyny raz po takim wyłączeniu się maca i ponownym włączeniu systemu, osx pokazywał że nie wykrywa baterii (mimo że działał wtedy na baterii).
Wtedy zrobiłem restart SMC i PRAM i wszystko wróciło do normy, bateria znowu widoczna. no ale niestety mac nadal się wyłącza jak odepne wtyczkę.
Ma ktoś pomysł o co tu chodzi? Czy ktoś z was spotkał sie z takim problemem? Zanim wybiorę sie do serwisu chciałbym poznać waszą opinie.

#2 cubasz

cubasz
  • 1 636 postów
  • SkądSzczotkolm - Wawa

Napisano 01 grudnia 2014 - 15:33

Pierwsza rzecz to dokładnie oczyść wtyczkę i gniazdo. Druga to pożycz/kup dobrą baterię i wypróbuj z nią. 


Tylko spokój może nas uratować ;-)


#3 Deryk

Deryk
  • 18 postów

Napisano 01 grudnia 2014 - 16:12

Ok, spróbuje, przynajmniej tą pierwszą rzecz. a czym to wyczyścić?

co do próby na dobrej baterii to już raczej jakiś serwis mi to sprawdzi. Czyli podejrzewasz baterię, w innym dziale ktoś mi napisał że to pewnie płyta główna.

 

Ciekaw jestem co też faktycznie mu dolega...



#4 cubasz

cubasz
  • 1 636 postów
  • SkądSzczotkolm - Wawa

Napisano 01 grudnia 2014 - 20:51

Spirytusem (najlepiej polipropylenowym ale może buyć i wódka) i patyczkiem do uszu. Odłącz prąd przy czyszczeniu wtyku. Obejrzyj czy piny się uginają na sprężynkach. Gniazdo może mieć złogi wokół kontaktów. Nie skrob za mocno bo oderwiesz powłokę z plastiku.

 

A jak światełka na baterii? Diody się świecą jak powinny? 


Użytkownik cubasz edytował ten post 01 grudnia 2014 - 20:52

Tylko spokój może nas uratować ;-)


#5 Deryk

Deryk
  • 18 postów

Napisano 01 grudnia 2014 - 21:22

przeczyściłem, było trochę brudu, piny się uginają i wyglądają na zdrowe. Niestety, nadal przy pomarańczowej diodzie mac się wyłącza.

 

diody baterii, te zielone z boku wskazują prawidłowy poziom baterii, przy 80% dwie się nie paliły, przy ładowaniu 7-ma miga, czyli wygląda że ok, dioda biała z przodu też prawidłowo. oddycha przy uśpieniu.

 

dziś jeszcze sprawdzę czy przy pełnym naładowaniu, wypięcie wtyczki spowoduje zgon maca.


Użytkownik Deryk edytował ten post 01 grudnia 2014 - 21:54


#6 tumpio

tumpio

    SERWIS


  • 6 245 postów
  • Płeć:
  • SkądWarszawa

Napisano 01 grudnia 2014 - 22:07

Możesz mieć uszkodzoną detekcję baterii, tzn mac ją widzi prawidłowo, ładuje, ale nie jest w stanie pobrać z niej prądu. To uszkodzenie może blokować SMC i przez to masz problemy z działaniem magsafe.


Specjalistyczny Serwis Komputerów Apple "Serwis Jabłek®"
ul. Stryjeńskich 10 lok usł 2A.
02-791 Warszawa tel: 533-996-563 lub 796-440-048
http://www.macbook-service.com

#7 Deryk

Deryk
  • 18 postów

Napisano 01 grudnia 2014 - 22:13

Możesz mieć uszkodzoną detekcję baterii, tzn mac ją widzi prawidłowo, ładuje, ale nie jest w stanie pobrać z niej prądu. To uszkodzenie może blokować SMC i przez to masz problemy z działaniem magsafe.

możesz napisać ile by mnie kosztowała naprawa, jeżeli to padła detekcja o której piszesz?

 

no i to trochę dziwne że nie potrafi pobrać z baterii prądu, bo działa na niej około 4 godzin bez żadnych problemów.

jak się wyłącza to mogę go spokojnie uruchomić na baterii i normalnie pracować.


Użytkownik Deryk edytował ten post 01 grudnia 2014 - 22:18


#8 tumpio

tumpio

    SERWIS


  • 6 245 postów
  • Płeć:
  • SkądWarszawa

Napisano 01 grudnia 2014 - 22:40

Abym dobrze zrozumiał:

  1. Macbook pracuje normalnie na baterii.
  2. Podłączasz zasilacz, ładujesz baterię i po odłączeniu zasilacza masz problem.

Jeśli tak to nadal twierdzę, że problem leży w detekcji baterii w sekcji SMC. Normalna praca na baterii praktycznie wyklucza charger (on przełącza zasilanie). Sprawdź jeszcze przy naładowaniu ok. 40-50% czy maczycho wstaje tylko na baterii (do pełnego zgłoszenia systemu).


Specjalistyczny Serwis Komputerów Apple "Serwis Jabłek®"
ul. Stryjeńskich 10 lok usł 2A.
02-791 Warszawa tel: 533-996-563 lub 796-440-048
http://www.macbook-service.com

#9 Deryk

Deryk
  • 18 postów

Napisano 01 grudnia 2014 - 22:46

Abym dobrze zrozumiał:

  1. Macbook pracuje normalnie na baterii.
  2. Podłączasz zasilacz, ładujesz baterię i po odłączeniu zasilacza masz problem.

Jeśli tak to nadal twierdzę, że problem leży w detekcji baterii w sekcji SMC. Normalna praca na baterii praktycznie wyklucza charger (on przełącza zasilanie). Sprawdź jeszcze przy naładowaniu ok. 40-50% czy maczycho wstaje tylko na baterii (do pełnego zgłoszenia systemu).

1. zgadza się, pracuje.

2. tak

 

przed chwilą naładowałem baterie, odłączyłem wtyczkę gdy komputer był uśpiony i się nie wyłączył. obudziłem więc go, podłączam wtyczkę i mac nie widzi ładowarki.

co do Twojego pytania, to maczek wstaje na baterii nawet przy 25 %.



#10 tumpio

tumpio

    SERWIS


  • 6 245 postów
  • Płeć:
  • SkądWarszawa

Napisano 01 grudnia 2014 - 22:50

To wyklucza także baterię. Nie pozostaje Ci nic innego jak przejść się do jakiegoś serwisu i niech zobaczą gdzie maca boli...

 

P.S. Na wszelki wypadek podmień ładowarkę, choć opisane objawy nie wskazują na nią...


Specjalistyczny Serwis Komputerów Apple "Serwis Jabłek®"
ul. Stryjeńskich 10 lok usł 2A.
02-791 Warszawa tel: 533-996-563 lub 796-440-048
http://www.macbook-service.com

#11 Deryk

Deryk
  • 18 postów

Napisano 01 grudnia 2014 - 22:59

To wyklucza także baterię. Nie pozostaje Ci nic innego jak przejść się do jakiegoś serwisu i niech zobaczą gdzie maca boli...

 

P.S. Na wszelki wypadek podmień ładowarkę, choć opisane objawy nie wskazują na nią...

 

własnie zauważyłem coś dziwnego. otóż:

 

1. gdy ładowarka jest podłączona do prądu i do maca i swięci się na pomarańczowo - odpięcie wtyki magsafe powoduje wyłączenie się maca

2. gdy ładowarka jest podłączona do prądu i do maca i swięci się na pomarańczowo - odpięcie nie wtyki a ładowarki z gniazdka nie powoduje wyłączenia maca, działa normalnie

3. gdy ładowarka jest podłączona do prądu i do maca i swięci się na zielono - odpięcie wtyki nie powoduje wyłączenia się maca, działa normalnie

 

Podłączenie najpierw ładowarki do gniazdka a potem do maca powoduje że mac nie widzi ładowarki, natomiast gdy wepnę najpierw magsafe do maca a potem do gniazdka to mac widzi ładowarkę. hm czy to oznacza że ładowarka to podróba?

Ale to i tak chyba nie wyjaśnia czemu mac się wyłącza, chyba...



#12 tumpio

tumpio

    SERWIS


  • 6 245 postów
  • Płeć:
  • SkądWarszawa

Napisano 01 grudnia 2014 - 23:11

(...)1. gdy ładowarka jest podłączona do prądu i do maca i swięci się na pomarańczowo - odpięcie wtyki magsafe powoduje wyłączenie się maca

2. gdy ładowarka jest podłączona do prądu i do maca i swięci się na pomarańczowo - odpięcie nie wtyki a ładowarki z gniazdka nie powoduje wyłączenia maca, działa normalnie

3. gdy ładowarka jest podłączona do prądu i do maca i swięci się na zielono - odpięcie wtyki nie powoduje wyłączenia się maca, działa normalnie(...)

 

Ad.1 - natychmiastowe odłączenie prądu od laptopa - laptop nie jest w stanie przełączyć się na zasilanie baterii.

Ad.2 - odłączenie zasilacza od sieci - jeszcze kilka sekund masz podtrzymanie napięcia na wtyczce (dopóki kondensator się nie rozładuje) - widać wystarczające aby przełączył zasilanie.

 

Po w/w wpisie prawdopodobne jest też uszkodzenie tranzystora wykonawczego ładownia - zwyczajnie przywiesza się. Niech Ci to ktoś ogarnie - możliwości uszkodzenia jest kilka a im dalej w las tym więcej ich dochodzi ;)


Specjalistyczny Serwis Komputerów Apple "Serwis Jabłek®"
ul. Stryjeńskich 10 lok usł 2A.
02-791 Warszawa tel: 533-996-563 lub 796-440-048
http://www.macbook-service.com

#13 Deryk

Deryk
  • 18 postów

Napisano 01 grudnia 2014 - 23:19

Ad.1 - natychmiastowe odłączenie prądu od laptopa - laptop nie jest w stanie przełączyć się na zasilanie baterii.

Ad.2 - odłączenie zasilacza od sieci - jeszcze kilka sekund masz podtrzymanie napięcia na wtyczce (dopóki kondensator się nie rozładuje) - widać wystarczające aby przełączył zasilanie.

 

Po w/w wpisie prawdopodobne jest też uszkodzenie tranzystora wykonawczego ładownia - zwyczajnie przywiesza się. Niech Ci to ktoś ogarnie - możliwości uszkodzenia jest kilka a im dalej w las tym więcej ich dochodzi ;)

 

ponieważ to co piszesz wydaje się logiczne najprawdopodobniej zgłoszę się do Ciebie .

Mógłbyś do mnie napisać na priv jakie to mogą być koszty?  



#14 tumpio

tumpio

    SERWIS


  • 6 245 postów
  • Płeć:
  • SkądWarszawa

Napisano 03 grudnia 2014 - 20:32   Najlepsza odpowiedź

Tajemnicze zachowanie maca zostało wyjaśnione  -  najprostsze rozwiązanie - uszkodzony zasilacz (prawdopodobnie podróbka).


  • cubasz lubi to
Specjalistyczny Serwis Komputerów Apple "Serwis Jabłek®"
ul. Stryjeńskich 10 lok usł 2A.
02-791 Warszawa tel: 533-996-563 lub 796-440-048
http://www.macbook-service.com




Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych