Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

Problem z Eclipse 4.4 (Luna) i JVM


  • Zaloguj się, aby dodać odpowiedź
2 odpowiedzi w tym temacie

#1 expressbits

expressbits
  • 1 postów

Napisano 26 czerwca 2014 - 20:22

Dzień dobry. Mam problem uruchomieniem Eclipse dla C++. Otóż pobrałem Eclipse IDE for C/C++ Developers ( Eclipse 4.4 [Luna] ) wersję dla Mac OS X 64 Bits ze strony projektu (eclipse.org) i zainstalowałem JRE 8 update 5 (build 1.8.0_05-b13) dla OS X. I gdy próbuję uruchomić Eclipse to otrzymuję monit (okno zatytułowane "Incompatible JVM") o treści " Version 1.6.0_65 of the JVM is not suitable for this product. Version: 1.7 or greater is required. " . I co mam teraz zrobić, aby uruchomić to środowisko programistyczne?

#2 drake29a

drake29a
  • 42 postów

Napisano 26 czerwca 2014 - 20:25

Zainstaluj JRE7 lub 6, możliwe że Eclipse nie jest jeszcze kompatybilne z Javą 8:)

#3 mkuleszoss

mkuleszoss
  • 4 postów

Napisano 08 lipca 2014 - 19:47

Luna została wydana z głównym hasłem kompatybilności z v.8 Javy. U mnie działa bez problemu. Stawiam, że kolega ma zainstalowaną Javę od Apple i ona jest ustawiona jako domyślna. Należałoby zmienić na wersję 8. Aby to zrobić należy w terminalu (podmień jdk1.7.0_21.jdk na wersję którą ty masz): > cd /System/Library/Frameworks/JavaVM.framework/Versions/ > rm Current > ln -s /Library/Java/JavaVirtualMachines/jdk1.7.0_21.jdk/Contents/ Current > java -version




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych