Skocz do zawartości

Witaj!

Zaloguj lub Zarejestruj się aby uzyskać pełny dostęp do forum.

Zdjęcie
- - - - -

MacBook Pro mid 2009 + 2x 4GB Ram = Kernel Panic


  • Zaloguj się, aby dodać odpowiedź
22 odpowiedzi w tym temacie

#1 konrado0905

konrado0905
  • 361 postów

Napisano 29 czerwca 2012 - 15:24

Witam. Czy ktoś spotkał się z takim problemem? Problem występuje np. podczas grania w Diablo 3. Na jednej kości (sprawdzałem obie jak i oba sloty) 4GB nie ma żadnych problemów. Przeszedłem trial Diablo 3 i ani jednego Kernel Panica. Gdy włożyłem obie kości, po 3 misji wyskoczył Kernel Panic. Mac: MacBook Pro mid 2009 Ram: 2x PATRIOT PSD34G13332S 4GB 1333MHz System: Lion Ram testowany, zero błędów.

#2 adimg19

adimg19
  • 300 postów
  • SkądWładysławowo, PL

Napisano 29 czerwca 2012 - 16:14

Masz złe kości pamięci. Ten macbook powinien mieć kości 1066Mhz. Dziwne, że wogóle ruszyły, bo mam mid 2010 i mój macbook nawet nie ruszył z pamięciami 1333

#3 virgin71

virgin71



  • 12 556 postów
  • SkądWrocław

Napisano 29 czerwca 2012 - 16:15

Czym testowany RAM? Bo na kilometr widać, że to wina ramu. Można dokładny hardware test zapuścić i wtedy jest odpowiedź, czy to wina ramu. Testy po 5 minut nie wykryją błędów. Nie masz jednej kości 1067?

#4 konrado0905

konrado0905
  • 361 postów

Napisano 29 czerwca 2012 - 16:40

Masz złe kości pamięci. Ten macbook powinien mieć kości 1066Mhz. Dziwne, że wogóle ruszyły, bo mam mid 2010 i mój macbook nawet nie ruszył z pamięciami 1333


Ram sam się dostosowuje do prędkości i działa na maksymalnej prędkości szyny (czyli 1067MHz).


Czym testowany RAM? Bo na kilometr widać, że to wina ramu. Można dokładny hardware test zapuścić i wtedy jest odpowiedź, czy to wina ramu. Testy po 5 minut nie wykryją błędów.

Nie masz jednej kości 1067?


MemTest i Remember. Tylko jak by były walnięte to by się wykrzaczył na którejś pojedynczej, a tak wykrzacza się tylko, jak obie są wsadzone.

#5 adimg19

adimg19
  • 300 postów
  • SkądWładysławowo, PL

Napisano 29 czerwca 2012 - 16:41

W normalnym laptopie moze i tak, ale maci wymagaja pamieci dedykowanych i jesli obsluguja 1066 to takie byc powinny

#6 konrado0905

konrado0905
  • 361 postów

Napisano 29 czerwca 2012 - 17:09

Masz na to jakieś źródło?

#7 adimg19

adimg19
  • 300 postów
  • SkądWładysławowo, PL

Napisano 29 czerwca 2012 - 17:25

Nie mam. Jedynie 5-letnie doświadczenie w salonie komputerowym z serwisem. Jeśli dany laptop wg producenta pamięci wymaga pamięci dedykowanych, to lepiej takie montować, a przynajmniej o takich samych parametrach, bo bywa, choć nie zawsze, że inne pamięci powodują niebieskie ekrany lub kernel panic albo po prostu komputer z nimi wogóle się nie uruchamia. Niestety nieraz się zdarzało, że musieliśmy zamawiać pamięci dedykowane, bo "uniwersalne" powodowały problemy. PS. Może przesadziłem ze słowem "wymagają"... po prostu są mocno zalecane.

#8 konrado0905

konrado0905
  • 361 postów

Napisano 29 czerwca 2012 - 17:29

Tylko dlaczego wykrzacza się tylko jak są dwie wsadzone?

#9 adimg19

adimg19
  • 300 postów
  • SkądWładysławowo, PL

Napisano 29 czerwca 2012 - 17:33

No i to jest właśnie to o czym pisałem. Skoro nie są to zalecane pamięci, to niestety trzeba się liczyć z tym, że mogą być problemy. Jak masz możliwość to dogadaj się z jakimś sklepem komputerowym na możliwość przetestowania pamięci 1066. Najwyżej te, które masz sprzedasz, a kupisz zalecane.

#10 franz84

franz84
  • 238 postów

Napisano 29 czerwca 2012 - 18:50

sprawdź na innym kompie jak możesz. mogły się zdarzyć uszkodzone moduły. Działać powinny to nie PPC :P każdy ram ma w SPD zapisane parametry w których ma się ustawić - btw da się to nawet edytować. Ludzie piszą że na mac-u mini 2010 schodzą tak jak przewidział to producent do 1066 i wtedy timing jest 7 a nie 9 :)

Jak obsadzisz jeden slot 1066 a drugi 1333 MHz to raczej nie ruszą właśnie przez ustawienia timingów.


UPDATE:
Pechowo twój laptop posiada błąd polegający na tym że nie obniża taktowania ramu. Poniżej historyjka + filmik + instrukcja. Potrzebny będzie bootcamp z windowsem ;) Jakby co robisz na własne ryzyko.

http://tylermilner.com/?p=342

#11 konrado0905

konrado0905
  • 361 postów

Napisano 29 czerwca 2012 - 19:55

sprawdź na innym kompie jak możesz. mogły się zdarzyć uszkodzone moduły. Działać powinny to nie PPC :P każdy ram ma w SPD zapisane parametry w których ma się ustawić - btw da się to nawet edytować. Ludzie piszą że na mac-u mini 2010 schodzą tak jak przewidział to producent do 1066 i wtedy timing jest 7 a nie 9 :)

Jak obsadzisz jeden slot 1066 a drugi 1333 MHz to raczej nie ruszą właśnie przez ustawienia timingów.


UPDATE:
Pechowo twój laptop posiada błąd polegający na tym że nie obniża taktowania ramu. Poniżej historyjka + filmik + instrukcja. Potrzebny będzie bootcamp z windowsem ;) Jakby co robisz na własne ryzyko.

How to Install 8GB RAM in 2010 MacBook Pro Without It Freezing | tylermilner.com


Co powiesz na to, że dzisiaj wsadziłem 2GB 1066MHz + 4GB 1333MHz i wszystko chodziło? ;) Tylko już nie chciało mi się grać w Diablo, a to jedyny znany mi sposób żeby spowodować Kernel Panic xD

Jak sprawdzić czy faktycznie częstotliwość i timing nie są obniżone?

#12 zgagato

zgagato
  • 114 postów
  • Skąd3miasto

Napisano 29 czerwca 2012 - 20:09

Niektore Komputery z GeForce 9400 obsluguja kosci 1333 bez problemu, inne nie. Trzeba to sprawdzic na danym egzemplarzu. Z mojego doswiadczenia wynika ze wiekszosc je obsluguje ale np mialem 3 macbooki 13 Alu nie Pro Late 2008 2.4Ghz i 2 obslugiwaly po 2 kosci 1333 (w sumie 4 i 8 GB) a 1 identyczny, obslugiwal tylko pojedyncza kosc 1333, 2 slot musial byc pusty lub z koscia 1066 i wtedy bylo ok. Wtedy najlatwiej wlozyc wolniejsze kostki. Modele z GF320 czyli 2010 z kostkami 1333 nie pracuja wcale i tez trzeba albo wkladac te wolniejsze albo 1 taka a druga wolniejsza. Mialem tez raz Bialego MB unibody 2009 2.26 ktory 1333 tez nie lubil.

#13 franz84

franz84
  • 238 postów

Napisano 29 czerwca 2012 - 20:09

Co powiesz na to, że dzisiaj wsadziłem 2GB 1066MHz + 4GB 1333MHz i wszystko chodziło? ;) Tylko już nie chciało mi się grać w Diablo, a to jedyny znany mi sposób żeby spowodować Kernel Panic xD

Jak sprawdzić czy faktycznie częstotliwość i timing nie są obniżone?


super czyli jest tak jak w tym artykule jak masz jedna kosc 1066 i jedna 1333 to komputer ustawia na 1066 i działa wszystko jak masz dwie 1333 to próbuje wystartować z 1333 i dostaje kernel panic bo chipset nie obsługuje takiej częstotliwości, co prawda jest tablica timmingów ale apple skopało sprawę :) pozostaje ci przeflaszowanie jednej kostki 4GB 1333 na 1066 wg instrukcji którą ci podałem i wygląda że będziesz miał luz. Tak wogle na tym polega tworzenie przez producenta pamięci dedykowanych, daje się specyficzne wartości poszczególnych opóźnień testuje itp, pakuje w ładne pudełko i proszę bardzo.


EDIT:
Raport systemowy i możesz sprwdzić czestotliwość w zakładce pamięć. Timmingi pod osx nie wiem jak sprawdzić. Pod windowsem lub linuxem bez problemu są do tego programy i jest bios :)

#14 konrado0905

konrado0905
  • 361 postów

Napisano 29 czerwca 2012 - 20:12

Najz. Dzięki, będę miał się wreszcie czym pobawić ;) Jak myślisz, bezpiecznie będzie to robić na wirtualnej maszynie?

#15 franz84

franz84
  • 238 postów

Napisano 29 czerwca 2012 - 20:23

Najz. Dzięki, będę miał się wreszcie czym pobawić ;)

Jak myślisz, bezpiecznie będzie to robić na wirtualnej maszynie?


Raczej bootowalny windows lub bootcamp na wirtualnej nie da rady bo tam jest tak jakby emulacja poszczególnego sprzętu np przydzielasz 2GB ramu ale nie wiadomo z której konkretnie kości itp.

Zainspirowałem się i zamówiłem właśnie sobie do mojego macbooka 2008 pamięć 2x4GB 1333, więc też się pobawię o ile nie pójdzie samo z siebie :)

#16 konrado0905

konrado0905
  • 361 postów

Napisano 29 czerwca 2012 - 20:25

Jak to zrobię, to zdam relacje ;)

#17 virgin71

virgin71



  • 12 556 postów
  • SkądWrocław

Napisano 29 czerwca 2012 - 20:59

Jak obsadzisz jeden slot 1066 a drugi 1333 MHz to raczej nie ruszą właśnie przez ustawienia timingów.

Nie prawda. Mam doświadczenie z Makami. Komputery z kościami 1067 + 1333 działają aż do wykrzaczenia (ale 1067 musi być w banku0). Jeśli wkładasz do maka 1067 2x1333 i się włączy, to się wykrzaczy. Niestety konrado, Twoja teoria jest nieprawdziwa. W sklepach wciskają kit, że ram się dostosuje. Otóż nie, niby się dostosuje, ale wysypie błędami. Oni bazują na Windowsowych userach, gdzie taka sytuacja spowoduje zawieszkę lub wykrzaczenie się programu. Niestety UNIX zrobi kernel panic w tej samej sytuacji. Typowy Linux by się nie włączył.

Idę o piwo, że zakończy się to wszystko zmianą ramu na 1067. Tak mówi mi 5-letnie doświadczenie z Makami. Dokładnie tak samo było w 2006 roku, jak Apple wypuszczało 667, a ludzie się nabierali w sklepach "u mnie taniej" na chwyt, że 800 się dostosuje. :) Wtedy były prawdziwe żniwa na, co tu ukrywać, frajerach z kingstonami.

Cytując mojego ojca, po kolejnej zawieszce, po zmianie ramu: "się zesra, a nie dostosuje".

#18 konrado0905

konrado0905
  • 361 postów

Napisano 29 czerwca 2012 - 21:05

Ręcznie zmienię częstotliwość i zobaczymy czy będzie banglać

#19 franz84

franz84
  • 238 postów

Napisano 29 czerwca 2012 - 22:56


Idę o piwo, że zakończy się to wszystko zmianą ramu na 1067. Tak mówi mi 5-letnie doświadczenie z Makami. Dokładnie tak samo było w 2006 roku, jak Apple wypuszczało 667, a ludzie się nabierali w sklepach "u mnie taniej" na chwyt, że 800 się dostosuje. :) Wtedy były prawdziwe żniwa na, co tu ukrywać, frajerach z kingstonami.

Cytując mojego ojca, po kolejnej zawieszce, po zmianie ramu: "się zesra, a nie dostosuje".


najwyżej zmieni hexy w obu kościach na 1066MHz CL7 i będzie ok :) tu nie ma tak jakby ram nic do tego bo kości jako takie są w stanie pracować na niższych ustawieniach bez łaski to że się nie przestawiają jest tylko winą apple (jak zwykle zresztą)

Problemy dotyczy:

THE LIST OF AFFECTED APPLE MACBOOK PRO LAPTOPS
* Macbook Pro (13-inch, 2009) w/ NVIDIA MCP79
* Macbook Pro (15-inch, 2009) w/ NVIDIA MCP79
* Macbook Pro (17-inch, 2009) w/ NVIDIA MCP79
* Macbook Pro (13-inch, Mid 2010) w/ NVIDIA MCP89

#20 virgin71

virgin71



  • 12 556 postów
  • SkądWrocław

Napisano 30 czerwca 2012 - 17:40

Wszystkie Maki są affected:)

#21 konrado0905

konrado0905
  • 361 postów

Napisano 13 lipca 2012 - 05:56

No i niestety. Nakombinowałem się jak koń pod górkę, a okazało się, że mój RAM ma zabezpieczenie PSWP. Oznacza to, że nie mogę przeprogramować (przynajmniej za pomocą softu) SPD. Pozostaje mi tylko wymiana RAMu...

#22 virgin71

virgin71



  • 12 556 postów
  • SkądWrocław

Napisano 13 lipca 2012 - 07:53

Ręcznie zmienię częstotliwość i zobaczymy czy będzie banglać


No i niestety. Nakombinowałem się jak koń pod górkę, a okazało się, że mój RAM ma zabezpieczenie PSWP. Oznacza to, że nie mogę przeprogramować (przynajmniej za pomocą softu) SPD. Pozostaje mi tylko wymiana RAMu...

Czyli tak jak w przypadku większości kości. Oznacza to dokładnie to co napisałem - wymiana RAM:)

#23 franz84

franz84
  • 238 postów

Napisano 13 lipca 2012 - 17:21

No i niestety. Nakombinowałem się jak koń pod górkę, a okazało się, że mój RAM ma zabezpieczenie PSWP. Oznacza to, że nie mogę przeprogramować (przynajmniej za pomocą softu) SPD. Pozostaje mi tylko wymiana RAMu...



no zdaża się generalnie spd w wielu przypadkach tylko utrudnia, czytałem że jeden koleś specjalnie sobie nawet wylutował ten moduł:)...
U mnie w każdym razie śmiga na 1333 bez problemu, 100% stabilnie. Pamięci Nanya 2x4GB, także nawet nie edytowałem spd bo zadziałało od razu. oczywiście to że wyświetla się 1333 jest błędem EFI, chodzą zgodnie z magistrala chipsetu na 1066. A wyświetla się domyślny profil z SPD (w sumie na tych kościach są zapisane 4 profile ustawień)

Dołączona grafika

Dołączona grafika

a kernel panic dostajesz tylko w diablo 3 ? bo jak tak to nie jesteś sam:

http://us.battle.net...opic/5149535853




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych